Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Problem running Mwe2 worflow(error appears when i run the Mwe2 file as a MWE2 workflow)
Problem running Mwe2 worflow [message #875277] Tue, 22 May 2012 13:08 Go to next message
frank fotso is currently offline frank fotsoFriend
Messages: 91
Registered: May 2012
Member
hi,

when i generate a xtext file(grammar) from an ecore model and i want to run the
.Mwe2 file as a MWE2 workflow i have the followin error :

 0    [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Registering platform uri 'D:\frank\workspace'
188  [main] ERROR mf.mwe2.launch.runtime.Mwe2Launcher  - Problems instantiating module org.xtext.example.Project2: java.lang.reflect.InvocationTargetException
java.lang.RuntimeException: Problems instantiating module org.xtext.example.Project2: java.lang.reflect.InvocationTargetException
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:90)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:73)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:64)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:55)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:74)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:35)
Caused by: org.eclipse.emf.common.util.WrappedException: java.lang.reflect.InvocationTargetException
	at org.eclipse.emf.mwe2.language.factory.SettingProviderImpl$1$1.setValue(SettingProviderImpl.java:56)
	at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.internalApplyAssignments(Mwe2ExecutionEngine.java:143)
	at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.inCase(Mwe2ExecutionEngine.java:114)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.eclipse.xtext.util.PolymorphicDispatcher.invoke(PolymorphicDispatcher.java:291)
	at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.internalSwitch(Mwe2ExecutionEngine.java:66)
	at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.internalApplyAssignments(Mwe2ExecutionEngine.java:142)
	at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.inCase(Mwe2ExecutionEngine.java:114)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.eclipse.xtext.util.PolymorphicDispatcher.invoke(PolymorphicDispatcher.java:291)
	at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.internalSwitch(Mwe2ExecutionEngine.java:66)
	at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.inCase(Mwe2ExecutionEngine.java:80)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.eclipse.xtext.util.PolymorphicDispatcher.invoke(PolymorphicDispatcher.java:291)
	at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.internalSwitch(Mwe2ExecutionEngine.java:66)
	at org.eclipse.emf.mwe2.language.factory.Mwe2ExecutionEngine.create(Mwe2ExecutionEngine.java:62)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:88)
	... 5 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.eclipse.emf.mwe2.language.factory.SettingProviderImpl$1$1.setValue(SettingProviderImpl.java:54)
	... 30 more
Caused by: java.lang.UnsupportedClassVersionError: Bad version number in .class file
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:164)
	at org.eclipse.emf.mwe.internal.core.MWEPlugin.loadClass(MWEPlugin.java:75)
	at org.eclipse.emf.mwe.core.resources.ResourceLoaderDefaultImpl.tryLoadClass(ResourceLoaderDefaultImpl.java:38)
	at org.eclipse.emf.mwe.core.resources.AbstractResourceLoader.loadClass(AbstractResourceLoader.java:37)
	at org.eclipse.emf.mwe.core.resources.ResourceLoaderDefaultImpl.loadClass(ResourceLoaderDefaultImpl.java:28)
	at org.eclipse.emf.mwe.utils.StandaloneSetup.addRegisterGeneratedEPackage(StandaloneSetup.java:307)
	... 35 more


can somebody help me?

My best regards
frank
  • Attachment: Project.zip
    (Size: 81.44KB, Downloaded 53 times)
Re: Problem running Mwe2 worflow [message #875285 is a reply to message #875277] Tue, 22 May 2012 13:21 Go to previous messageGo to next message
frank fotso is currently offline frank fotsoFriend
Messages: 91
Registered: May 2012
Member
and when i create a new Xtext project and when i finish with the grammar and i run the .MWE2 as a MWE2 workflow i don't have any error the program is executing well but , things becomes differents i try to do the same with the .MWE2 from an " Xtext project from an existing Ecore model " i have the errors written above
Re: Problem running Mwe2 worflow [message #875446 is a reply to message #875285] Tue, 22 May 2012 19:14 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 6550
Registered: July 2009
Senior Member
Hi,

the Xtext plugins have Java 5 configured, the EmfModel Project Java 6 so (depending on the compiler setup you have)
this might lead to Java 5 classes loaded with Java 6 so align the configurations in the manifest files
(probably to java 6)

~Christian
Re: Problem running Mwe2 worflow [message #875696 is a reply to message #875446] Wed, 23 May 2012 07:43 Go to previous messageGo to next message
frank fotso is currently offline frank fotsoFriend
Messages: 91
Registered: May 2012
Member
thks christian,

apparently every time i rebuild the project it change the JRE from 6 to 5 i don't know why and i always forget to look if is still JRE 6 .
thks for your help.
Re: Problem running Mwe2 worflow [message #875737 is a reply to message #875696] Wed, 23 May 2012 08:55 Go to previous message
frank fotso is currently offline frank fotsoFriend
Messages: 91
Registered: May 2012
Member
now when i try to run the project as an eclipse application i have this on the log error :

!SESSION 2012-05-23 10:46:49.865 -----------------------------------------------
eclipse.buildId=M20110909-1335
java.version=1.5.0_09
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
Framework arguments: -product org.eclipse.sdk.ide
Command-line arguments: -product org.eclipse.sdk.ide -data D:\frank\workspace/../runtime-EclipseApplication -dev file:D:/frank/workspace/.metadata/.plugins/org.eclipse.pde.core/Eclipse Application/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.equinox.p2.transport.ecf 2 0 2012-05-23 10:46:50.927
!MESSAGE [SCR] Found components with duplicated names! Details:
Component1 : Component[
name = org.eclipse.equinox.p2.transport.ecf
activate = activate
deactivate = deactivate
modified =
configuration-policy = optional
factory = null
autoenable = true
immediate = false
implementation = org.eclipse.equinox.internal.p2.transport.ecf.ECFTransportComponent
state = Unsatisfied
properties = {p2.agent.servicename=org.eclipse.equinox.internal.p2.repository.Transport}
serviceFactory = false
serviceInterface = [org.eclipse.equinox.p2.core.spi.IAgentServiceFactory]
references = null
located in bundle = org.eclipse.equinox.p2.transport.ecf_1.0.0.v20110510 [212]
]
Component2: Component[
name = org.eclipse.equinox.p2.transport.ecf
activate = activate
deactivate = deactivate
modified =
configuration-policy = optional
factory = null
autoenable = true
immediate = false
implementation = org.eclipse.equinox.internal.p2.transport.ecf.ECFTransportComponent
state = Unsatisfied
properties = {p2.agent.servicename=org.eclipse.equinox.internal.p2.repository.Transport}
serviceFactory = false
serviceInterface = [org.eclipse.equinox.p2.core.spi.IAgentServiceFactory]
references = null
located in bundle = org.eclipse.equinox.p2.transport.ecf_1.0.0.v20111128-0624 [211]
]

!ENTRY org.eclipse.osgi 2 0 2012-05-23 10:46:52.818
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.818
!MESSAGE Bundle org.eclipse.jdt.apt.pluggable.core_1.0.400.v20110305-1450 [235] was not resolved.
!SUBENTRY 2 org.eclipse.jdt.apt.pluggable.core 2 0 2012-05-23 10:46:52.818
!MESSAGE Missing imported package org.eclipse.jdt.internal.compiler.tool_0.0.0.
!SUBENTRY 2 org.eclipse.jdt.apt.pluggable.core 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing imported package org.eclipse.jdt.internal.compiler.apt.dispatch_0.0.0.
!SUBENTRY 2 org.eclipse.jdt.apt.pluggable.core 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing imported package org.eclipse.jdt.internal.compiler.apt.model_0.0.0.
!SUBENTRY 2 org.eclipse.jdt.apt.pluggable.core 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing imported package org.eclipse.jdt.internal.compiler.apt.util_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.eclipse.jdt.compiler.apt_1.0.400.v0110816-0800 [237] was not resolved.
!SUBENTRY 2 org.eclipse.jdt.compiler.apt 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing optionally imported package org.eclipse.jdt.internal.compiler.tool_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.eclipse.jdt.compiler.tool_1.0.100.v_B76_R37x [238] was not resolved.
!SUBENTRY 2 org.eclipse.jdt.compiler.tool 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.eclipse.jpt.dbws.eclipselink.core.gen_1.0.0.v201104110000 [272] was not resolved.
!SUBENTRY 2 org.eclipse.jpt.dbws.eclipselink.core.gen 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing required bundle org.eclipse.persistence.dbws.builder_[2.3.0,3.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.eclipse.jpt.dbws.eclipselink.ui_1.0.0.v201104110000 [273] was not resolved.
!SUBENTRY 2 org.eclipse.jpt.dbws.eclipselink.ui 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing required bundle org.eclipse.jpt.dbws.eclipselink.core.gen_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.jpt.dbws.eclipselink.ui 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing required bundle org.eclipse.persistence.dbws.builder_[2.3.0,3.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.eclipse.persistence.dbws_2.3.2.v20111125-r10461 [485] was not resolved.
!SUBENTRY 2 org.eclipse.persistence.dbws 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.eclipse.persistence.dbws.builder_2.3.2.v20111125-r10461 [486] was not resolved.
!SUBENTRY 2 org.eclipse.persistence.dbws.builder 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing required bundle org.eclipse.persistence.dbws_2.3.2.
!SUBENTRY 2 org.eclipse.persistence.dbws.builder 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing optionally imported package javax.tools_0.0.0.
!SUBENTRY 2 org.eclipse.persistence.dbws.builder 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing imported package org.eclipse.persistence.dbws_2.3.2.
!SUBENTRY 2 org.eclipse.persistence.dbws.builder 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing imported package org.eclipse.persistence.internal.dbws_2.3.2.
!SUBENTRY 2 org.eclipse.persistence.dbws.builder 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing imported package org.eclipse.persistence.internal.xr_2.3.2.
!SUBENTRY 2 org.eclipse.persistence.dbws.builder 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing imported package org.eclipse.persistence.internal.xr.sxf_2.3.2.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.eclipse.ui.win32_3.2.200.I20100509-0800 [529] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.eclipse.wb.swing.java6_1.3.0.r37x201202021417 [556] was not resolved.
!SUBENTRY 2 org.eclipse.wb.swing.java6 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle Project2_1.0.0.qualifier [810] was not resolved.
!SUBENTRY 2 Project2 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.6
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle Project2.edit_1.0.0.qualifier [811] was not resolved.
!SUBENTRY 2 Project2.edit 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing required bundle Project2_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.xtext.example.project2_1.0.0 [812] was not resolved.
!SUBENTRY 2 org.xtext.example.project2 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing required bundle Project2_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.xtext.example.project2.tests_1.0.0 [813] was not resolved.
!SUBENTRY 2 org.xtext.example.project2.tests 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing required bundle org.xtext.example.project2_0.0.0.
!SUBENTRY 2 org.xtext.example.project2.tests 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing required bundle org.xtext.example.project2.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-05-23 10:46:52.849
!MESSAGE Bundle org.xtext.example.project2.ui_1.0.0 [814] was not resolved.
!SUBENTRY 2 org.xtext.example.project2.ui 2 0 2012-05-23 10:46:52.849
!MESSAGE Missing required bundle org.xtext.example.project2_0.0.0.


for the first error i'm sure the 2 files have the the same name but i dont know where i will change it and if i have the right to change it?

and for the rest , is look like i have many missing plugin
Previous Topic:weird bundle dependencies generated
Next Topic:buckminster build project
Goto Forum:
  


Current Time: Sat Dec 20 05:11:20 GMT 2014

Powered by FUDForum. Page generated in 0.01867 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software