Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse won't launch can't find companion shared library(The Eclipse executable launcher was unable to locate its companion shared library)
Eclipse won't launch can't find companion shared library [message #868415] Tue, 01 May 2012 23:08 Go to next message
Winthrop Bastin is currently offline Winthrop Bastin
Messages: 3
Registered: May 2012
Junior Member
Windows XP. Was using Eclipse Indigo SR1 without incident. Updated software. Eclipse would not launch. Brief flash screen, that's it. Deleted Eclipse. Downloaded new Indigo SR2. When I launch Eclipse I get the following error message:
"The Eclipse executable launcher was unable to locate its companion shared library."

Re unzipped using 7Zip. Reinstalled Java. Added Java to Windows path. Removed old class path now just ".".

Eclipse still will not launch. Tried various command line arguments -clean, -vm, the library one. Nothing works.

Please help.
Re: Eclipse won't launch can't find companion shared library [message #868709 is a reply to message #868415] Wed, 02 May 2012 12:35 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2277
Registered: July 2009
Senior Member
Do you have read and execute rights on all of the .exe and .dll files under the eclipse directory? Exactly which file (by name) did you get for SR2? Did you download the 64-bit one by mistake?

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Eclipse won't launch can't find companion shared library [message #868834 is a reply to message #868709] Wed, 02 May 2012 15:58 Go to previous messageGo to next message
Winthrop Bastin is currently offline Winthrop Bastin
Messages: 3
Registered: May 2012
Junior Member
My computer runs Windows XP OS. I have administrative rights on the computer, so I do have read, execute rights on the .exe and .dll files.

The file I downloaded was : eclipse-SDK-3.7.2-win32.zip. I unziped it to: C:\eclipse3_7.

I read the sticky about specifying the virtual machine. I did that with:
-vm
C:\Program Files\jdk1.7.0_04\bin\javaw.exe

Still no luck. When trying to launch, I get the error message:
"The Eclipse executable launcher was unable to locate its companion shared library."

Thanks for your help.
Re: Eclipse won't launch can't find companion shared library [message #868848 is a reply to message #868834] Wed, 02 May 2012 16:20 Go to previous message
Winthrop Bastin is currently offline Winthrop Bastin
Messages: 3
Registered: May 2012
Junior Member
Solved. I was using 7-zip to unzip the .zip file. For some reason, it was not unziping correctly. I used the built-in Windows Compressed Folders Extraction Wizard and the zip file extracted correctly. Eclipse now works. I didn't need to specify the vm (it is in the class path).

Thank you for your reply and trying to help me. I am posting this in the event some other Windows user runs into the same problem.
Previous Topic:Accessing IProject through IFolder/IFile in plugin
Next Topic:keyword shortcuts in eclipse
Goto Forum:
  


Current Time: Wed Sep 24 04:35:10 GMT 2014

Powered by FUDForum. Page generated in 0.03550 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software