Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Debug Error(Cannot start debugging- cannot connect to VM)
Debug Error [message #849202] Thu, 19 April 2012 00:46 Go to next message
Chance Henderson is currently offline Chance Henderson
Messages: 1
Registered: April 2012
Junior Member
Hey there. I'm using JDK 1.7 and JRE 7 with Eclipse. I've started programming some java, and I usually test to see if it works from time to time with 'Run'. However, when I try to use 'Debug' I get an error window stating "Launching project has encountered a problem. Cannot connect to VM." The details given are "Cannot connect to VM. Socket operation on nonsocket: configureBlocking."
In the console, I have four lines appear:

FATAL ERROR in native method: JDWP No transports initialized, jvmtiError=AGENT_ERROR_TRANSPORT_INIT(197)

ERROR: transport error 202: connect failed: Connection refused

ERROR: JDWP Transport dt_socket failed to initialize, TRANSPORT_INIT(510)

JDWP exit error AGENT_ERROR_TRANSPORT_INIT(197): No transports initialized [../../../src/share/back/debugInit.c:741]

I'm new to eclipse, and pretty new to java in general, so I cannot decipher what any of this means. A number of google searches gave me several answers, but none that worked, and for problems that weren't quite identical (usually socket closed, compared to my not having any sockets to close). Can anyone help?
Re: Debug Error [message #849387 is a reply to message #849202] Thu, 19 April 2012 05:21 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2307
Registered: July 2009
Senior Member
If you are using a software firewall, make sure the JVM executable you used to run Eclipse and the one you're using to run your application are allowed for both incoming and outgoing traffic.

---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:Free Plugins To Beef Up Eclipses Text Editing Capabilities?
Next Topic:Empty workspace
Goto Forum:
  


Current Time: Mon Oct 20 13:18:15 GMT 2014

Powered by FUDForum. Page generated in 0.03308 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software