Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] 'Acceleo Builder' Errors
[Acceleo] 'Acceleo Builder' Errors [message #847648] Tue, 17 April 2012 14:15 Go to next message
saadia dhouib is currently offline saadia dhouibFriend
Messages: 36
Registered: April 2010
Member
Hi,

I have problems with the Acceleo builder when I switch the serialization from "bin" to "xmi" in the projects properties:

Errors occurred during the build.
Errors running builder 'Acceleo Builder' on project 'org.eclipse.acceleo.module.test'.
The feature 'et(Element)' is not a valid feature
Errors running builder 'Acceleo Builder' on project 'org.eclipse.acceleo.module.test'.
The feature 'clAny_Class' is not a valid feature
Errors running builder 'Acceleo Builder' on project 'org.eclipse.proteus.generators.acceleo.test2'.
The feature 'clAny_Class' is not a valid feature
Errors running builder 'Acceleo Builder' on project 'org.eclipse.proteus.generators.acceleo.test3'.
The feature 'clAny_Class' is not a valid feature
Errors running builder 'Acceleo Builder' on project 'org.eclipse.proteus.generators.acceleo.test4'.
The feature 'clAny_Class' is not a valid feature

Do you have an idea on those problems?

Cheers

[Updated on: Tue, 17 April 2012 14:15]

Report message to a moderator

Re: [Acceleo] 'Acceleo Builder' Errors [message #847657 is a reply to message #847648] Tue, 17 April 2012 14:27 Go to previous messageGo to next message
Stephane Begaudeau is currently offline Stephane BegaudeauFriend
Messages: 413
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

Which version of Acceleo are you using?

Regards,

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau & @acceleo
Google+: stephane.begaudeau & acceleo
Blog: http://stephanebegaudeau.tumblr.com
Acceleo Documentation: http://docs.obeonetwork.com/acceleo



Re: [Acceleo] 'Acceleo Builder' Errors [message #847662 is a reply to message #847657] Tue, 17 April 2012 14:33 Go to previous messageGo to next message
saadia dhouib is currently offline saadia dhouibFriend
Messages: 36
Registered: April 2010
Member
I'm using this version: 3.1.1.v20110914-0246
Re: [Acceleo] 'Acceleo Builder' Errors [message #847669 is a reply to message #847662] Tue, 17 April 2012 14:38 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

I recommend 3.1.2 and a full rebuild. I used to see those missing first
character errors too but I think 3.1.2 and XMI serialization fixed them.

Regards

Ed Willink

On 17/04/2012 15:33, saadia dhouib wrote:
> I'm using this version: 3.1.1.v20110914-0246
Re: [Acceleo] 'Acceleo Builder' Errors [message #847679 is a reply to message #847669] Tue, 17 April 2012 14:50 Go to previous messageGo to next message
saadia dhouib is currently offline saadia dhouibFriend
Messages: 36
Registered: April 2010
Member
I have upgraded the acceleo version to 3.1.2, cleaned all projects and rebuilt them.
But I have still the same errors
Re: [Acceleo] 'Acceleo Builder' Errors [message #848433 is a reply to message #847679] Wed, 18 April 2012 08:07 Go to previous messageGo to next message
saadia dhouib is currently offline saadia dhouibFriend
Messages: 36
Registered: April 2010
Member
Even with 3.1.3 version, I have the same errors
Re: [Acceleo] 'Acceleo Builder' Errors [message #848440 is a reply to message #848433] Wed, 18 April 2012 08:14 Go to previous messageGo to next message
saadia dhouib is currently offline saadia dhouibFriend
Messages: 36
Registered: April 2010
Member
If I summarize my problem:
With version 3.1.1, 3.1.2, 3.1.3 of Acceleo, and with Xmi or Bin serialization I have those compilation errors on three acceleo projects:
Errors occurred during the build.
Errors running builder 'Acceleo Builder' on project 'org.eclipse.acceleo.module.test'.
The feature 'et(Element)' is not a valid feature
Errors running builder 'Acceleo Builder' on project 'org.eclipse.acceleo.module.test'.
The feature 'clAny_Class' is not a valid feature
Errors running builder 'Acceleo Builder' on project 'org.eclipse.proteus.generators.acceleo.test2'.
The feature 'clAny_Class' is not a valid feature
Errors running builder 'Acceleo Builder' on project 'org.eclipse.proteus.generators.acceleo.test3'.
The feature 'clAny_Class' is not a valid feature
Errors running builder 'Acceleo Builder' on project 'org.eclipse.proteus.generators.acceleo.test4'.
The feature 'clAny_Class' is not a valid feature

[Updated on: Wed, 18 April 2012 08:14]

Report message to a moderator

Re: [Acceleo] 'Acceleo Builder' Errors [message #848486 is a reply to message #848440] Wed, 18 April 2012 09:13 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

Your underlying error is an off-by-one pointer error which is a sure
indication of inconsistent 'version's somewhere.

Another idea. I recall that I had a Java 5/6 conflict at some point.
Make sure that you use the same Java everywhere.

Most Eclipse Modeling projects have abandoned Java 4 support but are
reluctant to mandate Java 6, so J2SE-1.5 is the normal setting. Make
sure your Windows Preferences for the java compiler are 1.5, that all
your plugins are for the same (Indigo) release are have J2SE-1.5 as the
annotation on the JRE System Library in the Package Explorer and that
your genmodel compliance level is 5.0. Then clean all projects. If
necessary, restart Eclipse and clean all projects. If still necessary
create a new Workspace. If still necessary create a new Eclipse
installation with only a Java 5 JRE.

Regards

Ed Willink



On 18/04/2012 09:14, saadia dhouib wrote:
> If I summarize my problem:
> With version 3.1.1, 3.1.2, 3.1.3 of Acceleo, and with WMI or Bin
> serialization I have those compilation errors on three acceleo projects:
> Errors occurred during the build.
> Errors running builder 'Acceleo Builder' on project
> 'org.eclipse.acceleo.module.test'.
> The feature 'et(Element)' is not a valid feature
> Errors running builder 'Acceleo Builder' on project
> 'org.eclipse.acceleo.module.test'.
> The feature 'clAny_Class' is not a valid feature
> Errors running builder 'Acceleo Builder' on project
> 'org.eclipse.proteus.generators.acceleo.test2'.
> The feature 'clAny_Class' is not a valid feature
> Errors running builder 'Acceleo Builder' on project
> 'org.eclipse.proteus.generators.acceleo.test3'.
> The feature 'clAny_Class' is not a valid feature
> Errors running builder 'Acceleo Builder' on project
> 'org.eclipse.proteus.generators.acceleo.test4'.
> The feature 'clAny_Class' is not a valid feature
>
Re: [Acceleo] 'Acceleo Builder' Errors [message #848544 is a reply to message #848486] Wed, 18 April 2012 10:32 Go to previous messageGo to next message
saadia dhouib is currently offline saadia dhouibFriend
Messages: 36
Registered: April 2010
Member
Hi Ed,
stupid question: how to set genmodel compliance level ?
Re: [Acceleo] 'Acceleo Builder' Errors [message #848561 is a reply to message #848544] Wed, 18 April 2012 10:50 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

It's one of the "All" group of properties on the root element in the
GenModel editor.

Regards

Ed Willink


On 18/04/2012 11:32, saadia dhouib wrote:
> Hi Ed,
> stupid question: how to set genmodel compliance level ?
Re: [Acceleo] 'Acceleo Builder' Errors [message #848636 is a reply to message #848561] Wed, 18 April 2012 12:42 Go to previous messageGo to next message
saadia dhouib is currently offline saadia dhouibFriend
Messages: 36
Registered: April 2010
Member
Dear Ed,
I have done all the steps that you mentioned. Even I have uninstalled Java 6 from my machine.
But still the errors...
Is there anything else I can do?
Re: [Acceleo] 'Acceleo Builder' Errors [message #848675 is a reply to message #848636] Wed, 18 April 2012 13:27 Go to previous messageGo to next message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1639
Registered: July 2009
Senior Member
Hi,

These all seem quite "scattershot" answers to a vague question... Back to the issue at hand : Saadia, could you be a little more specific as to the issue you experience?

- Do you have the metamodel used by your templates in the workspace? If yes, you most likely encountered one of the known bugs of Acceleo 3.1. If you are in such a case, you will need to install the metamodels and remove them from the worspace (or launch a runtime in which you will develop the templates). Or you could try and use one of the 3.2 or 3.3 builds since these bugs are fixed : http://download.eclipse.org/modeling/m2t/acceleo/updates/milestones/3.2 .
- Can you confirm that you have indeed selected "XMI" by right-clicking on your project(s), selecting "properties" then "Acceleo"?
- Are these issues recurrent on a given set of templates, or do they appear for "all" templates?
- Have you tried a full, clean build on your workspace (disable "Project > Build Automatically", then use "Project > Clean..." while disabling the checkbox "Start a build automatically" at the bottom of the popup. Then, use "Project > Build All". Finally, reenable the "Poject > Build Automatically" item)?

If you tried all these, and it still fails with these errors : do you have a stack trace in the error log ("Window > Show View > Error Log")? Please provide it to us here if you do.

Finally, if none of this helps, could you provide us with a sample template on which you reproduce this issue (if possible, something that we can use to reproduce ourselves, thus not using your own metamodels)?

Laurent Goubet
Obeo

[Updated on: Wed, 18 April 2012 13:28]

Report message to a moderator

Re: [Acceleo] 'Acceleo Builder' Errors [message #848728 is a reply to message #848636] Wed, 18 April 2012 14:10 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

My previous experiences were in
http://www.eclipse.org/forums/index.php/mv/msg/197654/630274/#msg_630274
and the solution was a new workspace.

Cedric Brun had the same problem in
https://bugs.eclipse.org/bugs/show_bug.cgi?id=327116 which was CLOSED
INVALID although the cause was never identified.

Regards

Ed Willink


On 18/04/2012 13:42, saadia dhouib wrote:
> Dear Ed,
> I have done all the steps that you mentioned. Even I have uninstalled
> Java 6 from my machine.
> But still the errors...
> Is there anything else I can do?
Re: [Acceleo] 'Acceleo Builder' Errors [message #848742 is a reply to message #848728] Wed, 18 April 2012 14:27 Go to previous messageGo to next message
saadia dhouib is currently offline saadia dhouibFriend
Messages: 36
Registered: April 2010
Member
Thank you guys for the tips,
the problem comes from the fact that the metamodel (a static UML profile) used by acceleo was in my workspace.
Re: [Acceleo] 'Acceleo Builder' Errors [message #848770 is a reply to message #848742] Wed, 18 April 2012 14:58 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

It seems that you have a solid repro for an elusive problem. Can you ZIP
it up and submit it?

Regards

Ed Willink


On 18/04/2012 15:27, saadia dhouib wrote:
> Thank you guys for the tips,
> the problem comes from the fact that the metamodel (a static UML
> profile) used by acceleo was in my workspace.
Re: [Acceleo] 'Acceleo Builder' Errors [message #848793 is a reply to message #848770] Wed, 18 April 2012 15:26 Go to previous messageGo to next message
saadia dhouib is currently offline saadia dhouibFriend
Messages: 36
Registered: April 2010
Member
Do you want the acceleo and the static profile plugins? Where can I submit it?
Re: [Acceleo] 'Acceleo Builder' Errors [message #848812 is a reply to message #848793] Wed, 18 April 2012 15:41 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

Attaching a ZIP to a Bugzilla is best.

Since the problem is elusive, it's probably a good idea to have ZIPs of
all relevant non-Eclipse.org projects.

Regards

Ed Willink

On 18/04/2012 16:26, saadia dhouib wrote:
> Do you want the acceleo and the static profile plugins? Where can I
> submit it?
>
Re: [Acceleo] 'Acceleo Builder' Errors [message #849472 is a reply to message #848728] Thu, 19 April 2012 07:19 Go to previous messageGo to next message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1639
Registered: July 2009
Senior Member
Saadia,

As Ed mentionned, a zip of your projects (containing the projects with your templates and the profiles/metamodels it uses) would be the best. If you cannot provide us with the original files, can you try and reproduce your use case with generic, simple samples?

If you do reproduce, please attach the zipped projects on a bug on bugzilla.

Ed,

Edward Willink wrote on Wed, 18 April 2012 10:10

My previous experiences were in
http://www.eclipse.org/forums/index.php/mv/msg/197654/630274/#msg_630274
and the solution was a new workspace.


This issue has been encountered by a number of people with 3.1.1, and it had multiple causes, with as many bugs fixed with the latest releases. Most causes have been tracked down and fixed, the important part as far as we are concerned is to try and pinpoint the causes of this particular instance to see if if is one of those we fixed, or if one of them has passed through.

Edward Willink wrote on Wed, 18 April 2012 10:10

Cedric Brun had the same problem in
https://bugs.eclipse.org/bugs/show_bug.cgi?id=327116 which was CLOSED
INVALID although the cause was never identified.


And as mentionned on the bug along with the "closing" comment, without any reproduction steps, xml files or templates ... we have absolutely no way to try and fix it, hence my detailled questions in this thread.

Laurent Goubet
Obeo
Re: [Acceleo] 'Acceleo Builder' Errors [message #875284 is a reply to message #847669] Tue, 22 May 2012 13:18 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4188
Registered: July 2009
Senior Member
Hi

I got this off-by one error again (when upgrading to 3.3M7). It was
pretty obstinate until I re-re-started Eclipse, then it just went away.

Regards

Ed Willink

On 17/04/2012 15:38, Ed Willink wrote:
> Hi
>
> I recommend 3.1.2 and a full rebuild. I used to see those missing
> first character errors too but I think 3.1.2 and XMI serialization
> fixed them.
>
> Regards
>
> Ed Willink
Previous Topic:Error when parsing an external data type in the xmi model
Next Topic:Acceleo with my Metamodel
Goto Forum:
  


Current Time: Mon Dec 22 16:21:02 GMT 2014

Powered by FUDForum. Page generated in 0.02928 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software