Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Equinox and CrEme (J2ME CDC)
Equinox and CrEme (J2ME CDC) [message #101354] Fri, 09 November 2007 12:51 Go to next message
Jaime is currently offline Jaime
Messages: 56
Registered: July 2009
Member
Hi,

I've been testing equinox with IBM's J9 in a PDA and it works pretty well.
I'd like to check that it also works with CrEme (an implementation of J2ME
CDC 1.0 specification) but it doesn't work (it doesn't even start the
Equinox framework).

The log output (jscpout.txt) is:

NSIcom Ltd., CrEme(tm) Evaluation Version
CrE-ME J2ME(tm)
CrE-ME V4.12 B122.160107 16-Jan-2007
MemoryLimit=29056Kb
EBCI(TM) Interpreter V1.00,
Copyright 1998-2002 by Bytecodes, Inc.
java.lang.IllegalArgumentException: Cannot start without the following
system properties set: osgi.framework, osgi.install.area
at org.eclipse.core.runtime.adaptor.EclipseStarter.initializePr operties()
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup()
at org.eclipse.core.runtime.adaptor.EclipseStarter.run()
at org.eclipse.core.runtime.adaptor.EclipseStarter.main()



The link that I've used to start Equinox is:
255#\SD-MMCard\Windows\CrEme\bin\CrEme.exe -Of -sp:0 -cp
\SD-MMCard\equinox\org.eclipse.osgi_3.3.0.v20070530.jar
org.eclipse.core.runtime.adaptor.EclipseStarter -console -clean

I've tried to set up the "osgi.framework" and "osgi.install.area" system
properties:
255#\SD-MMCard\Windows\CrEme\bin\CrEme.exe -Of -sp:0 -Dosgi.framework=/SD-MMCard/equinox
-Dosgi.install.area=/SD-MMCard/equinox -cp
\SD-MMCard\equinox\org.eclipse.osgi_3.3.0.v20070530.jar
org.eclipse.core.runtime.adaptor.EclipseStarter -console -clean -debug
=/SD-MMCard/equinox/configuration/.options
but then the log is:

NSIcom Ltd., CrEme(tm) Evaluation Version
CrE-ME J2ME(tm)
CrE-ME V4.12 B122.160107 16-Jan-2007
MemoryLimit=29056Kb
EBCI(TM) Interpreter V1.00,
Copyright 1998-2002 by Bytecodes, Inc.
Debug options:
file:/SD-MMCard/equinox/configuration/.options loaded
org.eclipse.osgi Startup error
java.lang.NullPointerException
at org.eclipse.osgi.baseadaptor.BaseAdaptor.initializeStorage()
at org.eclipse.osgi.framework.internal.core.Framework.initializ e()
at org.eclipse.osgi.framework.internal.core.Framework.<init>()
at org.eclipse.osgi.framework.internal.core.OSGi.createFramewor k()
at org.eclipse.osgi.framework.internal.core.OSGi.<init>()
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup()
at org.eclipse.core.runtime.adaptor.EclipseStarter.run()
at org.eclipse.core.runtime.adaptor.EclipseStarter.main()
java.lang.NullPointerException
at org.eclipse.core.runtime.adaptor.EclipseStarter.run()
at org.eclipse.core.runtime.adaptor.EclipseStarter.main()

The /SD-MMCard/equinox is the directory that contains
org.eclipse.osgi_3.3.0.v20070530.jar and the configuration directory.

Did someone try to start up Equinox with CrEme?

Thank you in advance,
Jaime
Re: Equinox and CrEme (J2ME CDC) [message #631719 is a reply to message #101354] Fri, 08 October 2010 14:24 Go to previous message
Roy  is currently offline Roy
Messages: 1
Registered: October 2010
Junior Member
Ditto. I am at the same place. Did you manage to make any headway? Any help much appreciated.
Previous Topic:How to include third party bundles into a p2 Update Site?
Next Topic:How to retrieve the consumer with declarative services?
Goto Forum:
  


Current Time: Fri Oct 24 15:04:16 GMT 2014

Powered by FUDForum. Page generated in 0.09088 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software