Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Update Bundles with P2 that are required by other bundles
Update Bundles with P2 that are required by other bundles [message #815124] Wed, 07 March 2012 09:03 Go to next message
Daniel Lüddecke is currently offline Daniel Lüddecke
Messages: 1
Registered: March 2012
Junior Member
Hi,

I'm currently trying to get P2 working in our OSGI-based application. While Installing and Uninstalling seems to be working at the moment, I'm running into some problems with the update mechanism:
When I try to update a bundle A which exports a package that is imported by a second bundle B, the update operation can not be resolved.
It ends up with:
"'A' cannot be fully uninstalled because other installed software requires it.  The parts that are not required will be uninstalled."

The problem is of course very obvious: needed bundles cannot be uninstalled.
The question is: Do you have any ideas how I could update a bundle that is required by an other bundle?

best regards and thanks for your help in advance,
Daniel
Re: Update Bundles with P2 that are required by other bundles [message #822409 is a reply to message #815124] Fri, 16 March 2012 15:30 Go to previous message
Pascal Rapicault is currently offline Pascal Rapicault
Messages: 290
Registered: July 2009
Location: Ottawa
Senior Member
You would have to find the bundle or feature that explicitely install and requires it. For example in the following setup:
A -> B -> C

if updating C fails you would most likely have to update A.
Previous Topic:Event Admin Service. Thread configuration possible?
Next Topic:Control based authorization in eclipse RCP
Goto Forum:
  


Current Time: Thu Oct 23 17:18:50 GMT 2014

Powered by FUDForum. Page generated in 0.01753 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software