Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » JAVA CARD - Eclipse JCDE. generation of the CAP file(classes are not included inside the .exp file)
JAVA CARD - Eclipse JCDE. generation of the CAP file [message #806020] Fri, 24 February 2012 12:44 Go to next message
Eglantine Houdart is currently offline Eglantine HoudartFriend
Messages: 2
Registered: February 2012
Junior Member
Hi,

I develop applets on java card with eclipse JCDE.
There are two packages. The first one contains a class extends Applet, an interface extends Shareable and another class implementing the interface.
The second package contains a class importing a class from the first package.
I generate without problem the CAP, EXP and IJC file of the first package. But, I have a problem when I want to generate the CAP EXP and IJC files of the second package.
Here is the error message:
error: test2.serializable: class version0.version0SIO not found in export file version0.exp.
The class I used by importation from the first package is not found in the .EXP of the first package. I do not know why.
Have you ever encountered this problem and how solve it.
Thanks very much in advance for your answer.
Eglantine
Re: JAVA CARD - Eclipse JCDE. generation of the CAP file [message #846669 is a reply to message #806020] Mon, 16 April 2012 15:18 Go to previous messageGo to next message
luca apicella is currently offline luca apicellaFriend
Messages: 2
Registered: April 2012
Junior Member
Hi,

I have trouble witjh this message : error: wallet.Wallet: unsupported class file format of version 50.0.

I am using these configuration: Eclipse Version: 3.3.2, eclipse-jcde 1.0`s plugin into eclipse plugin directory and java_card_kit-2_2_2. So, I use EclipseJCDE(i just installed and do the commands given in this site. i can build the WRITE/READ applet. When I use "Java Card" menu item and select "Convert". This error message is sent to console window of eclipse ide.

What can be the reason(s)?


thanks LUCA Razz
Re: JAVA CARD - Eclipse JCDE. generation of the CAP file [message #847355 is a reply to message #846669] Tue, 17 April 2012 08:18 Go to previous messageGo to next message
Eglantine Houdart is currently offline Eglantine HoudartFriend
Messages: 2
Registered: February 2012
Junior Member
Hi,

This means that the java version is not the good one. The java version which is supported is the 1.5 or less.
I think I have had the problem and, if I well remember, I have changed the properties of my project.
1/ go on your project directory on eclipse and right click.
2/ Open "Properties", the last one of the proposed "option"
3/ go on "Java Compiler"
4/ Choose "Enable project specific settings" and chosse the folowing options:
- "compiler compilance level" : 1.4
- "Generated class files compatibility": CLDC 1.1
- "Source compatibility": 1.3
and do not change the another options.
Eglantine
Re: JAVA CARD - Eclipse JCDE. generation of the CAP file [message #847463 is a reply to message #847355] Tue, 17 April 2012 10:26 Go to previous message
luca apicella is currently offline luca apicellaFriend
Messages: 2
Registered: April 2012
Junior Member
thanks for your detailed answer!! I have the files .CAP, .EXP, .JCA now!!!
I tested the code, to writes and reads data from a smart card, with JCWDE and everything is ok. Now I should install the applet into the smart card but I do not know how to do Sad . Could you help me again? thanks LUCA
Previous Topic:Installed JREs - Could not create the view
Next Topic:Refresh Package Explorer?
Goto Forum:
  


Current Time: Fri Dec 19 15:20:19 GMT 2014

Powered by FUDForum. Page generated in 0.02229 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software