Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Voicetools » JSP Validation
JSP Validation [message #8662] Thu, 29 September 2005 14:43 Go to next message
Eclipse User
Originally posted by: dsb4103.cs.rit.edu

Is VTP supposed to do JSP Validation with VXML in it? Because when I have
JSP's which generate VXML it is coming up with unrecognized tags, I guess
it expects HTML.


Thanks,
Dan
Re: JSP Validation [message #8674 is a reply to message #8662] Thu, 13 October 2005 04:47 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Thu, 29 Sep 2005 10:43:22 -0400, Daniel Block <dsb4103@cs.rit.edu> wr=
ote:

> Is VTP supposed to do JSP Validation with VXML in it? Because when I h=
ave
> JSP's which generate VXML it is coming up with unrecognized tags, I gu=
ess
> it expects HTML.

Not sure which version of WTP you (voice tools project) are using
(and, honestly, not even sure if you're using our JSP Editor/validation,=

but last I checked, was),

But, we have recently, made fixes to correctly recognize "xml" in JSP's,=

and ... we have sort of a "guess" heuristic to look at JSP content types=

that "end with 'xml' " ... so, you might search our bugzilla's and or
try a "pure" WTP install (say, based on M8) as a quick check.

And, if we still don't "recognize" it as XML, please open a bug in WTP.
Re: JSP Validation [message #8711 is a reply to message #8674] Mon, 16 January 2006 13:51 Go to previous messageGo to next message
Eclipse User
Originally posted by: r.finan.mobilkom.at

Hi!

I've been playing around with trying to get the JSP editor to validate
VoiceXML files. I've added the VXML DTD catalog which comes with the
Voice Tools to the XML catalog, but no dice. (I'm running 1.0.0) Are the
tools supposed to validate JSPs or is that a future plan?

Thanks,

Robert

David Williams wrote:

> On Thu, 29 Sep 2005 10:43:22 -0400, Daniel Block <dsb4103@cs.rit.edu> wrote:

>> Is VTP supposed to do JSP Validation with VXML in it? Because when I have
>> JSP's which generate VXML it is coming up with unrecognized tags, I guess
>> it expects HTML.

> Not sure which version of WTP you (voice tools project) are using
> (and, honestly, not even sure if you're using our JSP Editor/validation,
> but last I checked, was),

> But, we have recently, made fixes to correctly recognize "xml" in JSP's,
> and ... we have sort of a "guess" heuristic to look at JSP content types
> that "end with 'xml' " ... so, you might search our bugzilla's and or
> try a "pure" WTP install (say, based on M8) as a quick check.

> And, if we still don't "recognize" it as XML, please open a bug in WTP.
Re: JSP Validation [message #8724 is a reply to message #8711] Thu, 19 January 2006 21:09 Go to previous messageGo to next message
Eclipse User
Originally posted by: gcormier99.hotmail.com

I do have the same problem. I've created a file "welcome.jsp". Here the
content of the file:

<?xml version="1.0" encoding ="UTF-8"?>
<!DOCTYPE vxml PUBLIC "-//W3C//DTD VOICEXML 2.1//EN"
"http://www.w3.org/TR/voicexml21/vxml.dtd">
<%@ taglib uri="/tags/struts-bean" prefix="bean" %>
<%@ taglib uri="/tags/struts-html" prefix="html" %>
<%@ taglib uri="/tags/struts-logic" prefix="logic" %>

<vxml version="2.1" xmlns="http://www.w3.org/2001/vxml"
application="app-root.jsp">

<form>
<field name="nextChoice">
<prompt>
<audio src="http://localhost/audio/welcome.wav" />
</prompt>

<grammar mode="dtmf" root="root" version="1.0">
<rule id="root" scope="public">
<one-of>
<item>0</item>
</one-of>
</rule>
</grammar>
</field>

<block>
<submit next="http://localhost/next.do"/>
</block>
</form>
</vxml>


Eclipse is giving me a warning : Unknown tag (vxml).
Any idea? I opened the jsp file with "JSP Editor"
Re: JSP Validation [message #8736 is a reply to message #8724] Fri, 20 January 2006 14:34 Go to previous messageGo to next message
Eclipse User
Originally posted by: gcormier99.hotmail.com

I have add the content-type and it's now working. When I created the file,
Eclipse content assist is now working, but if I close the file and reopen
it with JSP Editor, it works fine.
Here's the new file:

<%@ page contentType="application/voicexml+xml; charset=UTF-8" %>
<?xml version="1.0" encoding ="UTF-8"?>
<!DOCTYPE vxml PUBLIC "-//W3C//DTD VOICEXML 2.1//EN"
"http://www.w3.org/TR/voicexml21/vxml.dtd">
<%@ taglib uri="/tags/struts-bean" prefix="bean" %>
<%@ taglib uri="/tags/struts-html" prefix="html" %>
<%@ taglib uri="/tags/struts-logic" prefix="logic" %>

<vxml version="2.1" xmlns="http://www.w3.org/2001/vxml"
application="app-root.jsp">
<form>
<field name="nextChoice">
<prompt>
<audio src="http://localhost/audio/welcome.wav" />
</prompt>
<grammar mode="dtmf" root="root" version="1.0">
<rule id="root" scope="public">
<one-of>
<item>0</item>
</one-of>
</rule>
</grammar>
</field>
<block>
<submit next="http://localhost/next.do"/>
</block>
</form>
</vxml>
Re: JSP Validation [message #8748 is a reply to message #8736] Sun, 22 January 2006 23:26 Go to previous message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Fri, 20 Jan 2006 09:34:09 -0500, GuiLL <gcormier99@hotmail.com> wrote:

> I have add the content-type and it's now working. When I created the file,
> Eclipse content assist is now working, but if I close the file and reopen
> it with JSP Editor, it works fine.
> Here's the new file:
>
> <%@ page contentType="application/voicexml+xml; charset=UTF-8" %>

Yes, I can confirm this content type is the key.
(we do still have a little hole that if you have a jsp fragment,
and can not re-specify the content type, we'll need to provide a
special "content settings" page -- hopefully that won't be a problem for
you ... at least until a future release :)

Do feel free to open bugs on WTP if you find problems. (I glance at this news
group occasionally ... but not as often as our bug lists :)
Re: JSP Validation [message #572649 is a reply to message #8662] Thu, 13 October 2005 04:47 Go to previous message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Thu, 29 Sep 2005 10:43:22 -0400, Daniel Block <dsb4103@cs.rit.edu> wr=
ote:

> Is VTP supposed to do JSP Validation with VXML in it? Because when I h=
ave
> JSP's which generate VXML it is coming up with unrecognized tags, I gu=
ess
> it expects HTML.

Not sure which version of WTP you (voice tools project) are using
(and, honestly, not even sure if you're using our JSP Editor/validation,=

but last I checked, was),

But, we have recently, made fixes to correctly recognize "xml" in JSP's,=

and ... we have sort of a "guess" heuristic to look at JSP content types=

that "end with 'xml' " ... so, you might search our bugzilla's and or
try a "pure" WTP install (say, based on M8) as a quick check.

And, if we still don't "recognize" it as XML, please open a bug in WTP.
Re: JSP Validation [message #572748 is a reply to message #8674] Mon, 16 January 2006 13:51 Go to previous message
Eclipse User
Originally posted by: r.finan.mobilkom.at

Hi!

I've been playing around with trying to get the JSP editor to validate
VoiceXML files. I've added the VXML DTD catalog which comes with the
Voice Tools to the XML catalog, but no dice. (I'm running 1.0.0) Are the
tools supposed to validate JSPs or is that a future plan?

Thanks,

Robert

David Williams wrote:

> On Thu, 29 Sep 2005 10:43:22 -0400, Daniel Block <dsb4103@cs.rit.edu> wrote:

>> Is VTP supposed to do JSP Validation with VXML in it? Because when I have
>> JSP's which generate VXML it is coming up with unrecognized tags, I guess
>> it expects HTML.

> Not sure which version of WTP you (voice tools project) are using
> (and, honestly, not even sure if you're using our JSP Editor/validation,
> but last I checked, was),

> But, we have recently, made fixes to correctly recognize "xml" in JSP's,
> and ... we have sort of a "guess" heuristic to look at JSP content types
> that "end with 'xml' " ... so, you might search our bugzilla's and or
> try a "pure" WTP install (say, based on M8) as a quick check.

> And, if we still don't "recognize" it as XML, please open a bug in WTP.
Re: JSP Validation [message #572790 is a reply to message #8711] Thu, 19 January 2006 21:09 Go to previous message
Eclipse User
Originally posted by: gcormier99.hotmail.com

I do have the same problem. I've created a file "welcome.jsp". Here the
content of the file:

<?xml version="1.0" encoding ="UTF-8"?>
<!DOCTYPE vxml PUBLIC "-//W3C//DTD VOICEXML 2.1//EN"
"http://www.w3.org/TR/voicexml21/vxml.dtd">
<%@ taglib uri="/tags/struts-bean" prefix="bean" %>
<%@ taglib uri="/tags/struts-html" prefix="html" %>
<%@ taglib uri="/tags/struts-logic" prefix="logic" %>

<vxml version="2.1" xmlns="http://www.w3.org/2001/vxml"
application="app-root.jsp">

<form>
<field name="nextChoice">
<prompt>
<audio src="http://localhost/audio/welcome.wav" />
</prompt>

<grammar mode="dtmf" root="root" version="1.0">
<rule id="root" scope="public">
<one-of>
<item>0</item>
</one-of>
</rule>
</grammar>
</field>

<block>
<submit next="http://localhost/next.do"/>
</block>
</form>
</vxml>


Eclipse is giving me a warning : Unknown tag (vxml).
Any idea? I opened the jsp file with "JSP Editor"
Re: JSP Validation [message #572829 is a reply to message #8724] Fri, 20 January 2006 14:34 Go to previous message
Eclipse User
Originally posted by: gcormier99.hotmail.com

I have add the content-type and it's now working. When I created the file,
Eclipse content assist is now working, but if I close the file and reopen
it with JSP Editor, it works fine.
Here's the new file:

<%@ page contentType="application/voicexml+xml; charset=UTF-8" %>
<?xml version="1.0" encoding ="UTF-8"?>
<!DOCTYPE vxml PUBLIC "-//W3C//DTD VOICEXML 2.1//EN"
"http://www.w3.org/TR/voicexml21/vxml.dtd">
<%@ taglib uri="/tags/struts-bean" prefix="bean" %>
<%@ taglib uri="/tags/struts-html" prefix="html" %>
<%@ taglib uri="/tags/struts-logic" prefix="logic" %>

<vxml version="2.1" xmlns="http://www.w3.org/2001/vxml"
application="app-root.jsp">
<form>
<field name="nextChoice">
<prompt>
<audio src="http://localhost/audio/welcome.wav" />
</prompt>
<grammar mode="dtmf" root="root" version="1.0">
<rule id="root" scope="public">
<one-of>
<item>0</item>
</one-of>
</rule>
</grammar>
</field>
<block>
<submit next="http://localhost/next.do"/>
</block>
</form>
</vxml>
Re: JSP Validation [message #572847 is a reply to message #8736] Sun, 22 January 2006 23:26 Go to previous message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Fri, 20 Jan 2006 09:34:09 -0500, GuiLL <gcormier99@hotmail.com> wrote:

> I have add the content-type and it's now working. When I created the file,
> Eclipse content assist is now working, but if I close the file and reopen
> it with JSP Editor, it works fine.
> Here's the new file:
>
> <%@ page contentType="application/voicexml+xml; charset=UTF-8" %>

Yes, I can confirm this content type is the key.
(we do still have a little hole that if you have a jsp fragment,
and can not re-specify the content type, we'll need to provide a
special "content settings" page -- hopefully that won't be a problem for
you ... at least until a future release :)

Do feel free to open bugs on WTP if you find problems. (I glance at this news
group occasionally ... but not as often as our bug lists :)
Previous Topic:Voice Tools Development Call Minutes: December 8, 2005
Next Topic:Cannot run the "Getting Started" example
Goto Forum:
  


Current Time: Sun Sep 21 04:08:56 GMT 2014

Powered by FUDForum. Page generated in 0.02112 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software