Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » How to change @author default field in Javadoc
How to change @author default field in Javadoc [message #803224] Tue, 21 February 2012 03:52 Go to next message
Matthew Brand is currently offline Matthew BrandFriend
Messages: 1
Registered: February 2012
Junior Member
When I type /** and press return to insert a Javadoc comment, Eclipse automatically writes for me

/**
*
* @author Bobby Brown
*
*/

because I am using the computer of my good friend Bobby Brown. Is there a setting for me to change so that it writes a different name in the author field?

Thanks.
Re: How to change @author default field in Javadoc [message #803340 is a reply to message #803224] Tue, 21 February 2012 07:58 Go to previous messageGo to next message
Dani Megert is currently offline Dani MegertFriend
Messages: 3801
Registered: July 2009
Senior Member
On 21.02.2012 04:52, Matthew Brand wrote:
> When I type /** and press return to insert a Javadoc comment, Eclipse
> automatically writes for me
> /**
> * * @author Bobby Brown
> *
> */
> because I am using the computer of my good friend Bobby Brown. Is
> there a setting for me to change so that it writes a different name in
> the author field?
Start Eclipse with the following VM argument: -Duser.name=YourName

Dani
>
> Thanks.
Re: How to change @author default field in Javadoc [message #803388 is a reply to message #803340] Tue, 21 February 2012 09:28 Go to previous messageGo to next message
Bimlesh Sharma is currently offline Bimlesh SharmaFriend
Messages: 2
Registered: February 2012
Junior Member
FOllow these steps should
create a user with your name.
login to your user and start writting code.
change computer name with your name.
It should fix your issue.
Re: How to change @author default field in Javadoc [message #803534 is a reply to message #803388] Tue, 21 February 2012 13:10 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3799
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2012.02.21 2:28, Bimlesh Sharma wrote:
> FOllow these steps should create a user with your name.
> login to your user and start writting code.
> change computer name with your name.
> It should fix your issue.

(Yeah, Bobby Brown will love that idea.)
Re: How to change @author default field in Javadoc [message #803607 is a reply to message #803224] Tue, 21 February 2012 15:00 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3799
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2/20/2012 8:52 PM, Matthew Brand wrote:
> When I type /** and press return to insert a Javadoc comment, Eclipse
> automatically writes for me
> /**
> * * @author Bobby Brown
> *
> */
> because I am using the computer of my good friend Bobby Brown. Is there
> a setting for me to change so that it writes a different name in the
> author field?
>
> Thanks.

There's also an alternative method given at "Alternative" in the note at
this link. This method will achieve the same result, but it will also
contaminate the workspace on Bobby's computer (but only that workspace).

http://www.javahotchocolate.com/notes/eclipse.html#author
Re: How to change @author default field in Javadoc [message #957444 is a reply to message #803224] Thu, 25 October 2012 08:24 Go to previous messageGo to next message
David Petrák is currently offline David PetrákFriend
Messages: 1
Registered: October 2012
Location: Martin, Slovakia
Junior Member
Simply go to:
Window - Preferences - Java - Code Style - Code Templates - Comments - Types - Edit... and change ${user} to whatever you want.

Also go to:
Window - Preferences - Java - Editor - Templates - @author - Edit... and change ${user} to whatever you want.
Re: How to change @author default field in Javadoc [message #1739693 is a reply to message #803224] Thu, 04 August 2016 00:01 Go to previous message
Benjamin Hogan is currently offline Benjamin HoganFriend
Messages: 1
Registered: August 2016
Junior Member
To change what shows after the existing @author, this works:

Window - Preferences - Java - Code Style - Code Templates - Comments - Types - Click Edit and change ${user} to what you want.

Previous Topic:JRE Crash creating Eclipse (Mars x32bit) GWT project on Windows 7 Enterprise
Next Topic:Eclipse takes very long time to delete files during build.
Goto Forum:
  


Current Time: Fri Dec 09 17:40:13 GMT 2016

Powered by FUDForum. Page generated in 0.08812 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software