Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » cdt make error:CreatePipe
cdt make error:CreatePipe [message #95939] Mon, 01 March 2004 21:48 Go to next message
Eclipse UserFriend
Originally posted by: Eltonzld.comcast.net

I installed cdt2.0M6, eclipse 3.0M6 and cygwin system on a windows98.
I run a DLL project build, I got an error message:

Error launching builder (make -f Makefile build )
(Exec error:CreatePipe)

Is there any suggustion?

Thanks,
Elton
Re: cdt make error:CreatePipe [message #95954 is a reply to message #95939] Mon, 01 March 2004 22:32 Go to previous messageGo to next message
Sean Evoy is currently offline Sean EvoyFriend
Messages: 197
Registered: July 2009
Senior Member
Elton,
The builder is failing when it tries to execute the make command. It
looks to me like it is finding it, but I cannot say for sure because you
have not provided us with a dump of the environment in which you are
using the CDT.

Not being able to launch make is a known problem for Win98, or at least
other people have reported problems on this newsgroup. We do not test
against that platform, and even though the FAQ says the CDT "should"
work on Win98, it also says it might not.

People have reported similar problems on Win2003 as well, but this seems
to be related to the way the path is being interpreted, not the actual
launching.

If your path is set properly, and if you can invoke make on the command
line, and if you are running Eclipse in the same shell and not some
other way, then all I can say is that the likely problem is Win98.

I hope this helps.

Sean Evoy

Elton wrote:

> I installed cdt2.0M6, eclipse 3.0M6 and cygwin system on a windows98.
> I run a DLL project build, I got an error message:
>
> Error launching builder (make -f Makefile build )
> (Exec error:CreatePipe)
>
> Is there any suggustion?
>
> Thanks,
> Elton
>
>
>
Re: cdt make error:CreatePipe [message #95969 is a reply to message #95954] Tue, 02 March 2004 01:47 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eltonzld.comcast.net

Hi Sean,

Thanks for helps.

I have tried to use a full path for make command such as
d:/cygwin/bin/make -f Makefile or
d:\cygwin\bin\make -f Maekfile

In my Makefile I also set full path of the compiler:
CC = d:/cygwin/bin/gcc

I can run the Makefile from command line. So Maybe the problem comes
from Win98 itself.

The other problem is each time when I open the project's properties and
then
click on the 'C/C++ Make Project', I always got an error message:

The current displayed page comtains invalide values.

What's this?

Thanks,
Elton


Sean Evoy wrote:

> Elton,
> The builder is failing when it tries to execute the make command. It
> looks to me like it is finding it, but I cannot say for sure because you
> have not provided us with a dump of the environment in which you are
> using the CDT.

> Not being able to launch make is a known problem for Win98, or at least
> other people have reported problems on this newsgroup. We do not test
> against that platform, and even though the FAQ says the CDT "should"
> work on Win98, it also says it might not.

> People have reported similar problems on Win2003 as well, but this seems
> to be related to the way the path is being interpreted, not the actual
> launching.

> If your path is set properly, and if you can invoke make on the command
> line, and if you are running Eclipse in the same shell and not some
> other way, then all I can say is that the likely problem is Win98.

> I hope this helps.

> Sean Evoy

> Elton wrote:

> > I installed cdt2.0M6, eclipse 3.0M6 and cygwin system on a windows98.
> > I run a DLL project build, I got an error message:
> >
> > Error launching builder (make -f Makefile build )
> > (Exec error:CreatePipe)
> >
> > Is there any suggustion?
> >
> > Thanks,
> > Elton
> >
> >
> >
Re: cdt make error:CreatePipe [message #96030 is a reply to message #95969] Tue, 02 March 2004 16:41 Go to previous messageGo to next message
Sean Evoy is currently offline Sean EvoyFriend
Messages: 197
Registered: July 2009
Senior Member
Sorry Elton,
The standard build UI isn't really my area of expertise. Typically, the
error you report is due to an NPE when the property page elements are
being assembled by Eclipse. There is some changes going on in the
standard build system, so maybe it is related to that.

Elton wrote:
> Hi Sean,
>
> Thanks for helps.
>
> I have tried to use a full path for make command such as
> d:/cygwin/bin/make -f Makefile or
> d:\cygwin\bin\make -f Maekfile
>
> In my Makefile I also set full path of the compiler:
> CC = d:/cygwin/bin/gcc
>
> I can run the Makefile from command line. So Maybe the problem comes
> from Win98 itself.
>
> The other problem is each time when I open the project's properties and
> then
> click on the 'C/C++ Make Project', I always got an error message:
>
> The current displayed page comtains invalide values.
>
> What's this?
>
> Thanks,
> Elton
>
>
> Sean Evoy wrote:
>
>
>>Elton,
>>The builder is failing when it tries to execute the make command. It
>>looks to me like it is finding it, but I cannot say for sure because you
>>have not provided us with a dump of the environment in which you are
>>using the CDT.
>
>
>>Not being able to launch make is a known problem for Win98, or at least
>>other people have reported problems on this newsgroup. We do not test
>>against that platform, and even though the FAQ says the CDT "should"
>>work on Win98, it also says it might not.
>
>
>>People have reported similar problems on Win2003 as well, but this seems
>>to be related to the way the path is being interpreted, not the actual
>>launching.
>
>
>>If your path is set properly, and if you can invoke make on the command
>>line, and if you are running Eclipse in the same shell and not some
>>other way, then all I can say is that the likely problem is Win98.
>
>
>>I hope this helps.
>
>
>>Sean Evoy
>
>
>>Elton wrote:
>
>
>>>I installed cdt2.0M6, eclipse 3.0M6 and cygwin system on a windows98.
>>>I run a DLL project build, I got an error message:
>>>
>>>Error launching builder (make -f Makefile build )
>>>(Exec error:CreatePipe)
>>>
>>>Is there any suggustion?
>>>
>>>Thanks,
>>>Elton
>>>
>>>
>>>
>
>
>
Re: cdt make error:CreatePipe [message #96239 is a reply to message #95939] Thu, 04 March 2004 20:27 Go to previous message
John Camelon is currently offline John CamelonFriend
Messages: 242
Registered: July 2009
Senior Member
Windows 98 has always been awkward.
Please raise a bug on the core.
Thanks

JC

"Elton" <Eltonzld@comcast.net> wrote in message
news:c20b46$46f$1@eclipse.org...
>
> I installed cdt2.0M6, eclipse 3.0M6 and cygwin system on a windows98.
> I run a DLL project build, I got an error message:
>
> Error launching builder (make -f Makefile build )
> (Exec error:CreatePipe)
>
> Is there any suggustion?
>
> Thanks,
> Elton
>
>
>
Previous Topic:Problem with upgrade to 1.21.
Next Topic:CDT Support Remote C/C++ Debug
Goto Forum:
  


Current Time: Sat Dec 20 13:50:40 GMT 2014

Powered by FUDForum. Page generated in 0.05588 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software