Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Error adding a part(Get an error when adding part to part stack)
Error adding a part [message #789869] Fri, 03 February 2012 14:11 Go to next message
Phill Perryman is currently offline Phill PerrymanFriend
Messages: 214
Registered: July 2009
Senior Member
Back to the tutorial. I have created ther perspective stack/partsashcontainer/part stack. When I add the part I get the error below.

Is this a bug or is it something strange with the various install and updates I have done to my installation. If it is a bug do I just log it in bugzilla.

It does not stop the app launching but I can't put labels etc on the part as it won't render in the editor.

eclipse.buildId=I20120127-1145
java.version=1.6.0_29
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86

Error
Fri Feb 03 14:01:45 GMT 2012
Problems occurred when invoking code from plug-in: "org.eclipse.jface".

java.lang.NoSuchFieldError: APPLICATION_ELEMENT__PERSISTED_STATE
at org.eclipse.e4.tools.emf.ui.internal.common.component.PartEditor.createForm(PartEditor.java:289)
at org.eclipse.e4.tools.emf.ui.internal.common.component.PartEditor.doGetEditor(PartEditor.java:130)
at org.eclipse.e4.tools.emf.ui.common.component.AbstractComponentEditor.getEditor(AbstractComponentEditor.java:120)
at org.eclipse.e4.tools.emf.ui.internal.common.ModelEditor$5$1.run(ModelEditor.java:522)
at org.eclipse.core.databinding.observable.ObservableTracker.runAndCollect(ObservableTracker.java:150)
at org.eclipse.core.databinding.ObservablesManager.runAndCollect(ObservablesManager.java:103)
at org.eclipse.e4.tools.emf.ui.internal.common.ModelEditor$5.selectionChanged(ModelEditor.java:519)
at org.eclipse.jface.viewers.Viewer$2.run(Viewer.java:164)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
at org.eclipse.jface.viewers.Viewer.fireSelectionChanged(Viewer.java:162)
at org.eclipse.jface.viewers.StructuredViewer.updateSelection(StructuredViewer.java:2188)
at org.eclipse.jface.viewers.StructuredViewer.handleSelect(StructuredViewer.java:1211)
at org.eclipse.jface.viewers.StructuredViewer$4.widgetSelected(StructuredViewer.java:1241)
at org.eclipse.jface.util.OpenStrategy.fireSelectionEvent(OpenStrategy.java:239)
at org.eclipse.jface.util.OpenStrategy.access$4(OpenStrategy.java:233)
at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrategy.java:403)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4165)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3754)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:999)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:893)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:85)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:579)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:534)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:352)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:624)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:579)
at org.eclipse.equinox.launcher.Main.run(Main.java:1433)

Re: Error adding a part [message #789876 is a reply to message #789869] Fri, 03 February 2012 14:25 Go to previous messageGo to next message
Thomas Kölling is currently offline Thomas KöllingFriend
Messages: 45
Registered: December 2011
Location: Munich
Member
Yes i think it's a bug. Having the same issue. Bug is already filled in BugZilla.
Re: Error adding a part [message #789936 is a reply to message #789876] Fri, 03 February 2012 15:46 Go to previous messageGo to next message
Phill Perryman is currently offline Phill PerrymanFriend
Messages: 214
Registered: July 2009
Senior Member
Ah well as I can't now attach Java code to the model my tutorial has come to a premature end. Do you know the bugzilla number so I can watch it to see when I can go back to playing. If not I will go search for it.
Re: Error adding a part [message #790059 is a reply to message #789936] Fri, 03 February 2012 19:15 Go to previous messageGo to next message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1049
Registered: July 2009
Senior Member

Works for me, can you add the class by entering the bundleclass URI directly?

The URI schema is described here: URI schema in Eclipse 4

[Updated on: Fri, 03 February 2012 19:16]

Report message to a moderator

Re: Error adding a part [message #790063 is a reply to message #790059] Fri, 03 February 2012 19:17 Go to previous messageGo to next message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1049
Registered: July 2009
Senior Member

And can you describe what you do to get this error?
Re: Error adding a part [message #791765 is a reply to message #790063] Mon, 06 February 2012 08:31 Go to previous messageGo to next message
Phill Perryman is currently offline Phill PerrymanFriend
Messages: 214
Registered: July 2009
Senior Member
I added a Part to the PartStack.
<children xsi:type="basic:PartSashContainer" xmi:id="_MDPXAE5mEeG5SvA2hAKwLg" elementId="sash" horizontal="true">
<children xsi:type="basic:PartStack" xmi:id="_NDeE8E5mEeG5SvA2hAKwLg" elementId="one">
<children xsi:type="basic:Part" xmi:id="_0t2IcE5mEeG5SvA2hAKwLg"/>
</children>
When I click on the Part in the Form tab in the model editor I get the error and the Part form does not render. The title changes from PartStack to Part but the rest of the form stays as the PartStack form. Hence I can't set the values for the Part as I cannot get the form to render.
Re: Error adding a part [message #791815 is a reply to message #790063] Mon, 06 February 2012 09:45 Go to previous messageGo to next message
Thomas Kölling is currently offline Thomas KöllingFriend
Messages: 45
Registered: December 2011
Location: Munich
Member
Hi Phil,

the Bug is described here:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=370538

the solution: you have to use the following repository:
http://download.eclipse.org/e4/downloads/drops/S-0.12M5-201201271145/repository

then install the e4 tooling stuff. then you have the latest model editor installed.
Re: Error adding a part [message #792117 is a reply to message #791815] Mon, 06 February 2012 16:32 Go to previous message
Phill Perryman is currently offline Phill PerrymanFriend
Messages: 214
Registered: July 2009
Senior Member
Thanks, I installed the sdk and then added the repository as an update site and installed everything and now I no longer get the error.
Previous Topic:Adding a Part from another plug-in to a Perspective
Next Topic:E4 application accessibility question
Goto Forum:
  


Current Time: Wed Nov 26 19:09:12 GMT 2014

Powered by FUDForum. Page generated in 0.02456 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software