Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » weblogic 9.2 debug port change(how to change the debug port that eclipse listens to)
weblogic 9.2 debug port change [message #788360] Wed, 01 February 2012 17:58
Missing name Missing name is currently offline Missing name Missing nameFriend
Messages: 2
Registered: April 2011
Location: Pittsburgh
Junior Member
Hi,

I am using Eclipse Version: Indigo Service Release 1, Build id: 20110916-0149, on Windows XP.

I recently installed support for all app servers including weblogic server v9.2 (that I use to develop). All works well if I setup with default configuration - I am able to start, debug and stop - no problems.

Trouble is when I want to setup another instance of weblogic server v9.2, and i want to change the debug port from default 8453 to some other port like 8454. Please see below the specific change that I do to the weblogic startup command file

Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,address=8454,server=y,suspend=n

But when I try to launch this server instance in debug mode, eclipse is unable to listen, because it still thinks the debug port is 8453. What is the change in eclipse "Weblogic Server configuration" that I need to do, to instruct eclipse that the port changed from 8453 to 8454. BTW, when I setup a remote debug configuration and supply 8454, it does work, but I dont want to do this - I want to be able to just hit debug button on the weblogic server and the eclipse configuration automatically to know that the debug listen port is 8454.

Kindly help.
Previous Topic:[Bug] Web Page Editor
Next Topic:Unable to create publisher org.eclipse.jst.server.generic.antpublisher
Goto Forum:
  


Current Time: Sat Dec 20 06:46:33 GMT 2014

Powered by FUDForum. Page generated in 0.02022 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software