Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Report with RunningCount Throws NullPointerException
Report with RunningCount Throws NullPointerException [message #779562] Sun, 15 January 2012 22:47 Go to next message
Arun P Johny is currently offline Arun P Johny
Messages: 3
Registered: July 2009
Location: Bangalore
Junior Member
Hi,

I'm trying to create a report with a RunningCount aggregation. The report is working fine when generated with the WebViewer within the report designer. But when the report is exported as a PDF from the designer it throws an NullPointerException as given below.
Caused by: java.lang.NullPointerException
	at org.eclipse.birt.core.util.IOUtil.writeInt(IOUtil.java:226)
	at org.eclipse.birt.core.util.IOUtil.writeObject(IOUtil.java:674)
	at org.eclipse.birt.data.engine.executor.transform.SimpleGroupCalculator.next(SimpleGroupCalculator.java:233)
	at org.eclipse.birt.data.engine.executor.transform.SimpleResultSet.next(SimpleResultSet.java:562)
	at org.eclipse.birt.data.engine.executor.transform.ResultSetWrapper.next(ResultSetWrapper.java:81)
	at org.eclipse.birt.data.engine.impl.ResultIterator.hasNextRow(ResultIterator.java:584)
	at org.eclipse.birt.data.engine.impl.ResultIterator.nextRow(ResultIterator.java:525)
	at org.eclipse.birt.data.engine.impl.ResultIterator.next(ResultIterator.java:475)
	at org.eclipse.birt.report.engine.data.dte.QueryResultSet.next(QueryResultSet.java:191)
	at org.eclipse.birt.report.engine.executor.ListingElementExecutor.hasNextChild(ListingElementExecutor.java:244)
	at org.eclipse.birt.report.engine.internal.executor.wrap.WrappedReportItemExecutor.hasNextChild(WrappedReportItemExecutor.java:86)
	at org.eclipse.birt.report.engine.internal.executor.wrap.WrappedReportItemExecutor.hasNextChild(WrappedReportItemExecutor.java:86)
	at org.eclipse.birt.report.engine.layout.html.HTMLBlockStackingLM.layoutNodes(HTMLBlockStackingLM.java:62)
	at org.eclipse.birt.report.engine.layout.html.HTMLStackingLM.layoutChildren(HTMLStackingLM.java:26)
	at org.eclipse.birt.report.engine.layout.html.HTMLTableLM.layoutChildren(HTMLTableLM.java:132)
	at org.eclipse.birt.report.engine.layout.html.HTMLAbstractLM.layout(HTMLAbstractLM.java:140)
	at org.eclipse.birt.report.engine.layout.html.HTMLBlockStackingLM.layoutNodes(HTMLBlockStackingLM.java:70)
	at org.eclipse.birt.report.engine.layout.html.HTMLPageLM.layout(HTMLPageLM.java:92)
	at org.eclipse.birt.report.engine.layout.html.HTMLReportLayoutEngine.layout(HTMLReportLayoutEngine.java:100)
	at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.doRun(RunAndRenderTask.java:180)


All other report forms like excel, word etc also is throwing the NullPointerException.

Is it a known issue with BIRT 3.7.1 or Am I doing something wrong? I'm attaching my test case below(A rptdesign file and a xml data file).

Please help me to solve this issue.

Thank you.
Re: Report with RunningCount Throws NullPointerException [message #780409 is a reply to message #779562] Tue, 17 January 2012 13:39 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

This does appear to be a bug for the runningcount aggregate. Can you
log a bugzilla request for this? To work around it can you add the
aggregate to the dataset as a computed column. See attached example.

Jasoon

On 1/15/2012 10:47 PM, Arun P Johny wrote:
> Hi,
>
> I'm trying to create a report with a RunningCount aggregation. The report is working fine when generated with the WebViewer within the report designer. But when the report is exported as a PDF from the designer it throws an NullPointerException as given below.
>
> Caused by: java.lang.NullPointerException
> at org.eclipse.birt.core.util.IOUtil.writeInt(IOUtil.java:226)
> at org.eclipse.birt.core.util.IOUtil.writeObject(IOUtil.java:674)
> at org.eclipse.birt.data.engine.executor.transform.SimpleGroupCalculator.next(SimpleGroupCalculator.java:233)
> at org.eclipse.birt.data.engine.executor.transform.SimpleResultSet.next(SimpleResultSet.java:562)
> at org.eclipse.birt.data.engine.executor.transform.ResultSetWrapper.next(ResultSetWrapper.java:81)
> at org.eclipse.birt.data.engine.impl.ResultIterator.hasNextRow(ResultIterator.java:584)
> at org.eclipse.birt.data.engine.impl.ResultIterator.nextRow(ResultIterator.java:525)
> at org.eclipse.birt.data.engine.impl.ResultIterator.next(ResultIterator.java:475)
> at org.eclipse.birt.report.engine.data.dte.QueryResultSet.next(QueryResultSet.java:191)
> at org.eclipse.birt.report.engine.executor.ListingElementExecutor.hasNextChild(ListingElementExecutor.java:244)
> at org.eclipse.birt.report.engine.internal.executor.wrap.WrappedReportItemExecutor.hasNextChild(WrappedReportItemExecutor.java:86)
> at org.eclipse.birt.report.engine.internal.executor.wrap.WrappedReportItemExecutor.hasNextChild(WrappedReportItemExecutor.java:86)
> at org.eclipse.birt.report.engine.layout.html.HTMLBlockStackingLM.layoutNodes(HTMLBlockStackingLM.java:62)
> at org.eclipse.birt.report.engine.layout.html.HTMLStackingLM.layoutChildren(HTMLStackingLM.java:26)
> at org.eclipse.birt.report.engine.layout.html.HTMLTableLM.layoutChildren(HTMLTableLM.java:132)
> at org.eclipse.birt.report.engine.layout.html.HTMLAbstractLM.layout(HTMLAbstractLM.java:140)
> at org.eclipse.birt.report.engine.layout.html.HTMLBlockStackingLM.layoutNodes(HTMLBlockStackingLM.java:70)
> at org.eclipse.birt.report.engine.layout.html.HTMLPageLM.layout(HTMLPageLM.java:92)
> at org.eclipse.birt.report.engine.layout.html.HTMLReportLayoutEngine.layout(HTMLReportLayoutEngine.java:100)
> at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.doRun(RunAndRenderTask.java:180)
>
>
> All other report forms like excel, word etc also is throwing the NullPointerException.
>
> Is it a known issue with BIRT 3.7.1 or Am I doing something wrong? I'm attaching my test case below(A rptdesign file and a xml data file).
>
> Please help me to solve this issue.
>
> Thank you.
Re: Report with RunningCount Throws NullPointerException [message #780411 is a reply to message #779562] Tue, 17 January 2012 13:39 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

This does appear to be a bug for the runningcount aggregate. Can you
log a bugzilla request for this? To work around it can you add the
aggregate to the dataset as a computed column. See attached example.

Jasoon

On 1/15/2012 10:47 PM, Arun P Johny wrote:
> Hi,
>
> I'm trying to create a report with a RunningCount aggregation. The report is working fine when generated with the WebViewer within the report designer. But when the report is exported as a PDF from the designer it throws an NullPointerException as given below.
>
> Caused by: java.lang.NullPointerException
> at org.eclipse.birt.core.util.IOUtil.writeInt(IOUtil.java:226)
> at org.eclipse.birt.core.util.IOUtil.writeObject(IOUtil.java:674)
> at org.eclipse.birt.data.engine.executor.transform.SimpleGroupCalculator.next(SimpleGroupCalculator.java:233)
> at org.eclipse.birt.data.engine.executor.transform.SimpleResultSet.next(SimpleResultSet.java:562)
> at org.eclipse.birt.data.engine.executor.transform.ResultSetWrapper.next(ResultSetWrapper.java:81)
> at org.eclipse.birt.data.engine.impl.ResultIterator.hasNextRow(ResultIterator.java:584)
> at org.eclipse.birt.data.engine.impl.ResultIterator.nextRow(ResultIterator.java:525)
> at org.eclipse.birt.data.engine.impl.ResultIterator.next(ResultIterator.java:475)
> at org.eclipse.birt.report.engine.data.dte.QueryResultSet.next(QueryResultSet.java:191)
> at org.eclipse.birt.report.engine.executor.ListingElementExecutor.hasNextChild(ListingElementExecutor.java:244)
> at org.eclipse.birt.report.engine.internal.executor.wrap.WrappedReportItemExecutor.hasNextChild(WrappedReportItemExecutor.java:86)
> at org.eclipse.birt.report.engine.internal.executor.wrap.WrappedReportItemExecutor.hasNextChild(WrappedReportItemExecutor.java:86)
> at org.eclipse.birt.report.engine.layout.html.HTMLBlockStackingLM.layoutNodes(HTMLBlockStackingLM.java:62)
> at org.eclipse.birt.report.engine.layout.html.HTMLStackingLM.layoutChildren(HTMLStackingLM.java:26)
> at org.eclipse.birt.report.engine.layout.html.HTMLTableLM.layoutChildren(HTMLTableLM.java:132)
> at org.eclipse.birt.report.engine.layout.html.HTMLAbstractLM.layout(HTMLAbstractLM.java:140)
> at org.eclipse.birt.report.engine.layout.html.HTMLBlockStackingLM.layoutNodes(HTMLBlockStackingLM.java:70)
> at org.eclipse.birt.report.engine.layout.html.HTMLPageLM.layout(HTMLPageLM.java:92)
> at org.eclipse.birt.report.engine.layout.html.HTMLReportLayoutEngine.layout(HTMLReportLayoutEngine.java:100)
> at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.doRun(RunAndRenderTask.java:180)
>
>
> All other report forms like excel, word etc also is throwing the NullPointerException.
>
> Is it a known issue with BIRT 3.7.1 or Am I doing something wrong? I'm attaching my test case below(A rptdesign file and a xml data file).
>
> Please help me to solve this issue.
>
> Thank you.
Re: Report with RunningCount Throws NullPointerException [message #780414 is a reply to message #779562] Tue, 17 January 2012 13:39 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

This does appear to be a bug for the runningcount aggregate. Can you
log a bugzilla request for this? To work around it can you add the
aggregate to the dataset as a computed column. See attached example.

Jasoon

On 1/15/2012 10:47 PM, Arun P Johny wrote:
> Hi,
>
> I'm trying to create a report with a RunningCount aggregation. The report is working fine when generated with the WebViewer within the report designer. But when the report is exported as a PDF from the designer it throws an NullPointerException as given below.
>
> Caused by: java.lang.NullPointerException
> at org.eclipse.birt.core.util.IOUtil.writeInt(IOUtil.java:226)
> at org.eclipse.birt.core.util.IOUtil.writeObject(IOUtil.java:674)
> at org.eclipse.birt.data.engine.executor.transform.SimpleGroupCalculator.next(SimpleGroupCalculator.java:233)
> at org.eclipse.birt.data.engine.executor.transform.SimpleResultSet.next(SimpleResultSet.java:562)
> at org.eclipse.birt.data.engine.executor.transform.ResultSetWrapper.next(ResultSetWrapper.java:81)
> at org.eclipse.birt.data.engine.impl.ResultIterator.hasNextRow(ResultIterator.java:584)
> at org.eclipse.birt.data.engine.impl.ResultIterator.nextRow(ResultIterator.java:525)
> at org.eclipse.birt.data.engine.impl.ResultIterator.next(ResultIterator.java:475)
> at org.eclipse.birt.report.engine.data.dte.QueryResultSet.next(QueryResultSet.java:191)
> at org.eclipse.birt.report.engine.executor.ListingElementExecutor.hasNextChild(ListingElementExecutor.java:244)
> at org.eclipse.birt.report.engine.internal.executor.wrap.WrappedReportItemExecutor.hasNextChild(WrappedReportItemExecutor.java:86)
> at org.eclipse.birt.report.engine.internal.executor.wrap.WrappedReportItemExecutor.hasNextChild(WrappedReportItemExecutor.java:86)
> at org.eclipse.birt.report.engine.layout.html.HTMLBlockStackingLM.layoutNodes(HTMLBlockStackingLM.java:62)
> at org.eclipse.birt.report.engine.layout.html.HTMLStackingLM.layoutChildren(HTMLStackingLM.java:26)
> at org.eclipse.birt.report.engine.layout.html.HTMLTableLM.layoutChildren(HTMLTableLM.java:132)
> at org.eclipse.birt.report.engine.layout.html.HTMLAbstractLM.layout(HTMLAbstractLM.java:140)
> at org.eclipse.birt.report.engine.layout.html.HTMLBlockStackingLM.layoutNodes(HTMLBlockStackingLM.java:70)
> at org.eclipse.birt.report.engine.layout.html.HTMLPageLM.layout(HTMLPageLM.java:92)
> at org.eclipse.birt.report.engine.layout.html.HTMLReportLayoutEngine.layout(HTMLReportLayoutEngine.java:100)
> at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.doRun(RunAndRenderTask.java:180)
>
>
> All other report forms like excel, word etc also is throwing the NullPointerException.
>
> Is it a known issue with BIRT 3.7.1 or Am I doing something wrong? I'm attaching my test case below(A rptdesign file and a xml data file).
>
> Please help me to solve this issue.
>
> Thank you.
Re: Report with RunningCount Throws NullPointerException [message #780498 is a reply to message #780414] Wed, 18 January 2012 05:40 Go to previous message
Arun P Johny is currently offline Arun P Johny
Messages: 3
Registered: July 2009
Location: Bangalore
Junior Member
Dear Jason,

Thanks for your time.

As you suggested I've posted a ticket in Bugzilla. Please find the link for future references.

bugs.eclipse.org/bugs/show_bug.cgi?id=368904
Previous Topic:Emdeb word document in Birt Report?
Next Topic:Setting a default DB Connection
Goto Forum:
  


Current Time: Thu Aug 21 18:05:14 EDT 2014

Powered by FUDForum. Page generated in 0.01765 seconds