Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Republish does not work (static resources)
Republish does not work (static resources) [message #776082] Sat, 07 January 2012 11:49 Go to next message
Paul Pentosa is currently offline Paul Pentosa
Messages: 3
Registered: January 2012
Junior Member
When i run my webapp in eclipse i get an 404 error as soon as i call the dispatcher Servlet. First i thought there must be something wrong in the code but everthing seemed to be fine.

I looked up the org.eclipse.wst.server.core and the classes folder of the wtpwebapps was empty, so it's clear that Tomcat can't find the class file.

I exported the project as a war file and deployed it with the manager app of the tomcat gui. This time it worked without a problem. After that i tried it again in eclipse and here it worked, too. So i again looked up the classes folder in wtpwebapps and found the comiled servlets.

Update:

it happens that the content of my dynamic web project does not get published correctly. The web module and the server are marked as "Synchronized", but only partial content is deployed to wtpwebapps. I have to remove the project from the server, then do a rightclick --> Build Project and add again the web module to fix the problem.

When i modify a jsp, i immediately see in the servers tab that tomcat republishes. If i do the same with servlet no change takes place in the tab.

So why does Tomcat not republishes the static resources ?

I am new to java/webapplications and eclipse, so please tell me what i'm doing wrong.

Thank you in advance,

Paul Pentosa
Re: Republish does not work (static resources) [message #776471 is a reply to message #776082] Sun, 08 January 2012 13:58 Go to previous messageGo to next message
Mauro Molinari is currently offline Mauro Molinari
Messages: 278
Registered: July 2009
Senior Member
Il 07/01/2012 12:49, Paul Pentosa ha scritto:
> it happens that the content of my dynamic web project does not get
> published correctly. The web module and the server are marked as
> "Synchronized", but only partial content is deployed to wtpwebapps. I
> have to remove the project from the server, then do a rightclick -->
> Build Project and add again the web module to fix the problem.
>
> When i modify a jsp, i immediately see in the servers tab that tomcat
> republishes. If i do the same with servlet no change takes place in the
> tab.
>
> So why does Tomcat not republishes the static resources ?

A servlet is not a static resource. Do you have "Build automatically"
disabled?

Mauro.
Re: Republish does not work (static resources) [message #776476 is a reply to message #776471] Sun, 08 January 2012 14:16 Go to previous messageGo to next message
Paul Pentosa is currently offline Paul Pentosa
Messages: 3
Registered: January 2012
Junior Member
Hello Mauro,

in the Overview of Tomcat
Automatically publish when resource change
is enabled.
Re: Republish does not work (static resources) [message #777091 is a reply to message #776476] Mon, 09 January 2012 20:33 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2310
Registered: July 2009
Senior Member
On 1/8/2012 9:16 AM, Paul Pentosa wrote:
> in the Overview of Tomcat Automatically publish when resource change
> is enabled.

That's not what was asked. The quickest way to check is from the main
menubar's Project menu. If it's not on, turn it on.

--
---
Nitin Dahyabhai
Eclipse WTP Source Editing and JSDT
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Republish does not work (static resources) [message #779875 is a reply to message #777091] Mon, 16 January 2012 18:12 Go to previous message
Paul Pentosa is currently offline Paul Pentosa
Messages: 3
Registered: January 2012
Junior Member
Hey Guys,

thanks so much for your answer. Indeed "Built automatically" was disabled. I don't know why it was disabled but now it's working Smile
Previous Topic:Configure existing TOMCAT project
Next Topic:Graceful shutdown of Tomcat - How?
Goto Forum:
  


Current Time: Sun Oct 26 01:53:45 GMT 2014

Powered by FUDForum. Page generated in 0.03637 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software