Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Guava dependency Xtext Builder 2.2.1(requires bundle com.google.guava 1.0.0 - shouldnt this be 10.0.1?)
Guava dependency Xtext Builder 2.2.1 [message #766202] Thu, 15 December 2011 06:06 Go to next message
Dana W is currently offline Dana W
Messages: 19
Registered: July 2009
Junior Member
Dear Xtext team,

We have just noticed that the dependencies for the Xtext Builder in 2.2.1 requires com.google.guava - but version 1.0.0. Is this done on purpose? Should it be 10.0.1?
Is the google inject dependency also correct?

http://git.eclipse.org/c/tmf/org.eclipse.xtext.git/tree/plugins/org.eclipse.xtext.builder/META-INF/MANIFEST.MF

We've just encountered problems with building our new target.

Thank you!
Kind regards,
Dana
Re: Guava dependency Xtext Builder 2.2.1 [message #766325 is a reply to message #766202] Thu, 15 December 2011 10:00 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4031
Registered: July 2009
Senior Member
Hi

Are you sure that is your problem?

The Eclipse OCL editors broke on M4 because the OCL editors had a
com.google.collect plugin dependency while Xtext used com.google.guava
to provide the common.google.common.collect package. Consequently two
different flavours of the one package ....

Make sure you have no old references to com.google.collect.

Regards

Ed Willink

On 15/12/2011 03:07, dw wrote:
> Dear Xtext team,
>
> We have just noticed that the dependencies for the Xtext Builder in
> 2.2.1 requires com.google.guava - but version 1.0.0. Is this done on
> purpose? Should it be 10.0.1?
> Is the google inject dependency also correct?
>
> http://git.eclipse.org/c/tmf/org.eclipse.xtext.git/tree/plugins/org.eclipse.xtext.builder/META-INF/MANIFEST.MF
>
>
> We've just encountered problems with building our new target.
>
> Thank you!
> Kind regards,
> Dana
Re: Guava dependency Xtext Builder 2.2.1 [message #766789 is a reply to message #766202] Fri, 16 December 2011 07:38 Go to previous message
Sebastian Zarnekow is currently offline Sebastian Zarnekow
Messages: 2809
Registered: July 2009
Senior Member
Hi Dana,

the version constraint looks bogus to me. Could you please file a ticket?

Thanks,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 15.12.11 12:07, schrieb dw:
> Dear Xtext team,
>
> We have just noticed that the dependencies for the Xtext Builder in
> 2.2.1 requires com.google.guava - but version 1.0.0. Is this done on
> purpose? Should it be 10.0.1?
> Is the google inject dependency also correct?
>
> http://git.eclipse.org/c/tmf/org.eclipse.xtext.git/tree/plugins/org.eclipse.xtext.builder/META-INF/MANIFEST.MF
>
>
> We've just encountered problems with building our new target.
>
> Thank you!
> Kind regards,
> Dana
Previous Topic:Multi-Modelling with xText
Next Topic:Xtend2 not fully functional after upgrading to Xtext 2.2.1
Goto Forum:
  


Current Time: Sat Aug 23 15:57:05 EDT 2014

Powered by FUDForum. Page generated in 0.10440 seconds