Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » I get this and stopped when went install some js/jquery plugins(how proceed)
I get this and stopped when went install some js/jquery plugins [message #763824] Sat, 10 December 2011 17:17 Go to next message
LSE  is currently offline LSE
Messages: 37
Registered: July 2009
Member
this posted by error here:
http://www.eclipse.org/forums/index.php/m/763487/#msg_763487

I get this and stopped when went install some js/jquery plugins...
how proceed???

Cannot complete the install because one or more required items could not be found.
Software being installed: JSDT jQuery Integration 1.3.0 (org.eclipselabs.jsdt.jquery_feature.feature.group 1.3.0)
Missing requirement: JSDT jQuery UI 1.3.0 (org.eclipselabs.jsdt.jquery.ui 1.3.0) requires 'bundle org.eclipse.core.runtime [3.7.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: JSDT jQuery Integration 1.3.0 (org.eclipselabs.jsdt.jquery_feature.feature.group 1.3.0)
To: org.eclipselabs.jsdt.jquery.ui [1.3.0]

I have:

Eclipse Java EE IDE for Web Developers.
Version: Helios Service Release 1
Build id: 20100917-0705

Is it needed install ECLIPSE-JAVASCRIPT,...? Any way how install this in current install, not separate install???
Re: I get this and stopped when went install some js/jquery plugins [message #764053 is a reply to message #763824] Sun, 11 December 2011 07:54 Go to previous messageGo to next message
Michael Pellaton is currently offline Michael Pellaton
Messages: 289
Registered: July 2009
Senior Member
Hi

> ... requires 'bundle org.eclipse.core.runtime [3.7.0,4.0.0)'

> I have:
> ... Version: Helios Service Release 1
Helios is Eclipse 3.6 and the dependency requires 3.7 (Indigo).

BTW, the developer clearly says that 3.7 is required on the market place
[1] and again in this bug report [2] which is similar to your
question.

[1] http://marketplace.eclipse.org/content/jsdt-jquery
[2]
https://code.google.com/a/eclipselabs.org/p/jsdt-jquery/issues/detail?id=1

Cheers,
Michael
Re: I get this and stopped when went install some js/jquery plugins [message #764115 is a reply to message #764053] Sun, 11 December 2011 11:57 Go to previous messageGo to next message
LSE  is currently offline LSE
Messages: 37
Registered: July 2009
Member
THERE IS NO EQUIVALENT PLUG IN FOR MY VERSION?

OR

ECLIPSE-JAVASCRIPT,...? how install this in current install TO MY HELIOS JAVA EE IDE, not separate install???
Re: I get this and stopped when went install some js/jquery plugins [message #764203 is a reply to message #764115] Sun, 11 December 2011 16:45 Go to previous messageGo to next message
Michael Pellaton is currently offline Michael Pellaton
Messages: 289
Registered: July 2009
Senior Member
> THERE IS NO EQUIVALENT PLUG IN FOR MY VERSION?
In short: no.
Re: I get this and stopped when went install some js/jquery plugins [message #764214 is a reply to message #764203] Sun, 11 December 2011 17:16 Go to previous messageGo to next message
LSE  is currently offline LSE
Messages: 37
Registered: July 2009
Member
ok, so how about installing JavaScript(Eclipse) IDE in current installation...in my Helios... what steps follow...? again not new eclipse install...
Re: I get this and stopped when went install some js/jquery plugins [message #764269 is a reply to message #764214] Sun, 11 December 2011 20:10 Go to previous messageGo to next message
Michael Pellaton is currently offline Michael Pellaton
Messages: 289
Registered: July 2009
Senior Member
It does not work.

If the requirement is org.eclipse.core.runtime [3.7.0,4.0.0) it really
_is_ Eclipse 3.7.0 up to and not including 4.0.0.

Michael
Re: I get this and stopped when went install some js/jquery plugins [message #764284 is a reply to message #764269] Sun, 11 December 2011 20:51 Go to previous messageGo to next message
LSE  is currently offline LSE
Messages: 37
Registered: July 2009
Member
Michael Pellaton wrote on Sun, 11 December 2011 15:10
It does not work.

If the requirement is org.eclipse.core.runtime [3.7.0,4.0.0) it really
_is_ Eclipse 3.7.0 up to and not including 4.0.0.

Michael



You haven't old ECLIPSE javascript ide [NOT STAND ALONE] downloads for HELIOS?

I mean IDE and Not plugins...
Re: I get this and stopped when went install some js/jquery plugins [message #764391 is a reply to message #764284] Mon, 12 December 2011 04:40 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1344
Registered: July 2009
Senior Member
On 12/11/2011 02:51 PM, LSE wrote:
> Michael Pellaton wrote on Sun, 11 December 2011 15:10
>> It does not work.
>>
>> If the requirement is org.eclipse.core.runtime [3.7.0,4.0.0) it really
>> _is_ Eclipse 3.7.0 up to and not including 4.0.0.
>>
>> Michael
>
>
>
> You haven't old ECLIPSE javascript ide [NOT STAND ALONE] downloads for
> HELIOS?
>
> I mean IDE and Not plugins...
You really need to take this up with the developer of the plugin you are
trying to install. It is from a third party and not affiliated with
Eclipse.
Re: I get this and stopped when went install some js/jquery plugins [message #764440 is a reply to message #764391] Mon, 12 December 2011 07:22 Go to previous messageGo to next message
Michael Pellaton is currently offline Michael Pellaton
Messages: 289
Registered: July 2009
Senior Member
Hi

> You really need to take this up with the developer of the plugin you are
> trying to install. It is from a third party and not affiliated with
> Eclipse.
Well, I don't think so. The final answer is here and has been since my
first reply to this thread.

I know the guy - Philippe - providing the JSDT JQuery extension
personally as we both work for the same company and we both form the
"Eclipse crew" providing our inhouse Eclipse distribution. He even
mentioned that people keep bugging him about this despite his clear
statements on the issue.

On the marketplace [1] he states: "If you have trouble installing this
plugin it's likely that you don't have Eclipse 3.7." Besides that,
there is a bug report [2] about the exact issue discussed here and in
this case, he again clearly states "Helios / Eclipse 3.6 is not
supported. You need at least Indigo / 3.7.".

So, I'd like to end this thread with two conclusions:
a) JSDT JQuery requires Eclipse 3.7 or greater
b) Philippe is sure about this issue and he has discussed it over and
over again and he is no likely to change that.

Sorry, no luck - update to Indigo.

[1] http://marketplace.eclipse.org/content/jsdt-jquery
[2]
https://code.google.com/a/eclipselabs.org/p/jsdt-jquery/issues/detail?id=1

Michael
Re: I get this and stopped when went install some js/jquery plugins [message #764505 is a reply to message #764391] Mon, 12 December 2011 10:15 Go to previous messageGo to next message
LSE  is currently offline LSE
Messages: 37
Registered: July 2009
Member
"dpwegener: You really need to take this up with the developer of the plugin you are
trying to install. It is from a third party and not affiliated with
Eclipse."

I do not speak for the 3rd party plug-in anymore, but for the original
ECLIPSE javascript ide [NOT STAND ALONE]
like the
ECLIPSE java ee ide [NOT STAND ALONE]
<> // I have this [STAND ALONE] so need install ECLIPSE javascript ide [NOT STAND ALONE] over it, this from which come from Eclipse meant...
Re: I get this and stopped when went install some js/jquery plugins [message #764794 is a reply to message #764214] Mon, 12 December 2011 21:21 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric Rizzo
Messages: 2308
Registered: July 2009
Senior Member
On 12/11/11 12:16 PM, LSE wrote:
> ok, so how about installing JavaScript(Eclipse) IDE in current
> installation...in my Helios... what steps follow...? again not new
> eclipse install...

Open Help > Install New Software...
Select the Helios update site from the drop-down list at the top.
Search the list of available features for JavaScript.
Install what you want.

Eric
Re: I get this and stopped when went install some js/jquery plugins [message #764809 is a reply to message #764794] Mon, 12 December 2011 22:14 Go to previous messageGo to next message
LSE  is currently offline LSE
Messages: 37
Registered: July 2009
Member
I mean in the menu choice [upper/right corner] choose IDE:

JAVA, JAVA EE, ANDROID DDMS, JAVA BROWSING

Can Appear Javascript choice? how? I guest by installing Eclipse Javascript IDE [like the java ide, the whole Eclipse ide soft i have], NOT PLUGINS... I INSTALLED JAVASCRIPT choices like "JAVASCRIPT dev tools" but not appeared, well is any way install Eclipse Javascript IDE upon this installation NOT stand alone ver but install over this installation [so not need open new IDE to work purely with javascript but from same ide] or there isn't?
Re: I get this and stopped when went install some js/jquery plugins [message #764932 is a reply to message #764809] Tue, 13 December 2011 05:47 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2308
Registered: July 2009
Senior Member
It sounds like it's not properly installed, then.

To put it simply, you have Helios. You need Indigo. There's no getting around that for using the plug-ins you mentioned at the start of this thread.

The menu you're referring to is just listing the predefined Perspectives. There's nothing special about a Perspective, it's just a set of views, in a layout, with specific menu and toolbar contributions enabled. Nothing prevents you from working with JavaScript files in any Perspective you choose, even in Perspectives you create yourself. You should have one for JavaScript if that's been installed properly. Regardless, you'll have to move up to Indigo for the plug-ins you want. You can get the JavaScript tools as part of Indigo's "Eclipse IDE for JavaScript Web Developers". It's listed right on http://download.eclipse.org .


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: I get this and stopped when went install some js/jquery plugins [message #765144 is a reply to message #764932] Tue, 13 December 2011 13:58 Go to previous messageGo to next message
LSE  is currently offline LSE
Messages: 37
Registered: July 2009
Member
Eclipse IDE for JavaScript Web Developers,
if install this stand alone, I should install indigo even Java ide is Helios?

This (Eclipse IDE for JavaScript Web Developers) what server languages any support? PHP, java? color coding, or/and code completion...

If want include to Eclipse IDE for JavaScript Web Developers, and Eclipse php ide both indigo what to do(both in one)?

[Updated on: Tue, 13 December 2011 14:01]

Report message to a moderator

Re: I get this and stopped when went install some js/jquery plugins [message #765216 is a reply to message #765144] Tue, 13 December 2011 16:34 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2308
Registered: July 2009
Senior Member
On 12/13/2011 8:59 AM, LSE wrote:
> Eclipse IDE for JavaScript Web Developers,
> if install this stand alone, I should install indigo even Java ide is
> Helios?
>
> This (Eclipse IDE for JavaScript Web Developers) what server languages
> any support? PHP, java? color coding, or/and code completion...

The Indigo download would serve as a fresh start. DO NOT simply unpack
it over an existing copy of Eclipse. If you want both Java and
JavaScript support, you can get the Java EE package, or get either of
the Java or JavaScript Web packages and install the Indigo version of
the other feature from there.

--
---
Nitin Dahyabhai
Eclipse WTP Source Editing and JSDT
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: I get this and stopped when went install some js/jquery plugins [message #765251 is a reply to message #765216] Tue, 13 December 2011 17:41 Go to previous messageGo to next message
LSE  is currently offline LSE
Messages: 37
Registered: July 2009
Member
what if I want leave Java/ee with Helios and, want install stand alone, PHP and javascript IDEs INDIGO in one, then I must download both or download one then use help menu to get the other...in this case what first install PHP or javascript?
Re: I get this and stopped when went install some js/jquery plugins [message #765351 is a reply to message #765251] Tue, 13 December 2011 22:23 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1344
Registered: July 2009
Senior Member
Pick one to install. Go to Help->Install New Software to add the additional features you need.
Re: I get this and stopped when went install some js/jquery plugins [message #765513 is a reply to message #765351] Wed, 14 December 2011 08:24 Go to previous message
LSE  is currently offline LSE
Messages: 37
Registered: July 2009
Member
Eclipse IDE for JavaScript Web Developers this includes jQuery color coding & code completion? when indigo came out? next version when will be?
Previous Topic:workspace or project? 3-mercurials + n-parts inside
Next Topic:Java Formatter settings for casts
Goto Forum:
  


Current Time: Wed Oct 22 00:04:09 GMT 2014

Powered by FUDForum. Page generated in 0.02332 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software