Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Expanding a Tree by Index Path
Expanding a Tree by Index Path [message #759515] Mon, 28 November 2011 21:38 Go to next message
Chris Missing name is currently offline Chris Missing name
Messages: 32
Registered: June 2011
Member
Im having difficulty expanding a tree by Index path. Looking over the documentation it seems indicies start at 1 and it expects a string, with slashes to separate children from parent nodes. I have followed this example to attempt to expand the root node, and Im unsure of why it is not working. It is likely a silly mistake on my part.

I was able to get the expansion to work by textpath using the exact same component name so I am confident it is not an object mapping issue. I currently am using ub_tre_expandNode_byIndexpath to attempt this with absolute path type, 0 pre-ascend, and an index path string of "1", (I have also tried unsuccessfully with "1/1"), but the test always fails with an Activation Error - Invalid Index. Could someone please provide an example of valid indicies or some indication of why it is not working?

[Updated on: Mon, 28 November 2011 21:43]

Report message to a moderator

Re: Expanding a Tree by Index Path [message #759554 is a reply to message #759515] Tue, 29 November 2011 07:24 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1157
Registered: July 2009
Senior Member
Hm, I'm not sure why neither 1 nor 1/1 are working, especially if the expand by textpath works. Is there a log entry written in the client or agent log that gives more information? What kind of tree in what kind of application is it? On the other hand, did you know that select and check actions in trees expand the tree to the place they are selecting or checking, so an explicit expand is usually not necessary? (This doesn't mean I'm not interested in finding out what's going on with the expand, it just may alter the blockage for you Wink )

Best regards,
Alex

Re: Expanding a Tree by Index Path [message #759735 is a reply to message #759554] Tue, 29 November 2011 19:23 Go to previous messageGo to next message
Chris Missing name is currently offline Chris Missing name
Messages: 32
Registered: June 2011
Member
I am testing an Eclipse plug-in. The AUT Agent and Client error logs show nothing relevant. I will investigate using the select actions as a work around. I would be happy to include any additional information that would help get to the bottom of this.

Thanks,
Re: Expanding a Tree by Index Path [message #759746 is a reply to message #759735] Tue, 29 November 2011 20:10 Go to previous messageGo to next message
Chris Missing name is currently offline Chris Missing name
Messages: 32
Registered: June 2011
Member
Selection by Text path works as well, but when I try selection by index path it is exhibiting the same Action Error - Invalid Index that I previously encountered. The object I am trying to interact with is of type org.eclipse.swt.widgets.Tree

[Updated on: Tue, 29 November 2011 21:22]

Report message to a moderator

Re: Expanding a Tree by Index Path [message #759811 is a reply to message #759746] Wed, 30 November 2011 07:50 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1157
Registered: July 2009
Senior Member
Just to check - are you using the quotes to enter the indexpaths "1/1" or are you doing it without quotes: 1/1 ?
Without quotes would be the correct way.

Regards,
Alex
Re: Expanding a Tree by Index Path [message #759953 is a reply to message #759811] Wed, 30 November 2011 16:59 Go to previous messageGo to next message
Chris Missing name is currently offline Chris Missing name
Messages: 32
Registered: June 2011
Member
Wow good check. That was the issue. The documentation uses quotes when it specifies a command and I incorrectly took that to mean the quotes were part of it. Thanks for the help on this.
Re: Expanding a Tree by Index Path [message #760073 is a reply to message #759953] Thu, 01 December 2011 08:50 Go to previous message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1157
Registered: July 2009
Senior Member
I have to admit, I only thought of it because someone in another thread asked about the quotes Smile I've updated the documentation to specify "without quotes" - so a newer version will be clearer on that.

Best regards,
Alex
Previous Topic:autrun and complex_app_init test case
Next Topic:ub_app_restart restarts app to fast
Goto Forum:
  


Current Time: Fri Oct 31 12:26:49 GMT 2014

Powered by FUDForum. Page generated in 0.02125 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software