Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Still get nothing to build error
Still get nothing to build error [message #755841] Wed, 09 November 2011 19:04 Go to next message
serkan.ozer is currently offline serkan.ozer
Messages: 1
Registered: November 2011
Junior Member
I am getting this error when im trying to run a project.I added the C:\mingw\bin to my path variable and here is my path variable C:\Program Files (x86)\MiKTeX 2.9\miktex\bin;%CommonProgramFiles%\Microsoft Shared\Windows Live;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\FPC\2.4.4\bin\i386-Win32;C:\MinGW\bin;

After I build the project " nothing to build for x " is printed on console and suddenly it disappears resulting with a blank screen instead of an output. Only time I got the output properly is that I manually add a path variable(C:\mingw\bin ) in run configurations but I don't want to make this for every different file. Please help.

##I am using windows 7 64 bit by the way.
Re: Still get nothing to build error [message #756422 is a reply to message #755841] Sun, 13 November 2011 07:21 Go to previous messageGo to next message
Gerald Kozina is currently offline Gerald Kozina
Messages: 7
Registered: November 2011
Junior Member
If it built once, then you may still have .obj's and an .exe
Try using the clean option to delete them and rebuild.

I see the same problem with MinGW.

For Visual C the problem is worse, I get no obj and no exe
and it tells me it has nothing to build any way.

But I can get visual C to build using an existing make file or
using a batch file that executes the build steps.

So far I have been quite frustrated as there seems no
easy way to get any information on why it does not see anything to build.
Or detail of the path it takes internally.

Cheers,
Jerry
Re: Still get nothing to build error [message #829645 is a reply to message #756422] Mon, 26 March 2012 15:37 Go to previous messageGo to next message
TimMarc Cannon is currently offline TimMarc Cannon
Messages: 1
Registered: March 2012
Junior Member
I have exactly the same problem. I am making my first attempt to run a program under Eclipse. I am using C++ under Windows XP with the MinGW toolchain. I precisely followed the tutorial instructions for creating the "HelloWorld" program. When I attempt to run, I get the error "Nothing to build for HelloWorld".

The executable gets created. I have tried running it directly (outside the Eclipse debugger), and I get the message: "libgcc_s_dw2-1.dll was not found". Since that file is on mingw\bin, I suspect there may be a problem with my path.

There are still some things I can try. But I think the best option may be to use a different SDK.
Re: Still get nothing to build error [message #1402973 is a reply to message #829645] Sat, 19 July 2014 03:40 Go to previous message
Cesar Gonzales is currently offline Cesar Gonzales
Messages: 1
Registered: July 2014
Junior Member
I had the same problem. I finally resolved everything by carefully following the directions for installing MinGW which require that you install the C and C++ compilers and MSYS basic system, and MinGW developer toolk packages. Also make sure that C:\MinGW\bin;C:\MinGW\msys\1.0\bin are added to your Path system variables. Insuring all of these did the trick for me.
Previous Topic:C Editor, Strg+Shift+/ -> Change // to /**/
Next Topic: "make" is not found in PATH hello
Goto Forum:
  


Current Time: Tue Sep 16 05:18:08 GMT 2014

Powered by FUDForum. Page generated in 0.36351 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software