Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn Intent » Incomplete Dependencies on Update Site
Incomplete Dependencies on Update Site [message #754931] Sat, 05 November 2011 10:03 Go to next message
Marcel Bruch is currently offline Marcel BruchFriend
Messages: 230
Registered: July 2009
Senior Member
Hi,


installing from 0.7 update site fails with some missing dependencies. I'm using a classic Eclipse packaging w/o any EMF stuff installed. Does it make sense to add some EMF features on your dependencies section too - just for those guys that don't have any Mylyn or EMF feature installed?

Best,
Marcel

Cannot complete the install because one or more required items could not be found.
Software being installed: Mylyn Intent (Incubation) 0.7.0.201110271120 (org.eclipse.mylyn.docs.intent.feature.group 0.7.0.201110271120)
Missing requirement: EMF Compare differencer 1.2.1.v20110926-1308 (org.eclipse.emf.compare.diff 1.2.1.v20110926-1308) requires 'bundle org.eclipse.emf.ecore 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Intent Compare 0.7.0.201110271120 (org.eclipse.mylyn.docs.intent.compare 0.7.0.201110271120)
To: bundle org.eclipse.emf.compare.diff 1.2.1
Cannot satisfy dependency:
From: Mylyn Intent (Incubation) 0.7.0.201110271120 (org.eclipse.mylyn.docs.intent.feature.group 0.7.0.201110271120)
To: org.eclipse.mylyn.docs.intent.compare [0.7.0.201110271120]


tw: @MarcelBruch
tw: @Recommenders
Re: Incomplete Dependencies on Update Site [message #755066 is a reply to message #754931] Mon, 07 November 2011 09:24 Go to previous messageGo to next message
Alex Lagarde is currently offline Alex LagardeFriend
Messages: 185
Registered: May 2010
Senior Member

Hi Marcel,

first of all thank you for giving Intent a try !

The simpliest way of installing Intent is to start from an Indigo
Modeling, as explained in the Installation Guide
http://wiki.eclipse.org/Intent/Installation_Guide .

We will work on packaging and dependencies when we will align Intent 0.7
with the Juno release train.

Cheers,
Alex
Re: Incomplete Dependencies on Update Site [message #755340 is a reply to message #755066] Tue, 08 November 2011 08:26 Go to previous message
Marcel Bruch is currently offline Marcel BruchFriend
Messages: 230
Registered: July 2009
Senior Member
Thanks for the pointer. I missed that somehow.

tw: @MarcelBruch
tw: @Recommenders
Previous Topic:Mylyn 0.7 first build is available
Next Topic:No intent document in intent project
Goto Forum:
  


Current Time: Sat Dec 20 11:46:07 GMT 2014

Powered by FUDForum. Page generated in 0.01863 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software