Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Cannot edit html files with Web Page Editor - HTML Editor
Cannot edit html files with Web Page Editor - HTML Editor [message #736993] Fri, 14 October 2011 10:51 Go to next message
boumbh is currently offline boumbh
Messages: 3
Registered: October 2011
Junior Member
Hi,

When I open a file using HTML Editor, I cannot edit it. It is like if the file was openned in read-only mode, even if the status bar indicate "Writable".

I checked that the file had not actually the read-only attribute. I tried different build of WPE and JRE (as my long investigation through this forum lead me to www.eclipse.org/forums/index.php/mv/msg/65328/205514/).

If I open the html file from Text Editor, I can edit it only if the file is not also openned in HTML Editor.

Environment:
- Windows 7 Pro
- Eclipse 3.7.0
- Java version 1.6.0_24 (VM 19.1-b02)
- Web Page Editor 2.3.5.v201109051528-46AA9oB5875L5K4I77WPE installed from repository download.eclipse.org/releases/indigo

I also tried with:
- Java version 1.5.0_22 (VM 1.5.0_22-b03) (by adding a -vm attribute to the eclipse.ini file)
- Web Page Editor 2.3.4.v201105111126-468b9oB5875G5M6D4A installed from repository download.eclipse.org/releases/indigo/201106220900

Alternativelly, I tried to install WTP but I got the error "Cannot complete the install because of a conflicting dependency." How do I know which application is conflicting with WTP ?

Here is the list of installed applications on my Eclipse:
  CollabNet Merge Client	2.2.4
  Eclipse SDK	3.7.0.I20110613-1736
    Eclipse Project SDK	3.7.0.v20110426-7Q7xA7DPb31rE2_TcfD-VPkLqq8sfDmLus7XtaSo-7NHB
      Eclipse CVS Client	1.3.100.v20110520-0800-7B78FHk8sF7BB7SBB5EYD5
      Eclipse CVS Client Resources	1.3.100.v20110520-0800-7B78FHk8sF7BB7SBB5EYD5
      Eclipse Help Developer Resources	1.3.0.v20110327-7i7uFFiFFt6ZqnbOrMXLd1
      Eclipse Help System	1.3.0.v20110327-7i7uFFiFFt6ZqnbOrMXLd1
      Eclipse Java Development Tools	3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B
      Eclipse JDT Plug-in Developer Resources	3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B
      Eclipse PDE Plug-in Developer Resources	3.7.0.v20110504-0800-7b7qFVpFEx2XnmYtj_9RfO7
      Eclipse Platform	3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f
        Eclipse RCP	3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY
        Equinox p2 Provisioning for IDEs.	2.1.1.v20110526-6-Bg9JXOePwKUTU7X0teV1RtDu-e
          Add-on Function for p2	1.0.0.v20110519-7A4FD3DiVOManmZvpLOsnBhnPQM3
          Equinox p2 Core Function	1.0.0.v20110519-8290FZ-FWmE7gdAgmOPL2_C
          Equinox p2 RCP Management Facilities	1.0.0.v20110519-782EoBqNKGUkVQrqOf0z-BhnPQM3
      Eclipse Platform Plug-in Developer Resources	3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f
        Eclipse p2 Provisioning Developer Resources	2.1.1.v20110526-6-Bg9JXOePwKUTU7X0teV1RtDu-e
          Equinox p2 Core Function Source	1.0.0.v20110519-8290FZ-FWmE7gdAgmOPL2_C
          Equinox p2 RCP Management Facilities	1.0.0.v20110519-7A4FD3DiVOManmZvpLOsnBhnPQM3
          Equinox p2 RCP Management Facilities Source	1.0.0.v20110519-782EoBqNKGUkVQrqOf0z-BhnPQM3
        Eclipse RCP Plug-in Developer Resources	3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY
      Eclipse Plug-in Development Environment	3.7.0.v20110504-0800-7b7qFVpFEx2XnmYtj_9RfO7
  EPIC	0.6.40
  JavaScript Development Tools	1.3.1.v201108102009-7F78FXRFBBoPbXRPcHfz-uy
  Subclipse (Required)	1.6.18
  Subclipse Integration for Mylyn 3.x (Optional)	3.0.0
  Subversion Client Adapter (Required)	1.6.12
  Subversion JavaHL Native Library Adapter (Required)	1.6.17
  Subversion Revision Graph	1.0.9
  SVNKit Client Adapter (Not required)	1.6.15
  SVNKit Library	1.3.5.7406
    JNA Library	3.2.7
  Web Page Editor	2.3.5.v201109051528-46AA9oB5875L5K4I77
  XSL Tools SDK	1.0.2.v200908271520-4-390_CYVxWRxOsrgiEZFM0TlMiJ
    Eclipse XSL Developer Tools	1.0.2.v200908271520-7R7T8sFIhIehWg454rq_U1
    XSL Tools Developer Resources	1.0.2.v200908271520-7R7T8sFIhIehWg454rq_U1


Thanks in advance...

PS: I had to remove all the links of this message.
Re: Cannot edit html files with Web Page Editor - HTML Editor [message #737235 is a reply to message #736993] Fri, 14 October 2011 16:26 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2132
Registered: July 2009
Senior Member
The "Cannot complete the install because of a conflicting dependency." message usually indicates that, even if it's in a manner very hard to decipher. Was there more to the message?

How are you opening the file? Is this a problem just with the HTML Editor, or with the Web Page Editor as well? Is there anything related in your Error Log view? Have you tried downloading the Eclipse IDE for Java EE Developers, Indigo SR1, and retrying it with that?


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Cannot edit html files with Web Page Editor - HTML Editor [message #740455 is a reply to message #737235] Tue, 18 October 2011 10:29 Go to previous messageGo to next message
boumbh is currently offline boumbh
Messages: 3
Registered: October 2011
Junior Member
Thanks for your reply.

This happens during the installation of Web Developer Tools:
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Web Developer Tools 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL (org.eclipse.wst.web_ui.feature.feature.group 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL)
  Software currently installed: XSL Tools SDK 1.0.2.v200908271520-4-390_CYVxWRxOsrgiEZFM0TlMiJ (org.eclipse.wst.xsl_sdk.feature.feature.group 1.0.2.v200908271520-4-390_CYVxWRxOsrgiEZFM0TlMiJ)
  Only one of the following can be installed at once: 
    Structured Source Editor 1.3.1.v201108191312 (org.eclipse.wst.sse.ui 1.3.1.v201108191312)
    Structured Source Editor 1.1.102.v200910200227 (org.eclipse.wst.sse.ui 1.1.102.v200910200227)
    Structured Source Editor 1.3.0.v201105101529 (org.eclipse.wst.sse.ui 1.3.0.v201105101529)
    Structured Source Editor 1.1.101.v200908261807 (org.eclipse.wst.sse.ui 1.1.101.v200908261807)
  Cannot satisfy dependency:
    From: Eclipse Web Developer Tools 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL (org.eclipse.wst.web_ui.feature.feature.group 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL)
    To: org.eclipse.wst.xml_ui.feature.feature.group [3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL]
  Cannot satisfy dependency:
    From: XPath UI 1.0.0.v200904240436 (org.eclipse.wst.xml.xpath.ui 1.0.0.v200904240436)
    To: bundle org.eclipse.wst.sse.ui [1.0.101,1.2.0)
  Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL (org.eclipse.wst.xml_ui.feature.feature.group 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL)
    To: org.eclipse.wst.sse.ui [1.3.1.v201108191312]
  Cannot satisfy dependency:
    From: Eclipse XSL Developer Tools 1.0.2.v200908271520-7R7T8sFIhIehWg454rq_U1 (org.eclipse.wst.xsl.feature.feature.group 1.0.2.v200908271520-7R7T8sFIhIehWg454rq_U1)
    To: org.eclipse.wst.xml.xpath.ui [1.0.0.v200904240436]
  Cannot satisfy dependency:
    From: XSL Tools SDK 1.0.2.v200908271520-4-390_CYVxWRxOsrgiEZFM0TlMiJ (org.eclipse.wst.xsl_sdk.feature.feature.group 1.0.2.v200908271520-4-390_CYVxWRxOsrgiEZFM0TlMiJ)
    To: org.eclipse.wst.xsl.feature.feature.group [1.0.2.v200908271520-7R7T8sFIhIehWg454rq_U1]


Does Web Page Editor have anything to do with Web Developer Tools? Are there independent projects?

The questions:

Quote:
How are you opening the file?

In all the possible ways (in my view): double click (with HTML Editor being the default), right click, select HTML Editor, drag and drop into the Editor view (with HTML Editor being the default)... Same behaviour.

Quote:
Is this a problem just with the HTML Editor, or with the Web Page Editor as well?

Oh, that's strange, I was convinced that XSL and XML Editors were all working the other day (maybe I was wrong). Actually I got the same problem with XML and XSL Editors too. XSL and XML Editors (from Eclipse XSL Developer Tools) were working fine before the installation of WPE. Could it be a conflict between XSL DT and WPE?

Quote:
Is there anything related in your Error Log view?

Just discovered the logs!

I think this is not related to my problem:
!ENTRY org.eclipse.ui 4 4 2011-10-18 15:59:26.806
!MESSAGE Invalid preference page path: JSP Syntax

!ENTRY org.eclipse.ui 4 4 2011-10-18 15:59:26.809
!MESSAGE Invalid preference page path: HTML Syntax

!ENTRY org.eclipse.ui 4 4 2011-10-18 15:59:26.812
!MESSAGE Invalid preference page path: XSLT Validation


The following error is logged every time I try to edit the file (HTML, XSL or XML).
!ENTRY org.eclipse.ui 4 0 2011-10-18 15:59:39.840
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.AbstractMethodError: org.eclipse.wst.sse.ui.EditorExecutionContext.execute(Lorg/eclipse/core/runtime/ISafeRunnable;)V
	at org.eclipse.wst.sse.core.internal.text.JobSafeStructuredDocument.replace(JobSafeStructuredDocument.java:106)
	at org.eclipse.jface.text.DefaultDocumentAdapter.replaceTextRange(DefaultDocumentAdapter.java:248)
	at org.eclipse.swt.custom.StyledText.modifyContent(StyledText.java:7180)
	at org.eclipse.swt.custom.StyledText.sendKeyEvent(StyledText.java:7994)
	at org.eclipse.swt.custom.StyledText.doContent(StyledText.java:2456)
	at org.eclipse.swt.custom.StyledText.handleKey(StyledText.java:5911)
	at org.eclipse.swt.custom.StyledText.handleKeyDown(StyledText.java:5941)
	at org.eclipse.swt.custom.StyledText$7.handleEvent(StyledText.java:5635)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1077)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1062)
	at org.eclipse.swt.widgets.Widget.sendKeyEvent(Widget.java:1104)
	at org.eclipse.swt.widgets.Widget.sendKeyEvent(Widget.java:1100)
	at org.eclipse.swt.widgets.Widget.wmChar(Widget.java:1509)
	at org.eclipse.swt.widgets.Control.WM_CHAR(Control.java:4640)
	at org.eclipse.swt.widgets.Canvas.WM_CHAR(Canvas.java:345)
	at org.eclipse.swt.widgets.Control.windowProc(Control.java:4528)
	at org.eclipse.swt.widgets.Canvas.windowProc(Canvas.java:341)
	at org.eclipse.swt.widgets.Display.windowProc(Display.java:4972)
	at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
	at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2530)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3752)
	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)


Quote:
Have you tried downloading the Eclipse IDE for Java EE Developers, Indigo SR1, and retrying it with that?

First I will wait for your feedback (if there is anything you want me to test with my current config).

Then I will try and uninstall every XSL / XML / HTML Tools, then reinstall WPE or WTP independently.

I will try your suggestion after that if it still doesn't work.
Re: Cannot edit html files with Web Page Editor - HTML Editor [message #740587 is a reply to message #740455] Tue, 18 October 2011 13:20 Go to previous messageGo to next message
Nick Sandonato is currently offline Nick Sandonato
Messages: 125
Registered: July 2009
Senior Member
The stack trace you've supplied looks a lot like https://bugs.eclipse.org/360242, which appears to be a problem with going from something earlier than Indigo to Indigo SR1.
Re: Cannot edit html files with Web Page Editor - HTML Editor [message #740632 is a reply to message #740587] Tue, 18 October 2011 14:24 Go to previous messageGo to next message
boumbh is currently offline boumbh
Messages: 3
Registered: October 2011
Junior Member
Yes, it looks the same, same behaviour with XML files, same error message.

But I am still with:

Eclipse Version: 3.7.0
Build id: I20110613-1736

Recently installed (new workstation) and never updated. I'll try to uninstall some plugins now...

------------- Updated [Tue, 18 October 2011 14:34]

Uninstalled XSL Development Tools and Javascript Development Tools, no change.

------------- Updated [Tue, 18 October 2011 14:49]

Uninstall WTP, Installed Eclipse Web Developer Tools -> XML, XSL, HTML Editors are ok.

This configuration is fine for me, I'll check sometimes if you want more informations about this issue...

PS: You asked for some Plugins Id in Eclipse bugs (bugs.eclipse.org/bugs/show_bug.cgi?id=360242). It is likely that it won't help, but here are mine (after the installation of Eclipse Web Developer Tools):
  • org.eclipse.wst.sse.core: 1.1.601.v201108151912
  • org.eclipse.wst.sse.ui: 1.3.1.v201108191312

[Updated on: Tue, 18 October 2011 14:56]

Report message to a moderator

Re: Cannot edit html files with Web Page Editor - HTML Editor [message #881048 is a reply to message #740632] Sun, 03 June 2012 15:16 Go to previous message
Brian Canin is currently offline Brian Canin
Messages: 4
Registered: June 2012
Location: Coronado
Junior Member
Might help in this problem also.... see this fix which helped me:

Had this problem, I see multiple questions unanswered on this topic:

MESSAGE Invalid preference page path: XML Syntax

Easy fix....

I was able to fix it by creating a new workspace and then importing my project into it. If you had an original installation of Eclipse, then downloaded a new eclipse, readded all your android, ect. into it, you might get this error. Probably has to do with the XML with different keys from the old version in your hidden files in your workspace!
Previous Topic:Rhino debugging in Helios - What am I missing?
Next Topic:Eclipse misses perspectives and type of projects
Goto Forum:
  


Current Time: Thu Apr 17 11:38:38 EDT 2014

Powered by FUDForum. Page generated in 0.01695 seconds