Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Eclipse can't follow updating
Eclipse can't follow updating [message #731231] Fri, 30 September 2011 10:49 Go to next message
forsoap is currently offline forsoap
Messages: 2
Registered: September 2011
Junior Member
Hi all,
please help me, I use Eclipse Helios with PDT on Fedora 15, and I can't update the IDE.
Below the error message:

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse Java Development Tools 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK (org.eclipse.jdt.feature.group 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK)
Software currently installed: Shared profile 1.0.0.1303939529128 (SharedProfile_PlatformProfile 1.0.0.1303939529128)
Only one of the following can be installed at once:
Welcome Framework 3.4.100.v20110425 (org.eclipse.ui.intro 3.4.100.v20110425)
Welcome Framework 3.4.0.v20100427 (org.eclipse.ui.intro 3.4.0.v20100427)
Cannot satisfy dependency:
From: Shared profile 1.0.0.1303939529128 (SharedProfile_PlatformProfile 1.0.0.1303939529128)
To: org.eclipse.ui.intro [3.4.0.v20100427]
Cannot satisfy dependency:
From: Eclipse Java Development Tools 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK (org.eclipse.jdt.feature.group 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK)
To: org.eclipse.platform.feature.group 3.7.1
Cannot satisfy dependency:
From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK)
To: org.eclipse.ui.intro [3.4.100.v20110425]


Please, any help well come.
Thanks!
Re: Eclipse can't follow updating [message #759929 is a reply to message #731231] Wed, 30 November 2011 15:30 Go to previous messageGo to next message
Martin is currently offline Martin
Messages: 2
Registered: November 2011
Location: Rugby, UK
Junior Member

Hi,

I have this same issue. Is there a general help topic for resolving this sort of thing? Not seen one yet but still looking.

Re: Eclipse can't follow updating [message #760070 is a reply to message #759929] Thu, 01 December 2011 08:38 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 353
Registered: July 2009
Location: Japan
Senior Member
>Software currently installed: Shared profile 1.0.0.1303939529128 (SharedProfile_PlatformProfile 1.0.0.1303939529128)
It seems that this indicates you installed Fedora Eclipse but not Eclipse.
You can update via Fedora repository but not Eclipse repository.
Fedora Eclipse is being modified from Eclipse. It will disable update via Eclipse repository, or it will damage some functionalities of the feature which comes from outside Fedora repository. Do not mix Fedora Eclipse and Eclipse. You must use Eclipse which is available at http://www.eclipse.org/downloads/
Re: Eclipse can't follow updating [message #760136 is a reply to message #760070] Thu, 01 December 2011 13:08 Go to previous message
Martin is currently offline Martin
Messages: 2
Registered: November 2011
Location: Rugby, UK
Junior Member

Many thanks to Toshihiro Izumi as uninstalling Eclipse and then reinstalling from the download site appears to have fixed everything.
Previous Topic:Zend debugger installation for PDT 2.2 fails
Next Topic:Weird behavior with the editor.
Goto Forum:
  


Current Time: Fri Oct 31 09:30:54 GMT 2014

Powered by FUDForum. Page generated in 0.02621 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software