Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » GEF » Using different connections in the same viewer
Using different connections in the same viewer [message #78782] Thu, 08 May 2003 20:31 Go to next message
Stefan Junsved is currently offline Stefan Junsved
Messages: 56
Registered: July 2009
Member
Hi,

I'd like to use different connections in the same viewer, one with a
PolygonDecoration,
and one with no decoration at all. Now I use the ConnectionCreationToolEntry
class
for both when creating my palette and the result is that all connections are
created with
a PolygonDecoration. I have created two different classes derived from the
AbstractConnectionEditPart but only one is used.

Is it possible to differentiate the connections when I create them in my
Palette? The
factory parameter to the ConnectionCreationToolEntry class is used for the
model, not
the editpart...right??

Thanks
Re: Using different connections in the same viewer [message #78800 is a reply to message #78782] Thu, 08 May 2003 20:36 Go to previous messageGo to next message
Stefan Junsved is currently offline Stefan Junsved
Messages: 56
Registered: July 2009
Member
I'm sorry for this question. It's been a long day and I know how to solve
the problem.

/Stefan

"Stefan Junsved" <stefan.junsved@comactivity.net> wrote in message
news:b9eeqm$jbd$1@rogue.oti.com...
> Hi,
>
> I'd like to use different connections in the same viewer, one with a
> PolygonDecoration,
> and one with no decoration at all. Now I use the
ConnectionCreationToolEntry
> class
> for both when creating my palette and the result is that all connections
are
> created with
> a PolygonDecoration. I have created two different classes derived from the
> AbstractConnectionEditPart but only one is used.
>
> Is it possible to differentiate the connections when I create them in my
> Palette? The
> factory parameter to the ConnectionCreationToolEntry class is used for the
> model, not
> the editpart...right??
>
> Thanks
>
>
Re: Using different connections in the same viewer [message #78815 is a reply to message #78800] Thu, 08 May 2003 21:12 Go to previous message
Eclipse User
Originally posted by: none.us.ibm.com

I hope you are using the factory.getObjectType() to distinguish between the
two types of connections.
:-)

"Stefan Junsved" <stefan.junsved@comactivity.net> wrote in message
news:b9ef3u$jhl$1@rogue.oti.com...
> I'm sorry for this question. It's been a long day and I know how to solve
> the problem.
>
> /Stefan
>
> "Stefan Junsved" <stefan.junsved@comactivity.net> wrote in message
> news:b9eeqm$jbd$1@rogue.oti.com...
> > Hi,
> >
> > I'd like to use different connections in the same viewer, one with a
> > PolygonDecoration,
> > and one with no decoration at all. Now I use the
> ConnectionCreationToolEntry
> > class
> > for both when creating my palette and the result is that all connections
> are
> > created with
> > a PolygonDecoration. I have created two different classes derived from
the
> > AbstractConnectionEditPart but only one is used.
> >
> > Is it possible to differentiate the connections when I create them in my
> > Palette? The
> > factory parameter to the ConnectionCreationToolEntry class is used for
the
> > model, not
> > the editpart...right??
> >
> > Thanks
> >
> >
>
>
Previous Topic:Accesssibility
Next Topic:Any objections to placing palette on the left?
Goto Forum:
  


Current Time: Thu Oct 23 02:28:35 GMT 2014

Powered by FUDForum. Page generated in 0.17761 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software