Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SeMantic Information Logistics Architecture (SMILA) » misnomer numberOfParallelRecords for PipelineProcessingWorker
misnomer numberOfParallelRecords for PipelineProcessingWorker [message #730029] Tue, 27 September 2011 13:38 Go to next message
thomas menzel is currently offline thomas menzelFriend
Messages: 81
Registered: July 2009
Member
looking at the code it actually controls the size of the bunch to be
processed in *sequence* by a pipeline.

i vote to rename this to: pipelineRunBulkSize

admittedly the bulk in this name might be confusing but i think that's
fits best.

alternatively we could use pipelineMaxRecordCount, pipelineRunChunkSize
or others in that line of though

see
http://wiki.eclipse.org/SMILA/Documentation/Worker/PipelineProcessingWorker

--
thomas menzel aka tom


thomas menzel aka tom
Re: misnomer numberOfParallelRecords for PipelineProcessingWorker [message #730311 is a reply to message #730029] Wed, 28 September 2011 06:51 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: J
Re: misnomer numberOfParallelRecords for PipelineProcessingWorker [message #730333 is a reply to message #730029] Wed, 28 September 2011 07:46 Go to previous messageGo to next message
Juergen Schumacher is currently offline Juergen SchumacherFriend
Messages: 35
Registered: July 2009
Member
(Re-Post, because the web-interface seems to have problems with the umlaut
in my name ...)

Yeah, picking names is always the hard part, isn't it (;

I think you're right, the "parallel" is misleading.
Concerning a better name: I'm not able yet to make a decision...

Cheers,
Jürgen


Am 27.09.2011, 15:38 Uhr, schrieb thomas menzel <tmenzel@brox.de>:

> looking at the code it actually controls the size of the bunch to be
> processed in *sequence* by a pipeline.
>
> i vote to rename this to: pipelineRunBulkSize
>
> admittedly the bulk in this name might be confusing but i think that's
> fits best.
>
> alternatively we could use pipelineMaxRecordCount, pipelineRunChunkSize
> or others in that line of though
>
> see
> http://wiki.eclipse.org/SMILA/Documentation/Worker/PipelineProcessingWorker
>


--
Erstellt mit Operas revolutionärem E-Mail-Modul: http://www.opera.com/mail/
Re: misnomer numberOfParallelRecords for PipelineProcessingWorker [message #730348 is a reply to message #730333] Wed, 28 September 2011 08:17 Go to previous messageGo to next message
nadine.auslaender is currently offline nadine.auslaenderFriend
Messages: 1
Registered: September 2011
Junior Member
Hi,

I agree, numberOfParallelRecords does not fit here and pipelineRunBulkSize is a much better name.

You have my vote, too. Wink

Regards
Nadine
Re: misnomer numberOfParallelRecords for PipelineProcessingWorker [message #730355 is a reply to message #730348] Wed, 28 September 2011 08:17 Go to previous message
Juergen Schumacher is currently offline Juergen SchumacherFriend
Messages: 35
Registered: July 2009
Member
Am 28.09.2011, 10:17 Uhr, schrieb nadine.auslaender
<forums-noreply@eclipse.org>:

> Hi, I agree, numberOfParallelRecords does not fit here and
> pipelineRunBulkSize is a much better name. You have my vote, too. ;)
>
> Regards
> Nadine

Ok .. I'm changing it.

Cheers
Jürgen.
Previous Topic:Re: zookeeper info/error NoNode for /smila/XXXX
Next Topic:Release 0.9 is out!
Goto Forum:
  


Current Time: Wed Nov 26 09:13:53 GMT 2014

Powered by FUDForum. Page generated in 0.02899 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software