Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » org.eclipse.php.ui.PHPCompletionProposalComputer crash
org.eclipse.php.ui.PHPCompletionProposalComputer crash [message #78615] Tue, 19 August 2008 19:39 Go to next message
Eclipse User
Originally posted by: awjrichards.gmail.com

This is a multi-part message in MIME format.
--------------020206050905070006030101
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Hi,

I have 64-bit Eclipse PDT working with Ganymede under 64-bit Ubuntu
8.04. Whenever I try to create a PHP variable (typing '$'), Eclipse
freezes for a while - maybe 20 - 60 seconds. Occasionally, it will
display the following error:

"The 'org.eclipse.php.ui.PHPCompletionProposalCOmputer' proposal
computer from the 'org.eclipse.php.ui' plug-in did not complete
normally. The extension took too long to return from the
'computeCompletionProposals()' operation."

I have attached a screenshot. I've tried disabling all of the options
under the PHP->Editor->Code Assist pane in my preferences, which seems
to prevent any freezing, although performance is choppy - meaning
Eclipse will periodically hang for a second or two while I'm typing (I
can't detect any kind of pattern to it) or moving the cursor around.

I dunno if it'll make any difference, but I'm starting Eclipse with this
command: /usr/bin/eclipse64 -vmargs -Xmx512M.

Anybody have any ideas how to get around this? I'm also attaching my
error log.

Thanks so much!
Arthur Richards

--------------020206050905070006030101
Content-Type: text/plain;
name="eclipse_error_log.log"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;
filename="eclipse_error_log.log"

!SESSION 2008-08-19 09:41:41.113 -----------------------------------------------
eclipse.buildId=I20080617-2000
java.version=1.6.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

This is a continuation of log file /home/arthur/Dev/.metadata/.bak_0.log
Created Time: 2008-08-19 09:59:43.047

!ENTRY org.eclipse.jface.text 4 0 2008-08-19 09:59:43.047
!MESSAGE Unexpected runtime error while computing a text hover
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getVisibleS tore(ChainedPreferenceStore.java:529)
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getBoolean( ChainedPreferenceStore.java:171)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.isActive(AbstractAnnotationHover.java:135)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.getHoverInfo(AbstractAnnotationHover.java:95)
at org.eclipse.php.internal.ui.editor.hover.BestMatchHover.getH overInfo(Unknown Source)
at org.eclipse.php.internal.ui.editor.hover.PHPTextHoverProxy.g etHoverInfo(Unknown Source)
at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextView erHoverManager.java:168)

!ENTRY org.eclipse.jface.text 4 0 2008-08-19 10:02:55.471
!MESSAGE Unexpected runtime error while computing a text hover
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getVisibleS tore(ChainedPreferenceStore.java:529)
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getBoolean( ChainedPreferenceStore.java:171)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.isActive(AbstractAnnotationHover.java:135)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.getHoverInfo(AbstractAnnotationHover.java:95)
at org.eclipse.php.internal.ui.editor.hover.BestMatchHover.getH overInfo(Unknown Source)
at org.eclipse.php.internal.ui.editor.hover.PHPTextHoverProxy.g etHoverInfo(Unknown Source)
at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextView erHoverManager.java:168)

!ENTRY org.eclipse.search 4 0 2008-08-19 10:04:00.190
!MESSAGE Problems encountered during text search.
!SUBENTRY 1 org.eclipse.search 4 4 2008-08-19 10:04:00.190
!MESSAGE File 'berewarding/berewarding/log/frontend_dev.log' has been skipped, problem while reading: ('Resource is out of sync with the file system: '/berewarding/berewarding/log/frontend_dev.log'.').
!STACK 1
org.eclipse.core.internal.resources.ResourceException: Resource is out of sync with the file system: '/berewarding/berewarding/log/frontend_dev.log'.
at org.eclipse.core.internal.localstore.FileSystemResourceManag er.read(FileSystemResourceManager.java:619)
at org.eclipse.core.internal.resources.File.getContents(File.ja va:298)
at org.eclipse.core.internal.resources.File.getContents(File.ja va:287)
at org.eclipse.search.internal.core.text.FileCharSequenceProvid er$FileCharSequence.getInputStream(FileCharSequenceProvider. java:282)
at org.eclipse.search.internal.core.text.FileCharSequenceProvid er$FileCharSequence.initializeReader(FileCharSequenceProvide r.java:276)
at org.eclipse.search.internal.core.text.FileCharSequenceProvid er$FileCharSequence.reset(FileCharSequenceProvider.java:268)
at org.eclipse.search.internal.core.text.FileCharSequenceProvid er.newCharSequence(FileCharSequenceProvider.java:40)
at org.eclipse.search.internal.core.text.TextSearchVisitor.proc essFile(TextSearchVisitor.java:255)
at org.eclipse.search.internal.core.text.TextSearchVisitor.proc essFiles(TextSearchVisitor.java:190)
at org.eclipse.search.internal.core.text.TextSearchVisitor.sear ch(TextSearchVisitor.java:171)
at org.eclipse.search.internal.core.text.TextSearchVisitor.sear ch(TextSearchVisitor.java:183)
at org.eclipse.search.core.text.TextSearchEngine$1.search(TextS earchEngine.java:54)
at org.eclipse.search.internal.ui.text.FileSearchQuery.run(File SearchQuery.java:184)
at org.eclipse.search2.internal.ui.InternalSearchUI$InternalSea rchJob.run(InternalSearchUI.java:94)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
!SUBENTRY 2 org.eclipse.core.resources 4 274 2008-08-19 10:04:00.190
!MESSAGE Resource is out of sync with the file system: '/berewarding/berewarding/log/frontend_dev.log'.

!ENTRY org.eclipse.jface.text 4 0 2008-08-19 10:04:25.115
!MESSAGE Unexpected runtime error while computing a text hover
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getVisibleS tore(ChainedPreferenceStore.java:529)
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getBoolean( ChainedPreferenceStore.java:171)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.isActive(AbstractAnnotationHover.java:135)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.getHoverInfo(AbstractAnnotationHover.java:95)
at org.eclipse.php.internal.ui.editor.hover.BestMatchHover.getH overInfo(Unknown Source)
at org.eclipse.php.internal.ui.editor.hover.PHPTextHoverProxy.g etHoverInfo(Unknown Source)
at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextView erHoverManager.java:168)

!ENTRY org.eclipse.jface.text 4 0 2008-08-19 10:04:36.090
!MESSAGE Unexpected runtime error while computing a text hover
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getVisibleS tore(ChainedPreferenceStore.java:529)
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getBoolean( ChainedPreferenceStore.java:171)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.isActive(AbstractAnnotationHover.java:135)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.getHoverInfo(AbstractAnnotationHover.java:95)
at org.eclipse.php.internal.ui.editor.hover.BestMatchHover.getH overInfo(Unknown Source)
at org.eclipse.php.internal.ui.editor.hover.PHPTextHoverProxy.g etHoverInfo(Unknown Source)
at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextView erHoverManager.java:168)

!ENTRY org.eclipse.jface.text 4 0 2008-08-19 10:04:46.097
!MESSAGE Unexpected runtime error while computing a text hover
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getVisibleS tore(ChainedPreferenceStore.java:529)
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getBoolean( ChainedPreferenceStore.java:171)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.isActive(AbstractAnnotationHover.java:135)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.getHoverInfo(AbstractAnnotationHover.java:95)
at org.eclipse.php.internal.ui.editor.hover.BestMatchHover.getH overInfo(Unknown Source)
at org.eclipse.php.internal.ui.editor.hover.PHPTextHoverProxy.g etHoverInfo(Unknown Source)
at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextView erHoverManager.java:168)

!ENTRY org.eclipse.jface.text 4 0 2008-08-19 10:06:17.167
!MESSAGE Unexpected runtime error while computing a text hover
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getVisibleS tore(ChainedPreferenceStore.java:529)
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getBoolean( ChainedPreferenceStore.java:171)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.isActive(AbstractAnnotationHover.java:135)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.getHoverInfo(AbstractAnnotationHover.java:95)
at org.eclipse.php.internal.ui.editor.hover.BestMatchHover.getH overInfo(Unknown Source)
at org.eclipse.php.internal.ui.editor.hover.PHPTextHoverProxy.g etHoverInfo(Unknown Source)
at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextView erHoverManager.java:168)

!ENTRY org.eclipse.jface 2 0 2008-08-19 10:38:50.387
!MESSAGE Ignored reentrant call while viewer is busy. This is only logged once per viewer instance, but similar calls will still be ignored.
!STACK 0
java.lang.RuntimeException
at org.eclipse.jface.viewers.ColumnViewer.checkBusy(ColumnViewe r.java:763)
at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer. java:541)
at org.eclipse.dltk.internal.ui.navigator.ScriptExplorerContent Provider$4.run(ScriptExplorerContentProvider.java:1078)
at org.eclipse.dltk.internal.ui.navigator.ScriptExplorerContent Provider.runUpdates(ScriptExplorerContentProvider.java:180)
at org.eclipse.dltk.internal.ui.navigator.ScriptExplorerContent Provider.executeRunnables(ScriptExplorerContentProvider.java :141)
at org.eclipse.dltk.internal.ui.navigator.ScriptExplorerContent Provider.elementChanged(ScriptExplorerContentProvider.java:1 30)
at org.eclipse.dltk.internal.core.DeltaProcessor$3.run(DeltaPro cessor.java:1660)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.dltk.internal.core.DeltaProcessor.notifyListener s(DeltaProcessor.java:1646)
at org.eclipse.dltk.internal.core.DeltaProcessor.firePostChange Delta(DeltaProcessor.java:1490)
at org.eclipse.dltk.internal.core.DeltaProcessor.fire(DeltaProc essor.java:1464)
at org.eclipse.dltk.internal.core.ModelOperation.run(ModelOpera tion.java:751)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.dltk.core.DLTKCore.run(DLTKCore.java:1336)
at org.eclipse.dltk.core.DLTKCore.setBuildpathContainer(DLTKCor e.java:1977)
at org.eclipse.php.internal.core.language.LanguageModelInitiali zer.initialize(Unknown Source)
at org.eclipse.dltk.internal.core.ModelManager.initializeContai ner(ModelManager.java:1684)
at org.eclipse.dltk.internal.core.ModelManager$8.run(ModelManag er.java:1629)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.dltk.internal.core.ModelManager.initializeAllCon tainers(ModelManager.java:1638)
at org.eclipse.dltk.internal.core.ModelManager.getBuildpathCont ainer(ModelManager.java:1508)
at org.eclipse.dltk.core.DLTKCore.getBuildpathContainer(DLTKCor e.java:1674)
at org.eclipse.dltk.internal.ui.scriptview.BuildPathContainer.<init >(BuildPathContainer.java:91)
at org.eclipse.dltk.internal.ui.navigator.ScriptExplorerContent Provider.getProjectFragments(ScriptExplorerContentProvider.j ava:369)
at org.eclipse.dltk.internal.ui.StandardModelElementContentProv ider.getChildren(StandardModelElementContentProvider.java:16 3)
at org.eclipse.dltk.internal.ui.navigator.ScriptExplorerContent Provider.getChildren(ScriptExplorerContentProvider.java:307)
at org.eclipse.jface.viewers.AbstractTreeViewer.getRawChildren( AbstractTreeViewer.java:1352)
at org.eclipse.jface.viewers.TreeViewer.getRawChildren(TreeView er.java:385)
at org.eclipse.jface.viewers.AbstractTreeViewer.getFilteredChil dren(AbstractTreeViewer.java:636)
at org.eclipse.jface.viewers.AbstractTreeViewer.getSortedChildr en(AbstractTreeViewer.java:602)
at org.eclipse.jface.viewers.AbstractTreeViewer$1.run(AbstractT reeViewer.java:799)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:70)
at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren( AbstractTreeViewer.java:776)
at org.eclipse.jface.viewers.TreeViewer.createChildren(TreeView er.java:634)
at org.eclipse.jface.viewers.AbstractTreeViewer.handleTreeExpan d(AbstractTreeViewer.java:1442)
at org.eclipse.jface.viewers.TreeViewer.handleTreeExpand(TreeVi ewer.java:927)
at org.eclipse.jface.viewers.AbstractTreeViewer$4.treeExpanded( AbstractTreeViewer.java:1453)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListe ner.java:126)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1182)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1167)
at org.eclipse.swt.widgets.Tree.gtk_test_expand_row(Tree.java:2 026)
at org.eclipse.swt.widgets.Widget.windowProc(Widget.java:1572)
at org.eclipse.swt.widgets.Display.windowProc(Display.java:4105 )
at org.eclipse.swt.internal.gtk.OS._gtk_main_do_event(Native Method)
at org.eclipse.swt.internal.gtk.OS.gtk_main_do_event(OS.java:57 83)
at org.eclipse.swt.widgets.Display.eventProc(Display.java:1177)
at org.eclipse.swt.internal.gtk.OS._g_main_context_iteration(Na tive Method)
at org.eclipse.swt.internal.gtk.OS.g_main_context_iteration(OS. java:1541)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3031)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2382)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 98)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
at org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:288)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:488)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:382)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

!ENTRY org.eclipse.jface.text 4 0 2008-08-19 10:41:10.475
!MESSAGE Unexpected runtime error while computing a text hover
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getVisibleS tore(ChainedPreferenceStore.java:529)
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getBoolean( ChainedPreferenceStore.java:171)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.isActive(AbstractAnnotationHover.java:135)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.getHoverInfo(AbstractAnnotationHover.java:95)
at org.eclipse.php.internal.ui.editor.hover.BestMatchHover.getH overInfo(Unknown Source)
at org.eclipse.php.internal.ui.editor.hover.PHPTextHoverProxy.g etHoverInfo(Unknown Source)
at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextView erHoverManager.java:168)

!ENTRY org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.sse.ui 1.0.305.v200802142230 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.common.ui 1.0.1.v20070912 to requiredCapability: osgi.bundle/org.eclipse.emf/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.common.ui 1.0.1.v20070912 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.common 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.edit.ui/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.common 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.core 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.core 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.core 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.core 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.ui.ide/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.ui/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.core.runtime/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.search/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.jface.text/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.ui.workbench.texteditor/[3.2.0,3.4.0 ).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.106.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.106.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.106.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.106.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.codegen/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200806252211 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200806252211 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200806252211 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200806252211 to requiredCapability: osgi.bundle/org.eclipse.emf.codegen/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200803071930 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200803071930 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200803071930 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200803071930 to requiredCapability: osgi.bundle/org.eclipse.emf.codegen/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.web 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.web 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.web 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.codegen/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.sse.core 1.1.203.v200802140626 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.modulecore 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.modulecore 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.modulecore 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.core 1.1.101.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.core.runtime/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.core 1.1.101.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.core 1.1.101.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.core.expressions/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.622
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.emf 1.1.104.v200709131115 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.facesconfig 1.0.1.v20070912 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.facesconfig 1.0.1.v20070912 to requiredCapability: osgi.bundle/org.eclipse.emf.edit.ui/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.core 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.core 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.common.frameworks 1.1.102.v200709122200 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.common.frameworks 1.1.102.v200709122200 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.emfworkbench.integration 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.emfworkbench.integration 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jem 2.0.100.v200709051030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.3.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.frameworks 1.1.103.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.common.annotations.controller 1.1.2.v200708301745 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.web 1.1.103.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.environment 1.0.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200803242054 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200803242054 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200803242054 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200806261300 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200806261300 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200806261300 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.2.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.2.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.2.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.common.annotations.core 1.1.2.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.jca 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.jca 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.command.env 1.0.205.v200710161954 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.command.env 1.0.205.v200710161954 to requiredCapability: osgi.bundle/org.eclipse.ant.core/[3.1.100,3.2.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.command.env.ui 1.0.203.v200709052219 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws 1.0.204.v200711140435 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws 1.0.204.v200711140435 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws 1.0.204.v200711140435 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws 1.0.204.v200711140435 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.wsdl 1.1.101.v200801152132 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.wsdl 1.1.101.v200801152132 to requiredCapability: osgi.bundle/org.eclipse.xsd/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws.ui 1.0.203.v200708222126 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws.ui 1.0.203.v200708222126 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.wsi 1.0.105.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:25:52.623
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.xsd.core 1.1.202.v200710011705 to requiredCapability: osgi.bundle/org.eclipse.xsd/[2.2.0,2.4.0).
!SESSION 2008-08-19 11:26:53.344 -----------------------------------------------
eclipse.buildId=I20080617-2000
java.version=1.6.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 2 1 2008-08-19 11:27:06.680
!MESSAGE NLS unused message: EditVariableEntryDialog_filename_empty in: org.eclipse.dltk.internal.ui.wizards.NewWizardMessages

!ENTRY org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.sse.ui 1.0.305.v200802142230 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.common.ui 1.0.1.v20070912 to requiredCapability: osgi.bundle/org.eclipse.emf/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.common.ui 1.0.1.v20070912 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.common 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.edit.ui/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.common 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.core 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.core 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.core 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.core 1.0.2.v200802201120 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0)..
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.ui.ide/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.ui/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.core.runtime/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.483
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.search/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.jface.text/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.ui 1.1.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.ui.workbench.texteditor/[3.2.0,3.4.0 ).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.106.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.106.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.106.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.106.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.codegen/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200806252211 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200806252211 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200806252211 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200806252211 to requiredCapability: osgi.bundle/org.eclipse.emf.codegen/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200803071930 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200803071930 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200803071930 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee 1.1.107.v200803071930 to requiredCapability: osgi.bundle/org.eclipse.emf.codegen/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.web 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.web 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.web 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.codegen/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.sse.core 1.1.203.v200802140626 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.modulecore 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.modulecore 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.modulecore 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.core 1.1.101.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.core.runtime/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.core 1.1.101.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.core 1.1.101.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.core.expressions/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.emf 1.1.104.v200709131115 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.facesconfig 1.0.1.v20070912 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jsf.facesconfig 1.0.1.v20070912 to requiredCapability: osgi.bundle/org.eclipse.emf.edit.ui/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.core 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.core 1.1.104.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.common.frameworks 1.1.102.v200709122200 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.484
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.common.frameworks 1.1.102.v200709122200 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.485
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.emfworkbench.integration 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.485
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.emfworkbench.integration 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.485
!MESSAGE Unable to satisfy dependency from org.eclipse.jem 2.0.100.v200709051030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.3.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.485
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.frameworks 1.1.103.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.485
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.common.annotations.controller 1.1.2.v200708301745 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.489
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.web 1.1.103.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.489
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.common.environment 1.0.200.v200705302225 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.489
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200803242054 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.489
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200803242054 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.489
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200803242054 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200806261300 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200806261300 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.3.v200806261300 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.2.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.2.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.jee 1.0.2.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.common.annotations.core 1.1.2.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.jca 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.jst.j2ee.jca 1.1.105.v200802192030 to requiredCapability: osgi.bundle/org.eclipse.emf.edit/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.command.env 1.0.205.v200710161954 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.command.env 1.0.205.v200710161954 to requiredCapability: osgi.bundle/org.eclipse.ant.core/[3.1.100,3.2.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.command.env.ui 1.0.203.v200709052219 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws 1.0.204.v200711140435 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws 1.0.204.v200711140435 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws 1.0.204.v200711140435 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws 1.0.204.v200711140435 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore.xmi/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.wsdl 1.1.101.v200801152132 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.wsdl 1.1.101.v200801152132 to requiredCapability: osgi.bundle/org.eclipse.xsd/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws.ui 1.0.203.v200708222126 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.ws.ui 1.0.203.v200708222126 to requiredCapability: osgi.bundle/org.eclipse.emf.common/[2.2.0,2.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.wsi 1.0.105.v200706120315 to requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.2.0,3.4.0).
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2008-08-19 11:28:28.490
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.xsd.core 1.1.202.v200710011705 to requiredCapability: osgi.bundle/org.eclipse.xsd/[2.2.0,2.4.0).
!SESSION 2008-08-19 11:30:53.672 -----------------------------------------------
eclipse.buildId=I20080617-2000
java.version=1.6.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 2 1 2008-08-19 11:31:06.102
!MESSAGE NLS unused message: EditVariableEntryDialog_filename_empty in: org.eclipse.dltk.internal.ui.wizards.NewWizardMessages
!SESSION 2008-08-19 11:46:28.136 -----------------------------------------------
eclipse.buildId=I20080617-2000
java.version=1.6.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.core.resources 2 10035 2008-08-19 11:46:45.068
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.

!ENTRY org.eclipse.osgi 2 1 2008-08-19 11:46:53.835
!MESSAGE NLS unused message: EditVariableEntryDialog_filename_empty in: org.eclipse.dltk.internal.ui.wizards.NewWizardMessages

!ENTRY org.eclipse.jface.text 4 0 2008-08-19 12:07:03.351
!MESSAGE Unexpected runtime error while computing a text hover
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getVisibleS tore(ChainedPreferenceStore.java:529)
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getBoolean( ChainedPreferenceStore.java:171)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.isActive(AbstractAnnotationHover.java:135)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.getHoverInfo(AbstractAnnotationHover.java:95)
at org.eclipse.php.internal.ui.editor.hover.BestMatchHover.getH overInfo(Unknown Source)
at org.eclipse.php.internal.ui.editor.hover.PHPTextHoverProxy.g etHoverInfo(Unknown Source)
at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextView erHoverManager.java:168)

!ENTRY org.eclipse.jface.text 4 0 2008-08-19 12:07:04.734
!MESSAGE Unexpected runtime error while computing a text hover
!STACK 0
java.lang.NullPointerException
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getVisibleS tore(ChainedPreferenceStore.java:529)
at org.eclipse.ui.texteditor.ChainedPreferenceStore.getBoolean( ChainedPreferenceStore.java:171)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.isActive(AbstractAnnotationHover.java:135)
at org.eclipse.dltk.internal.ui.text.hover.AbstractAnnotationHo ver.getHoverInfo(AbstractAnnotationHover.java:95)
at org.eclipse.php.internal.ui.editor.hover.BestMatchHover.getH overInfo(Unknown Source)
at org.eclipse.php.internal.ui.editor.hover.PHPTextHoverProxy.g etHoverInfo(Unknown Source)
at org.eclipse.jface.text.TextViewerHoverManager$4.run(TextView erHoverManager.java:168)
!SESSION 2008-08-19 13:33:05.208 -----------------------------------------------
eclipse.buildId=I20080617-2000
java.version=1.6.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.core.resources 2 10035 2008-08-19 13:33:08.431
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.

!ENTRY org.eclipse.osgi 2 1 2008-08-19 13:33:15.768
!MESSAGE NLS unused message: EditVariableEntryDialog_filename_empty in: org.eclipse.dltk.internal.ui.wizards.NewWizardMessages

!ENTRY org.eclipse.dltk.ui 2 0 2008-08-19 13:36:27.114
!MESSAGE The 'org.eclipse.php.ui.PHPCompletionProposalComputer' proposal computer from the 'org.eclipse.php.ui' plug-in did not complete normally. The extension took too long to return from the 'computeCompletionProposals()' operation.

!ENTRY org.eclipse.ui.workbench 2 0 2008-08-19 13:36:27.573
!MESSAGE A handler conflict occurred. This may disable some commands.
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2008-08-19 13:36:27.573
!MESSAGE Conflict for 'org.eclipse.ui.navigate.forwardHistory':
HandlerActivation(commandId=org.eclipse.ui.navigate.forwardH istory,
handler=ActionHandler(org.eclipse.ui.internal.NavigationHistoryAction@38a09316),
expression=ActiveShellExpression(Shell {PHP - rncwc/metrics.php - Eclipse SDK}),sourcePriority=17408)
HandlerActivation(commandId=org.eclipse.ui.navigate.forwardH istory,
handler=ActionHandler(org.eclipse.ui.internal.dialogs.Prefer encePageHistory$2@3618a665),
expression=ActiveShellExpression(Shell {Preferences}),sourcePriority=17408)
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2008-08-19 13:36:27.573
!MESSAGE Conflict for 'org.eclipse.ui.navigate.backwardHistory':
HandlerActivation(commandId=org.eclipse.ui.navigate.backward History,
handler=ActionHandler(org.eclipse.ui.internal.dialogs.Prefer encePageHistory$1@c544ca2),
expression=ActiveShellExpression(Shell {Preferences}),sourcePriority=17408)
HandlerActivation(commandId=org.eclipse.ui.navigate.backward History,
handler=ActionHandler(org.eclipse.ui.internal.NavigationHistoryAction@72732600),
expression=ActiveShellExpression(Shell {PHP - rncwc/metrics.php - Eclipse SDK}),sourcePriority=17408)

!ENTRY org.eclipse.ui 4 0 2008-08-19 13:38:49.278
!MESSAGE Unhandled event loop exception
!STACK 0
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.OutOfMemoryError: GC overhead limit exceeded)
at org.eclipse.swt.SWT.error(SWT.java:3777)
at org.eclipse.swt.SWT.error(SWT.java:3695)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:136)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3378)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3036)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2382)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2346)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:21 98)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:493)
at org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:288)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:488)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:382)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lan
Eclipse 3.4/PDT 2.0 Linux - No syntax checking; no code assist [message #78650 is a reply to message #78615] Tue, 19 August 2008 21:35 Go to previous messageGo to next message
Ed Wright is currently offline Ed Wright
Messages: 11
Registered: July 2009
Junior Member
Hi,

Running PDT 2.0.0v20080722 on Eclipse 3.4.0v20080617 on Debian Etch system.

Syntax checking and code assist are not working. I'm wondering if these
are issues with the current version, or if I have a configuration
problem somewhere. If the latter, any advice on getting it straightened
out would be much appreciated.

On a separate note (related or not I don't know) I get the below error
spewed as many as 30-40 times/second at occasional intervals.

Thanks,
Ed


(Note: "eQstuff" is an existing project)

!ENTRY org.eclipse.php.core 4 4 2008-08-19 18:10:43.428
!MESSAGE eQstuff does not exist
!STACK 1
org.eclipse.dltk.core.ModelException: eQstuff does not exist
at
org.eclipse.dltk.internal.core.ModelOperation.runOperation(M odelOperation.java:768)
at
org.eclipse.dltk.internal.core.SourceType.newSupertypeHierar chy(SourceType.java:360)
at
org.eclipse.dltk.internal.core.SourceType.newSupertypeHierar chy(SourceType.java:333)
at
org.eclipse.php.internal.core.ast.nodes.TypeBinding.getInter faces(Unknown
Source)
at
org.eclipse.php.internal.core.ast.nodes.Bindings.findOverrid denMethod(Unknown
Source)
at
org.eclipse.php.internal.ui.editor.OverrideIndicatorManager$ 1.visit(Unknown
Source)
at
org.eclipse.php.internal.core.ast.nodes.MethodDeclaration.ac cept0(Unknown
Source)
at
org.eclipse.php.internal.core.ast.nodes.ASTNode.accept(Unkno wn Source)
at
org.eclipse.php.internal.core.ast.nodes.Block.childrenAccept (Unknown Source)
at
org.eclipse.php.internal.core.ast.nodes.Block.accept0(Unknow n Source)
at
org.eclipse.php.internal.core.ast.nodes.ASTNode.accept(Unkno wn Source)
at
org.eclipse.php.internal.core.ast.nodes.ClassDeclaration.chi ldrenAccept(Unknown
Source)
at
org.eclipse.php.internal.core.ast.nodes.ClassDeclaration.acc ept0(Unknown
Source)
at
org.eclipse.php.internal.core.ast.nodes.ASTNode.accept(Unkno wn Source)
at
org.eclipse.php.internal.core.ast.nodes.Program.childrenAcce pt(Unknown
Source)
at
org.eclipse.php.internal.core.ast.nodes.Program.accept0(Unkn own Source)
at
org.eclipse.php.internal.core.ast.nodes.ASTNode.accept(Unkno wn Source)
at
org.eclipse.php.internal.ui.editor.OverrideIndicatorManager. updateAnnotations(Unknown
Source)
at
org.eclipse.php.internal.ui.editor.OverrideIndicatorManager. reconciled(Unknown
Source)
at
org.eclipse.php.internal.ui.editor.PHPStructuredEditor.recon ciled(Unknown
Source)
at
org.eclipse.php.internal.ui.editor.validation.PhpReconciling Strategy.validate(Unknown
Source)
at
org.eclipse.wst.sse.ui.internal.reconcile.validator.Reconcil eStepForValidator.validate(ReconcileStepForValidator.java:34 0)
at
org.eclipse.wst.sse.ui.internal.reconcile.validator.Reconcil eStepForValidator.reconcileModel(ReconcileStepForValidator.j ava:247)
at
org.eclipse.jface.text.reconciler.AbstractReconcileStep.reco ncile(AbstractReconcileStep.java:96)
at
org.eclipse.wst.sse.ui.internal.reconcile.validator.Validato rStrategy.reconcile(ValidatorStrategy.java:229)
at
org.eclipse.wst.sse.ui.internal.reconcile.DocumentRegionProc essor.process(DocumentRegionProcessor.java:175)
at
org.eclipse.wst.sse.ui.internal.reconcile.StructuredRegionPr ocessor.process(StructuredRegionProcessor.java:252)
at
org.eclipse.wst.sse.ui.internal.reconcile.DirtyRegionProcess or.run(DirtyRegionProcessor.java:638)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
!SUBENTRY 1 org.eclipse.dltk.core 4 969 2008-08-19 18:10:43.429
!MESSAGE eQstuff does not exist
Re: Eclipse 3.4/PDT 2.0 Linux - No syntax checking; no code assist [message #78668 is a reply to message #78650] Tue, 19 August 2008 22:17 Go to previous messageGo to next message
Ed Wright is currently offline Ed Wright
Messages: 11
Registered: July 2009
Junior Member
Oh, damn....

Please forgive the "thread hijacking"..... it was unintended.

Ed
Re: Eclipse 3.4/PDT 2.0 Linux - No syntax checking; no code assist [message #78712 is a reply to message #78668] Wed, 20 August 2008 09:38 Go to previous messageGo to next message
David Muir is currently offline David Muir
Messages: 63
Registered: July 2009
Member
Use one of the latest nightlies instead.
Re: Eclipse 3.4/PDT 2.0 Linux - No syntax checking; no code assist [message #78852 is a reply to message #78712] Wed, 20 August 2008 23:21 Go to previous messageGo to next message
Ed Wright is currently offline Ed Wright
Messages: 11
Registered: July 2009
Junior Member
David,

On 2008/08/20 22:38, David Muir wrote:
> Use one of the latest nightlies instead.

Thanks for the reply.

Have you had experience that syntax checking does not work with
I20080722 but does work with the nightlies? I'm a little leery of
possibly introducing stability or other problems with nightly builds as
I need to get work done and don't have a lot of time to mess with the
platform.

Ed
Re: Eclipse 3.4/PDT 2.0 Linux - No syntax checking; no code assist [message #78878 is a reply to message #78852] Thu, 21 August 2008 07:25 Go to previous messageGo to next message
David Muir is currently offline David Muir
Messages: 63
Registered: July 2009
Member
> Thanks for the reply.

> Have you had experience that syntax checking does not work with
> I20080722 but does work with the nightlies? I'm a little leery of
> possibly introducing stability or other problems with nightly builds as
> I need to get work done and don't have a lot of time to mess with the
> platform.

> Ed

I've found the nightlies to be significantly better. I20080722 has some
big bugs, and they should have released new integration builds after
fixing the issues with code completion, and the $ freese issue (which
isn't completely fixed yet, but vastly improved).
Re: Eclipse 3.4/PDT 2.0 Linux - No syntax checking; no code assist [message #78911 is a reply to message #78878] Thu, 21 August 2008 22:48 Go to previous messageGo to next message
Ed Wright is currently offline Ed Wright
Messages: 11
Registered: July 2009
Junior Member
On 2008/08/21 20:25, David Muir wrote:
> I've found the nightlies to be significantly better.

Hmmm.... ok.... soon's I get a little time I'll give a nightly a try.

Thanks,
Ed
Re: org.eclipse.php.ui.PHPCompletionProposalComputer crash [message #92432 is a reply to message #78615] Fri, 30 January 2009 07:11 Go to previous message
Phil is currently offline Phil
Messages: 7
Registered: July 2009
Junior Member
We're getting this error on various machines now and it's making Eclipse
unusable. Eclipse will freeze as you're typing, and stay locked for around
30-60 seconds, haven't measured it exactly.

Error message:
"The 'org.eclipse.php.ui.PHPCompletionProposalComputer' proposal computer
from the 'org.eclipse.php.ui' plug-in did not complete normally. The
Extension took too long to return from the 'computeCompletionProposals()'
operation."

So far I've seen it on Eclipse 3.4 + PDT 2.0 under XP 32-bit, and Eclipse
3.4 + PDT 2.0 under Ubuntu 64-bit.

The XP install was from the PDT all-in-one. The only other plugins active
are Subclipse and YamlEditor.
Previous Topic:New face to Eclipse PDT Web Site
Next Topic:Hanging on exit, not saving workspace
Goto Forum:
  


Current Time: Fri Aug 22 15:40:03 EDT 2014

Powered by FUDForum. Page generated in 0.01928 seconds