Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » After recent Mylyn upgrade, Eclipse is nagging me for JIRA credentials
After recent Mylyn upgrade, Eclipse is nagging me for JIRA credentials [message #729687] Mon, 26 September 2011 14:52 Go to next message
David M. Karr is currently offline David M. Karr
Messages: 350
Registered: July 2009
Senior Member
A couple days ago I noticed that there was an update for Mylyn, which I installed. This morning I noticed that Eclipse was nagging me with a JIRA credentials dialog, and no matter what I entered, it would continue to nag me. Nothing else has changed. I verified my JIRA credentials and I verified with the JIRA sysadmin that nothing has changed on the JIRA server. I haven't tried restarting Eclipse yet (because it takes too dang long to restart) or rebooting (worse).
Re: After recent Mylyn upgrade, Eclipse is nagging me for JIRA credentials [message #730125 is a reply to message #729687] Tue, 27 September 2011 12:47 Go to previous message
David M. Karr is currently offline David M. Karr
Messages: 350
Registered: July 2009
Senior Member
If it matters, I determined that I needed to determine whether it's continually bringing up the dialog because it thinks the password is wrong, or because it's simply continually bringing up the dialog. I believed it would be the latter, because I've actually seen this behavior in the past. When I saw it before, many months ago, the behavior simply stopping happening after hours or days of it happening.

I simply tried to create a new task from the JIRA repo it's complaining about. I didn't need to actually create one, all I needed to do was use the "Update Project Listing" button. When I clicked this, it brought up the password dialog again, which I confirmed, and then it apparently gave me an updated project listing.

So, for some reason Eclipse is giving me the password dialog on every single interaction it attempts with the JIRA server. I've checked "Save password" every single time, but it appears to have no effect.
Previous Topic:[SOLVED] Mylyn + Trac - My queries only show "Blocker" issues
Next Topic:Package Explorer Missing 'Focus on Active Task'
Goto Forum:
  


Current Time: Thu Jul 24 02:38:57 EDT 2014

Powered by FUDForum. Page generated in 0.04923 seconds