Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Tomcat failed to start(Tomcat failed to start in my Eclipse )
icon4.gif  Tomcat failed to start [message #725428] Wed, 14 September 2011 14:30 Go to next message
chandrurajendran.1217 is currently offline chandrurajendran.1217
Messages: 1
Registered: September 2011
Junior Member
Please help me,
when i changed the versions of tomcat in my eclipse the problem started, it's been already two that the tomcat error ruined my work, i have tried everything but my eclipse says the tomcat failed to start, after many fine tunes now it shows this error msg,


"Server Tomcat v7.0 Server at localhost was unable to start within 45 seconds. If the server requires more time, try increasing the timeout in the server editor."



even after increasing start time the same error returns, my console says,

-----------------------------------------------------------------------------------

14 Sep, 2011 11:55:30 PM org.apache.catalina.core.AprLifecycleListener init
INFO: Loaded APR based Apache Tomcat Native library 1.1.22.
14 Sep, 2011 11:55:30 PM org.apache.catalina.core.AprLifecycleListener init
INFO: APR capabilities: IPv6 [false], sendfile [true], accept filters [false], random [true].
14 Sep, 2011 11:55:30 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.jee.server:jsep' did not find a matching property.
14 Sep, 2011 11:55:31 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-apr-8080"]
14 Sep, 2011 11:55:31 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-apr-8009"]
14 Sep, 2011 11:55:31 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1163 ms
14 Sep, 2011 11:55:31 PM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
14 Sep, 2011 11:55:31 PM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.21
14 Sep, 2011 11:55:31 PM org.apache.catalina.startup.Catalina start
SEVERE: Catalina.start:
org.apache.catalina.LifecycleException: Failed to start component [StandardServer[8005]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:152)
at org.apache.catalina.startup.Catalina.start(Catalina.java:621)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:322)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:450)
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardService[Catalina]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:152)
at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:727)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:148)
... 7 more
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:152)
at org.apache.catalina.core.StandardService.startInternal(StandardService.java:443)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:148)
... 9 more
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:152)
at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:1033)
at org.apache.catalina.core.StandardEngine.startInternal(StandardEngine.java:291)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:148)
... 11 more
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:152)
at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:1033)
at org.apache.catalina.core.StandardHost.startInternal(StandardHost.java:774)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:148)
... 14 more
Caused by: java.lang.NoSuchMethodError: javax.servlet.ServletContext.getSessionCookieConfig()Ljavax/servlet/SessionCookieConfig;
at org.apache.catalina.deploy.WebXml.configureContext(WebXml.java:1308)
at org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1390)
at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:896)
at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:322)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5103)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:148)
... 17 more
14 Sep, 2011 11:55:31 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 216 ms

-------------------------------------------------------------------------------------

what could be wrong, what i can do start the tomcat, somebody please help me..!!!
Re: Tomcat failed to start [message #725478 is a reply to message #725428] Wed, 14 September 2011 17:32 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3136
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 14-Sep-11 12:30, chandrurajendran.1217 wrote:
> Please help me,
> when i changed the versions of tomcat in my eclipse the problem started,
> it's been already two that the tomcat error ruined my work, i have tried
> everything but my eclipse says the tomcat failed to start, after many
> fine tunes now it shows this error msg,
> [snip]
>
> what could be wrong, what i can do start the tomcat, somebody please
> help me..!!!

This is a question for the Eclipse web tools forum. In the meantime, you
should look at http://wiki.eclipse.org/WTP_Tomcat_FAQ
Re: Tomcat failed to start [message #870395 is a reply to message #725478] Mon, 07 May 2012 19:50 Go to previous message
Venkat Star is currently offline Venkat Star
Messages: 1
Registered: May 2012
Junior Member
You just have to double click the server in Eclipse, in the servers perspective, when you double click it you will see a window showing server config and a section named Timeouts.

hope it work for you.


Previous Topic:Remote Search
Next Topic:Project Organisation
Goto Forum:
  


Current Time: Thu Jul 31 15:49:40 EDT 2014

Powered by FUDForum. Page generated in 0.10982 seconds