Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » PDT 3.0.0 Sytax error highlighting in Eclipse Indigo doesnt work
PDT 3.0.0 Sytax error highlighting in Eclipse Indigo doesnt work [message #724889] Tue, 13 September 2011 08:42 Go to next message
Novumcoder  is currently offline Novumcoder
Messages: 2
Registered: September 2011
Junior Member
I just downloaded Eclipse Indigo, then installed PDT 3.0.0 using the standard indigo update site. For some reason whenever i have a syntax error or some warning, its not being highlighted in the editor.

But still, the highlighting still works for Java, but not for PHP files.

Does anyone know how to enable this.

Under Preferences -> Validation, everything is enabled.
Re: PDT 3.0.0 Sytax error highlighting in Eclipse Indigo doesnt work [message #724901 is a reply to message #724889] Tue, 13 September 2011 09:05 Go to previous messageGo to next message
dominik is currently offline dominik
Messages: 122
Registered: July 2009
Senior Member
On 2011-09-13 14:42, Novumcoder wrote:
> I just downloaded Eclipse Indigo, then installed PDT 3.0.0 using the standard
> indigo update site. For some reason whenever i have a syntax error or some
> warning, its not being highlighted in the editor.
>
> But still, the highlighting still works for Java, but not for PHP files.
> Does anyone know how to enable this.
> Under Preferences -> Validation, everything is enabled.

Check error log for problems and errors. There should be something about this.

/dmc
Re: PDT 3.0.0 Sytax error highlighting in Eclipse Indigo doesnt work [message #724909 is a reply to message #724901] Tue, 13 September 2011 09:29 Go to previous message
Novumcoder  is currently offline Novumcoder
Messages: 2
Registered: September 2011
Junior Member
I have only this in my .log file:

!SESSION 2011-09-13 15:25:59.469 -----------------------------------------------
eclipse.buildId=I20110613-1736
java.version=1.6.0_27
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.javascript.product
Command-line arguments:  -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.javascript.product

!ENTRY org.eclipse.osgi 2 1 2011-09-13 15:26:19.017
!MESSAGE NLS unused message: CodeAssistPreferencePage_showStub in: org.eclipse.php.internal.ui.PHPUIMessages
Previous Topic:Huge eclipse index,
Next Topic:smarty templates errors and problems
Goto Forum:
  


Current Time: Thu Jul 24 09:14:01 EDT 2014

Powered by FUDForum. Page generated in 0.01720 seconds