Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » [10.7] Eclipse crashes on updateSplash at startup when launched by launchd(Bug 353185 -- Is there a workaround?)
[10.7] Eclipse crashes on updateSplash at startup when launched by launchd [message #722776] Tue, 06 September 2011 13:07
Steven Darnell is currently offline Steven Darnell
Messages: 18
Registered: November 2010
Junior Member
On Mac 10.7 (Lion), Eclipse crashes on the splash screen when it is launched from the Finder (i.e. using launchd). Bug 353185 (forum won't let me provide a link) describes the problem; however, there has been no activity on the bug since it was reported on 7/27/11 (save other users observing the same problem).

This is a serious problem for my (and other's) RCP apps that has file extensions associated with it. Can anyone on the forum suggest a workaround for the problem?

Some notes from Bug 353185:

Reproducible: Always

Steps to Reproduce:
1. Choose any file in Finder and select Open With | Other... | Eclipse (you may
need to browse to location of your Eclipse installation)
2. Eclipse crashes and Mac shows a crash report

Specifying -nosplash in eclipse.ini doesn't help (it
just hides the splash screen but the crash still occurs).

Stack trace and crash report are available in the bug report.
Previous Topic:How to bundle database drivers and expose a connection pool?
Next Topic:Alternative to -Xbootclasspath
Goto Forum:
  


Current Time: Sat Aug 30 14:33:01 EDT 2014

Powered by FUDForum. Page generated in 0.02474 seconds