Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Problems with Virgo IDE
Problems with Virgo IDE [message #716760] Thu, 18 August 2011 11:05 Go to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-SchwartzFriend
Messages: 448
Registered: July 2009
Senior Member
Hello.

I am moving from STS to the new Virgo IDE for my Virgo/OSGi projects. I have followed the installation instructions as laid out in http://wiki.eclipse.org/Virgo/Tooling and all seems fine.

However, when I try to import my existing projects into the workspace, I get the following error:

Plugin execution not covered by lifecycle configuration: com.springsource.bundlor:com.springsource.bundlor.maven:1.0.0.RELEASE:bundlor (execution: bundlor, phase: compile) pom.xml /com.iggroup.wb.core.common

What does this mean?

TIA,
B.
Re: Problems with Virgo IDE [message #716828 is a reply to message #716760] Thu, 18 August 2011 14:31 Go to previous messageGo to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-SchwartzFriend
Messages: 448
Registered: July 2009
Senior Member
After reading this interesting page, my problem appears to be solved by adding the following to my master pom:
<pluginManagement>
   <plugins>
   <!-- This plugin's configuration is used to store Eclipse m2e settings only. It has no influence on the Maven build itself. -->
      <plugin>
         <groupId>org.eclipse.m2e</groupId>
         <artifactId>lifecycle-mapping</artifactId>
         <version>1.0.0</version>
         <configuration>
            <lifecycleMappingMetadata>
               <pluginExecutions>
	          <pluginExecution>
                     <pluginExecutionFilter>
                        <groupId>
                           com.springsource.bundlor
                        </groupId>
                        <artifactId>
                           com.springsource.bundlor.maven
                        </artifactId>
                        <versionRange>
                           [1.0.0.RELEASE,)
                        </versionRange>
                        <goals>
                           <goal>bundlor</goal>
                        </goals>
                     </pluginExecutionFilter>
                     <action>
                        <ignore></ignore>
                     </action>
                  </pluginExecution>
               </pluginExecutions>
            </lifecycleMappingMetadata>
         </configuration>
      </plugin>
   </plugins>
</pluginManagement>


Hope this is of help to someone else.
Re: Problems with Virgo IDE [message #716839 is a reply to message #716828] Thu, 18 August 2011 14:54 Go to previous messageGo to next message
Chris Frost is currently offline Chris FrostFriend
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Hi,

From within Eclipse the name of the Bundlor .settings file and the properties within it has changed and currently has to be updated manually. This may cause problems if you are using variable replacement in the template.mf of your existing project.

Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Problems with Virgo IDE [message #717122 is a reply to message #716839] Fri, 19 August 2011 11:18 Go to previous messageGo to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-SchwartzFriend
Messages: 448
Registered: July 2009
Senior Member
Hi Chris, thanks for this.

So what do I need to change manually exactly? And is the pom change I detailed earlier the correct approach?

Thanks!
Re: Problems with Virgo IDE [message #717136 is a reply to message #717122] Fri, 19 August 2011 11:59 Go to previous messageGo to next message
Chris Frost is currently offline Chris FrostFriend
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

I know nothing about POM's so I wouldn't like to recommend anything. As for what exactly needs changing, here is an example of the Bundlor settings file under the new tooling.

.settings/org.eclipse.virgo.ide.bundlor.core.prefs


#Thu Aug 11 12:30:55 BST 2011
eclipse.preferences.version=1
org.eclipse.virgo.ide.bundlor.core.bundlor.generated.manifest.autoformatting=false
org.eclipse.virgo.ide.bundlor.core.byte.code.scanning=true
org.eclipse.virgo.ide.bundlor.core.template.properties.files=../build.versions


Hope that helps,
Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Problems with Virgo IDE [message #717223 is a reply to message #717136] Fri, 19 August 2011 15:57 Go to previous message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-SchwartzFriend
Messages: 448
Registered: July 2009
Senior Member
Thanks Chris.

I should have read the Eclipsepedia page till the end, your instructions are clearly explained there also! Embarrassed

My next question is: in the same .settings directory, I can also see an org.springframework.ide.eclipse.core.prefs file. Is this obsolete or should it be retained?

Thanks.
Previous Topic:Install Plandora Project Management on Eclipse Virgo
Next Topic:plans with overlapping artifacts?
Goto Forum:
  


Current Time: Fri Dec 19 01:45:16 GMT 2014

Powered by FUDForum. Page generated in 0.02645 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software