Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Axis web service wsdl file being altered after deploying to application server(Used Axis Top-Down method to create web service and when its deployed the resulting wsdl fails WS-I Basic Profile 1.1)
Axis web service wsdl file being altered after deploying to application server [message #714829] Thu, 11 August 2011 11:06
spincrusher63 is currently offline spincrusher63
Messages: 2
Registered: July 2011
Junior Member
Hi Everybody,

I have a web service I generated through the axis top-down method. I've checked the generated wsdl file in the web contents folder and it is WS-I Basic Profile 1.1 compliant. It also uses the document/literal binding that we need.

But when the web service gets published to an application server like tomcat or websphere, when we try to access the wsdl a lot of the inline schema definitions were altered.
Also the wsdl inputs and outputs in the binding definition had unnecessary name attributes added. The names are correct, the project wsdl file didn't have them.

Is the Axis engine suppose to generate an additional wsdl document when the project is deployed to an application server? And if so, is there a configuration file that is driving the wsdl document changes? Because I would prefer that it does get altered.
Previous Topic:DOM object
Next Topic:Adding Content Assist for external Javascript library
Goto Forum:
  


Current Time: Fri Aug 29 06:29:14 EDT 2014

Powered by FUDForum. Page generated in 0.01700 seconds