Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » AJDT » can't compile anymore pointcut with generic after upgrade
can't compile anymore pointcut with generic after upgrade [message #73533] Fri, 20 March 2009 07:35 Go to next message
Mario L is currently offline Mario L
Messages: 7
Registered: July 2009
Junior Member
Hi all,

I just upgraded AJDT from 1.6.0 to 1.6.4 and suddenly I get the following
error:

[iajc] error at : syncFields(theData, changedMap, outputMap, runRules)
[iajc] ^^^^^^^
[iajc]
E:\hudson\jobs\Main\WOPI\Data\plugins\com.myapp\src\com\myap p\aspects\DataAccess.aj:389:0::0
incompatible type, expected
java.util.HashMap<java.lang.String,com.myapp.model.FieldModel <>> found
BindingTypePattern(java.util.HashMap<java.lang.String,com.csc.ezbook.eztarif.model.FieldModel <*>>,
1). Check the type specified in your pointcut
[iajc] MessageHolder: (74 info) (1 error)
[iajc] [error 0]: error at : syncFields(theData, changedMap,
outputMap, runRules)
[iajc] ^^^^^^^
[iajc]
E:\hudson\jobs\Main\workspace\WOPI\Data\plugins\com.myapp\sr c\com\myapp\aspects\DataAccess.aj:389:0::0
incompatible type, expected
java.util.HashMap<java.lang.String,com.csc.ezbook.eztarif.model.FieldModel <>>
found
BindingTypePattern(java.util.HashMap<java.lang.String,com.csc.ezbook.eztarif.model.FieldModel <*>>,
1). Check the type specified in your pointcut

As you can see I'm using the AspectJ compiler from an Ant script. Nothing
else changed expect this AJDT upgrade. As this 1.6.4 delivery forgot to
deliver some aspectjtools.jar I'm using the one from 1.6.0 - but I don't
think it matters here. By looking at the AspectJ site I also have the
uneasy feeling I got through the AJDT update site an experimental build
(oficially says 1.6.3, but the site pushes 1.6.4) so it might be this.

Anyway I don't really get it: is it complaining about that new
BindingTypePattern, is it complaining about the <> versus <*> (although in
my code it's <?> everywhere), is it complaining about the thing it
underlined (theData), is it an error coming from the AspectJ development
release , do I see one or two errors here, or what? I'm so confused :)

I crossposted this message also to the AspectJ newslist as I have no idea
which is actually the one causing the error.

Thanks for any input,
JM
Re: can't compile anymore pointcut with generic after upgrade [message #73552 is a reply to message #73533] Fri, 20 March 2009 16:43 Go to previous message
Eclipse User
Originally posted by: andrew.eisenberg.springsource.com

The mailing list is the preferred way of communication. I believe that your
question has already been answered on the mailing list, and if you have any
further questions, please ask there.


On 20/03/09 4:35 AM, in article
420afa468537de8ded07aaef15770c2e$1@www.eclipse.org, "Mario"
<send_lotsa_spam_here@yahoo.com> wrote:

> Hi all,
>
> I just upgraded AJDT from 1.6.0 to 1.6.4 and suddenly I get the following
> error:
>
> [iajc] error at : syncFields(theData, changedMap, outputMap, runRules)
> [iajc] ^^^^^^^
> [iajc]
> E:\hudson\jobs\Main\WOPI\Data\plugins\com.myapp\src\com\myap p\aspects\DataAcce
> ss.aj:389:0::0
> incompatible type, expected
> java.util.HashMap<java.lang.String,com.myapp.model.FieldModel <>> found
> BindingTypePattern(java.util.HashMap<java.lang.String,com.csc.ezbook.eztarif.m
> odel.FieldModel<*>>,
> 1). Check the type specified in your pointcut
> [iajc] MessageHolder: (74 info) (1 error)
> [iajc] [error 0]: error at : syncFields(theData, changedMap,
> outputMap, runRules)
> [iajc] ^^^^^^^
> [iajc]
> E:\hudson\jobs\Main\workspace\WOPI\Data\plugins\com.myapp\sr c\com\myapp\aspect
> s\DataAccess.aj:389:0::0
> incompatible type, expected
> java.util.HashMap<java.lang.String,com.csc.ezbook.eztarif.model.FieldModel <>>
> found
> BindingTypePattern(java.util.HashMap<java.lang.String,com.csc.ezbook.eztarif.m
> odel.FieldModel<*>>,
> 1). Check the type specified in your pointcut
>
> As you can see I'm using the AspectJ compiler from an Ant script. Nothing
> else changed expect this AJDT upgrade. As this 1.6.4 delivery forgot to
> deliver some aspectjtools.jar I'm using the one from 1.6.0 - but I don't
> think it matters here. By looking at the AspectJ site I also have the
> uneasy feeling I got through the AJDT update site an experimental build
> (oficially says 1.6.3, but the site pushes 1.6.4) so it might be this.
>
> Anyway I don't really get it: is it complaining about that new
> BindingTypePattern, is it complaining about the <> versus <*> (although in
> my code it's <?> everywhere), is it complaining about the thing it
> underlined (theData), is it an error coming from the AspectJ development
> release , do I see one or two errors here, or what? I'm so confused :)
>
> I crossposted this message also to the AspectJ newslist as I have no idea
> which is actually the one causing the error.
>
> Thanks for any input,
> JM
>
Re: can't compile anymore pointcut with generic after upgrade [message #599791 is a reply to message #73533] Fri, 20 March 2009 16:43 Go to previous message
Andrew Eisenberg is currently offline Andrew Eisenberg
Messages: 77
Registered: July 2009
Member
The mailing list is the preferred way of communication. I believe that your
question has already been answered on the mailing list, and if you have any
further questions, please ask there.


On 20/03/09 4:35 AM, in article
420afa468537de8ded07aaef15770c2e$1@www.eclipse.org, "Mario"
<send_lotsa_spam_here@yahoo.com> wrote:

> Hi all,
>
> I just upgraded AJDT from 1.6.0 to 1.6.4 and suddenly I get the following
> error:
>
> [iajc] error at : syncFields(theData, changedMap, outputMap, runRules)
> [iajc] ^^^^^^^
> [iajc]
> E:\hudson\jobs\Main\WOPI\Data\plugins\com.myapp\src\com\myap p\aspects\DataAcce
> ss.aj:389:0::0
> incompatible type, expected
> java.util.HashMap<java.lang.String,com.myapp.model.FieldModel <>> found
> BindingTypePattern(java.util.HashMap<java.lang.String,com.csc.ezbook.eztarif.m
> odel.FieldModel<*>>,
> 1). Check the type specified in your pointcut
> [iajc] MessageHolder: (74 info) (1 error)
> [iajc] [error 0]: error at : syncFields(theData, changedMap,
> outputMap, runRules)
> [iajc] ^^^^^^^
> [iajc]
> E:\hudson\jobs\Main\workspace\WOPI\Data\plugins\com.myapp\sr c\com\myapp\aspect
> s\DataAccess.aj:389:0::0
> incompatible type, expected
> java.util.HashMap<java.lang.String,com.csc.ezbook.eztarif.model.FieldModel <>>
> found
> BindingTypePattern(java.util.HashMap<java.lang.String,com.csc.ezbook.eztarif.m
> odel.FieldModel<*>>,
> 1). Check the type specified in your pointcut
>
> As you can see I'm using the AspectJ compiler from an Ant script. Nothing
> else changed expect this AJDT upgrade. As this 1.6.4 delivery forgot to
> deliver some aspectjtools.jar I'm using the one from 1.6.0 - but I don't
> think it matters here. By looking at the AspectJ site I also have the
> uneasy feeling I got through the AJDT update site an experimental build
> (oficially says 1.6.3, but the site pushes 1.6.4) so it might be this.
>
> Anyway I don't really get it: is it complaining about that new
> BindingTypePattern, is it complaining about the <> versus <*> (although in
> my code it's <?> everywhere), is it complaining about the thing it
> underlined (theData), is it an error coming from the AspectJ development
> release , do I see one or two errors here, or what? I'm so confused :)
>
> I crossposted this message also to the AspectJ newslist as I have no idea
> which is actually the one causing the error.
>
> Thanks for any input,
> JM
>
Previous Topic:can't compile anymore pointcut with generic after upgrade
Next Topic:AccessControlException using LTW in a custom classloader with a security manager
Goto Forum:
  


Current Time: Thu Apr 24 11:23:36 EDT 2014

Powered by FUDForum. Page generated in 0.07416 seconds