Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Tigerstripe » Errors using TS 2.2.4
Errors using TS 2.2.4 [message #6406] Thu, 06 March 2008 14:57 Go to next message
Marc FLAUW is currently offline Marc FLAUWFriend
Messages: 100
Registered: July 2009
Senior Member
Hello,

I was using Tigerstripe 2.2.1 and I had several projects working under
this version.

I have now upgrated to 2.2.4 and Eclipse Europa. For each one of my
project, I have the following 2 errors:


Project 'fm_model' is missing required library:
'C:\eclipse\plugins\com.tigerstripesoftware.workbench.base_2 .2.1.v20070730-0941\src\compatibility\1.1.x\distrib.core.mod el-1.0.6.jar' fm_model Build
path 1204801538209 6735
Project 'fm_model' is missing required library:
'C:\eclipse\tigerstripe\phantom\lib\phantom.zip' fm_model Build
path 1204801538209 6734

Can you help?

Thanks,

Marc
Re: Errors using TS 2.2.4 [message #6425 is a reply to message #6406] Thu, 06 March 2008 16:16 Go to previous messageGo to next message
Eric Dillon is currently offline Eric DillonFriend
Messages: 103
Registered: July 2009
Senior Member
Hi Marc,

Hmmm... Not too sure about what happened. I suppose you upgraded Eclipse +
Tigerstripe but kept the same workspace? I wonder if TS got its wires
crossed.
Anyway, you should be able to fix this.

In the Tigerstripe Explorer, highlight the project (fm_model), and hit
Alt-Return. This will bring up the properties about this project.
Select the Java Build Path section, and inside there the "Libraries" tab.

You will need to make sure that you get correct references for these
variables:
- "Legacy Core Artifacts"
- PROFILE_ARTIFACTS_LIB.

They should have been updated by TS upon upgrade but I suspect something
went wrong.
They should look like the picture attached.

First of all I'd try to stop Eclipse and restart it, hopefully whatever went
wrong the first time around will fix itself. If not, you should be able to
edit them so that they are valid.
Note that the goal is to get both variables fixed. Then all TS project
(since they use these variables) should be OK after a rebuild.

Let me know how that goes.
Eric


"Marc Flauw" <marc.flauw@hp.com> wrote in message
news:1a3435ccb90b11b4a154b10e1f77e2a3$1@www.eclipse.org...
> Hello,
>
> I was using Tigerstripe 2.2.1 and I had several projects working under
> this version.
>
> I have now upgrated to 2.2.4 and Eclipse Europa. For each one of my
> project, I have the following 2 errors:
>
>
> Project 'fm_model' is missing required library:
> 'C:\eclipse\plugins\com.tigerstripesoftware.workbench.base_2 .2.1.v20070730-0941\src\compatibility\1.1.x\distrib.core.mod el-1.0.6.jar'
> fm_model Build
> path 1204801538209 6735
> Project 'fm_model' is missing required library:
> 'C:\eclipse\tigerstripe\phantom\lib\phantom.zip' fm_model Build
> path 1204801538209 6734
>
> Can you help?
>
> Thanks,
>
> Marc
>


  • Attachment: settings.gif
    (Size: 17.04KB, Downloaded 147 times)
Re: Errors using TS 2.2.4 [message #6444 is a reply to message #6425] Thu, 06 March 2008 16:44 Go to previous message
Marc FLAUW is currently offline Marc FLAUWFriend
Messages: 100
Registered: July 2009
Senior Member
Eric,

Thanks. Yes, I did use the same workspace as before.

I did that (exiting from Eclipse) and it didn't change anything.

Then I created a new test project from scratch and by magic, all these
errors went away...

Strange... but anyway, as it is a temporary version.

I hope you will provide migration from both 2.2.1 and 22.4 for your new
Eclipse version.

Best regards,

Marc
Re: Errors using TS 2.2.4 [message #562069 is a reply to message #6406] Thu, 06 March 2008 16:16 Go to previous message
Eric Dillon is currently offline Eric DillonFriend
Messages: 103
Registered: July 2009
Senior Member
Hi Marc,

Hmmm... Not too sure about what happened. I suppose you upgraded Eclipse +
Tigerstripe but kept the same workspace? I wonder if TS got its wires
crossed.
Anyway, you should be able to fix this.

In the Tigerstripe Explorer, highlight the project (fm_model), and hit
Alt-Return. This will bring up the properties about this project.
Select the Java Build Path section, and inside there the "Libraries" tab.

You will need to make sure that you get correct references for these
variables:
- "Legacy Core Artifacts"
- PROFILE_ARTIFACTS_LIB.

They should have been updated by TS upon upgrade but I suspect something
went wrong.
They should look like the picture attached.

First of all I'd try to stop Eclipse and restart it, hopefully whatever went
wrong the first time around will fix itself. If not, you should be able to
edit them so that they are valid.
Note that the goal is to get both variables fixed. Then all TS project
(since they use these variables) should be OK after a rebuild.

Let me know how that goes.
Eric


"Marc Flauw" <marc.flauw@hp.com> wrote in message
news:1a3435ccb90b11b4a154b10e1f77e2a3$1@www.eclipse.org...
> Hello,
>
> I was using Tigerstripe 2.2.1 and I had several projects working under
> this version.
>
> I have now upgrated to 2.2.4 and Eclipse Europa. For each one of my
> project, I have the following 2 errors:
>
>
> Project 'fm_model' is missing required library:
> 'C:\eclipse\plugins\com.tigerstripesoftware.workbench.base_2 .2.1.v20070730-0941\src\compatibility\1.1.x\distrib.core.mod el-1.0.6.jar'
> fm_model Build
> path 1204801538209 6735
> Project 'fm_model' is missing required library:
> 'C:\eclipse\tigerstripe\phantom\lib\phantom.zip' fm_model Build
> path 1204801538209 6734
>
> Can you help?
>
> Thanks,
>
> Marc
>


  • Attachment: settings.gif
    (Size: 17.04KB, Downloaded 89 times)
Re: Errors using TS 2.2.4 [message #562094 is a reply to message #6425] Thu, 06 March 2008 16:44 Go to previous message
Marc FLAUW is currently offline Marc FLAUWFriend
Messages: 100
Registered: July 2009
Senior Member
Eric,

Thanks. Yes, I did use the same workspace as before.

I did that (exiting from Eclipse) and it didn't change anything.

Then I created a new test project from scratch and by magic, all these
errors went away...

Strange... but anyway, as it is a temporary version.

I hope you will provide migration from both 2.2.1 and 22.4 for your new
Eclipse version.

Best regards,

Marc
Previous Topic:Errors using TS 2.2.4
Next Topic:Class Diagram problems
Goto Forum:
  


Current Time: Thu Nov 27 23:37:55 GMT 2014

Powered by FUDForum. Page generated in 0.02345 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software