Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » "Cannot find a solution satisfying the following requirements com.python.pydev.codecompletion&q(can't install roundtrip (pyuml) via update site because of pydev.codecompletion error)
"Cannot find a solution satisfying the following requirements com.python.pydev.codecompletion&q [message #697850] Mon, 18 July 2011 07:58 Go to next message
amadain Mising name is currently offline amadain Mising name
Messages: 3
Registered: July 2011
Junior Member
Hi
I'm hoping somebody can help me. I have eclipse 3.4.2 with pydev 2.2.1 installed on it. I want to install roundtrip (pyuml) on my eclipse via the update site (this is the recommended way). The trouble is when I try to install I get the following error:

Cannot find a solution satisfying the following requirements com.python.pydev.codecompletion [2.2.1.2011071313]

and the software won't install. I verified via Preferences that code completion was enabled for the editor under pydev. I tried updating pydev (the error was originally on an earlier version "Cannot find a solution satisfying the following requirements com.python.pydev.codecompletion [2.2.0.2011062419]")

On my eclipse box I have the following:

Java version 1.6.0_16

[bash]$ java -version
java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) 64-Bit Server VM (build 14.2-b01, mixed mode)
[bash]$

Python 2.4.3 (#1, Dec 10 2010, 17:24:35)

Eclipse Version: 3.4.2

PyDev for eclipse 2.2.1.2011071313

Can anybody offer guidance as to what to check next and how to resolve this?

Thanks

A
Re: "Cannot find a solution satisfying the following requirements com.python.pydev.codecomp [message #699121 is a reply to message #697850] Wed, 20 July 2011 21:28 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric Rizzo
Messages: 2313
Registered: July 2009
Senior Member
On 7/18/11 3:58 AM, amadain wrote:
> Hi
> I'm hoping somebody can help me. I have eclipse 3.4.2 with pydev 2.2.1
> installed on it. I want to install roundtrip (pyuml) on my eclipse via
> the update site (this is the recommended way). The trouble is when I try
> to install I get the following error:
>
> Cannot find a solution satisfying the following requirements
> com.python.pydev.codecompletion [2.2.1.2011071313]

There should be some more lines of information after that; it would help
to see the full details.

Eric
Re: "Cannot find a solution satisfying the following requirements com.python.pydev.codecomp [message #699229 is a reply to message #699121] Thu, 21 July 2011 06:38 Go to previous messageGo to next message
amadain Mising name is currently offline amadain Mising name
Messages: 3
Registered: July 2011
Junior Member
This is what comes up In the install box details when I try to install PyUml Feature Version 1.2.2:

Cannot complete the request. See the details.
Cannot find a solution satisfying the following requirements com.python.pydev.codecompletion [2.2.1.2011071313].



workspace/.metadata/.log says:

!ENTRY org.eclipse.equinox.p2.director 4 0 2011-07-21 06:36:35.829
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from org.python.pydev 1.5.2.1260362205 to requiredCapability: osgi.bundle/org.eclipse.compare.core/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUml 1.2.2 to requiredCapability: osgi.bundle/org.eclipse.emf.common/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUml 1.2.2 to requiredCapability: osgi.bundle/org.eclipse.emf.ecore/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUml 1.2.2 to requiredCapability: osgi.bundle/org.eclipse.uml2.uml/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUml 1.2.2 to requiredCapability: osgi.bundle/org.eclipse.gmf.runtime.common.core/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUml 1.2.2 to requiredCapability: osgi.bundle/org.eclipse.gmf.runtime.diagram.core/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUml 1.2.2 to requiredCapability: osgi.bundle/org.eclipse.gmf.runtime.common.ui/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUml 1.2.2 to requiredCapability: osgi.bundle/org.eclipse.gmf.runtime.diagram.ui/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUml 1.2.2 to requiredCapability: osgi.bundle/org.eclipse.gmf.runtime.diagram.ui.resources.editor/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUml 1.2.2 to requiredCapability: osgi.bundle/org.eclipse.uml2.diagram.clazz/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from org.python.pydev.red_core 1.5.9.2010063000 to requiredCapability: osgi.bundle/com.aptana.theme/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUML.feature.group 1.2.2 to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.emf.common/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUML.feature.group 1.2.2 to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.emf.ecore/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUML.feature.group 1.2.2 to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.uml2.uml/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUML.feature.group 1.2.2 to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.common.core/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUML.feature.group 1.2.2 to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.diagram.core/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUML.feature.group 1.2.2 to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.common.ui/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUML.feature.group 1.2.2 to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.diagram.ui/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUML.feature.group 1.2.2 to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.diagram.ui.resources.editor/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-07-21 06:36:35.829
!MESSAGE Unable to satisfy dependency from pyUML.feature.group 1.2.2 to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.uml2.diagram.clazz/0.0.0.
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2011-07-21 06:36:35.829
!MESSAGE No solution found because the problem in /tmp/p2Encoding3903441005037336562.opb is unsatisfiable.

!ENTRY org.eclipse.equinox.p2.ui 4 10005 2011-07-21 06:36:36.173
!MESSAGE Cannot complete the request. See the details.
!SUBENTRY 1 org.eclipse.equinox.p2.ui 4 10005 2011-07-21 06:36:36.173
!MESSAGE Cannot complete the request. See the details.
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2011-07-21 06:36:36.173
!MESSAGE Cannot find a solution satisfying the following requirements com.python.pydev.codecompletion [2.2.1.2011071313].

!ENTRY org.eclipse.equinox.p2.ui 4 10005 2011-07-21 06:36:36.569
!MESSAGE Cannot complete the request. See the details.
!SUBENTRY 1 org.eclipse.equinox.p2.ui 4 10005 2011-07-21 06:36:36.569
!MESSAGE Cannot complete the request. See the details.
!SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2011-07-21 06:36:36.569
!MESSAGE Cannot find a solution satisfying the following requirements com.python.pydev.codecompletion [2.2.1.2011071313].

Re: "Cannot find a solution satisfying the following requirements com.python.pydev.codecomp [message #876483 is a reply to message #699229] Thu, 24 May 2012 17:36 Go to previous messageGo to next message
Le Snelson is currently offline Le Snelson
Messages: 2
Registered: October 2011
Junior Member
A year later and I'm having the same problem resolving 'org.eclipse.uml2.diagram.clazz 0.0.0' for pyUml.

Did you resolve this? If so could you briefly document what you learned here for us newbies?
Re: "Cannot find a solution satisfying the following requirements com.python.pydev.codecomp [message #997008 is a reply to message #876483] Thu, 03 January 2013 12:03 Go to previous messageGo to next message
amadain Mising name is currently offline amadain Mising name
Messages: 3
Registered: July 2011
Junior Member
This was never answered and the problem remains. I don't know if nobody looks at these forums or if there is no answer but this is all I ever got from this question - nothing. Confused
Re: "Cannot find a solution satisfying the following requirements com.python.pydev.code [message #997098 is a reply to message #997008] Thu, 03 January 2013 15:50 Go to previous message
Russell Bateman is currently offline Russell Bateman
Messages: 3225
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 1/3/2013 5:03 AM, amadain Mising name wrote:
> This was never answered and the problem remains. I don't know if nobody
> looks at these forums or if there is no answer but this is all I ever
> got from this question - nothing. :?

From en.wikipedia.org/wiki/Pydev :

PyDev is a third-party plug-in for Eclipse.

This makes the problem very marginal in terms of support in this forum.
You're waiting on the off-chance that someone who knows something about
PyDev will happen to visit and see the question. This hasn't happened.

You should contact the Appcelerator folk about this; it appears that
PyDev belongs to them now.
Previous Topic:help plz!!
Next Topic:"Egit could not detect where GIT is installed"
Goto Forum:
  


Current Time: Sat Oct 25 06:31:26 GMT 2014

Powered by FUDForum. Page generated in 0.01732 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software