Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » WindowBuilder » Cant install wb toolkits([Eclipse 3.7, WB as included with release])
Cant install wb toolkits [message #696539] Thu, 14 July 2011 08:50 Go to next message
hai.kataker is currently offline hai.katakerFriend
Messages: 2
Registered: July 2011
Junior Member
Hello everyone,

I use Eclipse for Java development, and recently updated to Indigo/3.7.
I was pleasently surprised to find out that it now includes "a" Window Builder (I did not know the project before). However, I cannot seem to install any of the windowing toolkits required to actually use the WB (and I don't see why none of them is included with the release, if wb is included itself -- since it is useless without the toolkits).

I use Eclipse 3.7 (Java SE package) on a Win7 Home Premium 32bit, and on a Win7 Pro 64bit (however, I use 32bit Eclipse on both machines). I cleaned the eclipse folder when I updated, and I also tested installing the Toolkits on clean workspaces.
When I try to let Eclipse install any of the 4 selectable windowing toolkits (either from the WB menu, from marketplace or from "Install new software"), it takes a long time and then fails with an installation error, which mainly consist of
Quote:
eclipse.buildId=I20110613-1736
java.version=1.6.0_26
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Framework arguments: -product org.eclipse.epp.package.java.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.java.product

Error
Thu Jul 14 10:12:22 CEST 2011
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

and
Quote:
eclipse.buildId=I20110613-1736
java.version=1.6.0_26
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Framework arguments: -product org.eclipse.epp.package.java.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.java.product

Error
Thu Jul 14 10:12:22 CEST 2011
Artifact not found: osgi.bundle,org.eclipse.wb.core,1.0.0.r37x201107060849.

java.io.FileNotFoundException: ftp://artfiles.org/eclipse.org//windowbuilder/WB/release/R201106211200/3.7/plugins/org.eclipse.wb.core_1.0.0.r37x201107060849.jar
at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryStatusHelper.checkFileNotFound(RepositoryStatusHelper.java:297)
at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.checkException(FileReader.java:384)
at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.sendRetrieveRequest(FileReader.java:358)
at org.eclipse.equinox.internal.p2.transport.ecf.FileReader.readInto(FileReader.java:295)
at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryTransport.download(RepositoryTransport.java:80)
at org.eclipse.equinox.internal.p2.transport.ecf.RepositoryTransport.download(RepositoryTransport.java:130)
at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(SimpleArtifactRepository.java:625)
at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(SimpleArtifactRepository.java:569)
at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:680)
at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.getArtifact(MirrorRequest.java:260)
at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transferSingle(MirrorRequest.java:235)
at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transfer(MirrorRequest.java:191)
at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.perform(MirrorRequest.java:122)
at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:664)
at org.eclipse.equinox.internal.p2.artifact.repository.simple.DownloadJob.run(DownloadJob.java:63)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)


I have also tried this from different network connections, so a connection problem on my end seems rather unlikely. Google was also quite silent on the matter.

Does anyone else have this problem? Does someone know more about what those errors mean? Does this problem warrant a bug report?

Best regards and thanks in advance,
~Nevik
Re: Cant install wb toolkits [message #696668 is a reply to message #696539] Thu, 14 July 2011 14:37 Go to previous messageGo to next message
Devon Carew is currently offline Devon CarewFriend
Messages: 1
Registered: July 2011
Junior Member
When I manually try and connect to ftp_//artfiles.org/eclipse.org//windowbuilder/WB/release/R201106211200/3.7/plugins/org.eclipse.wb.core_1.0.0.r37x201107060849.jar (or to ftp_//artfiles.org/eclipse.org/windowbuilder/WB/release/R201106211200/3.7/plugins/org.eclipse.wb.core_1.0.0.r37x201107060849.jar) I get a 601 error. Is this mirror up to date? Does it contain the WindowBuilder plugins?

The normal Eclipse + WindowBuilder distribution ships with the Swing UI toolkit but not any of the others (in the interest of space). You can manually install additional WindowBuilder toolkits using the http //download.eclipse.org/windowbuilder/WB/integration/3.7 update site. This will hopefully get around any issues with that mirror (if that's the actually problem). Cheers,

Devon
Re: Cant install wb toolkits [message #696700 is a reply to message #696668] Thu, 14 July 2011 16:15 Go to previous messageGo to next message
hai.kataker is currently offline hai.katakerFriend
Messages: 2
Registered: July 2011
Junior Member
Hey, I just tried installing again, making sure to select the download.eclipse.org mirror and disabling "check all available sites for dependencies"; still no success. I get the same error, and this time i can past you the error as it is displayed in the dialog:
Quote:
An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Artifact not found: osgi.bundle,org.eclipse.wb.core,1.0.0.r37x201107060849.
ftp_//eclipse.stu.edu.tw/eclipse/windowbuilder/WB/release/R201106211200/3.7/plugins/org.eclipse.wb.core_1.0.0.r37x201107060849.jar
Artifact not found: osgi.bundle,org.eclipse.wb.core.databinding,1.0.0.r37x201107060849.
http_//eclipse.stu.edu.tw/windowbuilder/WB/release/R201106211200/3.7/plugins/org.eclipse.wb.core.databinding_1.0.0.r37x201107060849.jar
Artifact not found: osgi.bundle,org.eclipse.wb.core.lib,1.0.0.r37x201107060849.
http_//eclipse.stu.edu.tw//windowbuilder/WB/release/R201106211200/3.7/plugins/org.eclipse.wb.core.lib_1.0.0.r37x201107060849.jar
Artifact not found: osgi.bundle,org.eclipse.wb.core.ui,1.0.0.r37x201107060853.
http_//mirror.netcologne.de/eclipse//windowbuilder/WB/release/R201106211200/3.7/plugins/org.eclipse.wb.core.ui_1.0.0.r37x201107060853.jar


As you can see, it selected a different mirror, to which was probably redirected by the eclipse download site.
What I also noticed is that at the beginning of the download, it tries to get an XML file with a rather obscure link (unfortunately you cannot copy/paste it from the download dialog and it's not included in the errors). It was formed something like "http_//download.eclipse.org/download/download.php?/windowbuilder/WB/release/R201106211200/3.7/plugins/org.eclipse.wb.core.ui_1.0.0.r37x201107060853&[langcode, format, etc]" (I'm not certain the windowbuilder/... path is correct like that, but it was similar. What i did notice was that in the additional parameters that followed, no ampersands separated the parameters (that should be there for HTTP requests); but I don't know if the dialog just doesnt display them, or if they weren't there in the actual request sent to the server.
I assume that it gets a mirror from download.eclipse.org in that XML file (if it does get it, which I can't tell -- at least there is no FileNotFoundException).

So, the next thing I would like to try is, set a mirror site manually -- but how do i find out the exact path to the WB download site that's located on a mirror?
Re: Cant install wb toolkits [message #696929 is a reply to message #696700] Fri, 15 July 2011 06:50 Go to previous messageGo to next message
NirZ  is currently offline NirZ Friend
Messages: 2
Registered: July 2011
Junior Member
Hi, Facing same problem on win7 32 bit.

Anyone found the solution for it please?
can we download some how the windowbuilder plugin, and install it manually maybe?
Re: Cant install wb toolkits [message #697039 is a reply to message #696929] Fri, 15 July 2011 11:33 Go to previous message
NirZ  is currently offline NirZ Friend
Messages: 2
Registered: July 2011
Junior Member
Hi,
ok. i downloaded it manually from: grrr.. i cant put links.
just add colon after http
http //eclipse.org/windowbuilder/download.php
and now i can install it through eclipse from local folder.

at last after 4 days i succeeded lol
Previous Topic:Using Substance Skins causes errors
Next Topic:Set execution context (CWD)?
Goto Forum:
  


Current Time: Sun Nov 23 03:41:03 GMT 2014

Powered by FUDForum. Page generated in 0.02473 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software