Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Error ruleMemo while creating new Xtext project
Error ruleMemo while creating new Xtext project [message #689021] Sun, 26 June 2011 10:50 Go to next message
El Arbi Aboussoror is currently offline El Arbi Aboussoror
Messages: 90
Registered: June 2010
Member
Hi,

I have dowloaded Xtext 1.0.2 from the update site on my Helios 3.6.1
And when I click on finish in the first page of the new Xtext project wizard (with the default settings) I have an error popup window with "RuleMemo"

And this is the event details from the Error Log view
eclipse.buildId=M20100909-0800
java.version=1.6.0_23
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Framework arguments: -product org.eclipse.epp.package.modeling.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.modeling.product


Error
Sun Jun 26 16:48:03 CEST 2011
org.eclipse.xtext.internal.ResourceServiceProviderDescriptor - Plug-in org.eclipse.emf.mwe2.language.ui was unable to load class org.eclipse.emf.mwe2.language.ui.Mwe2ExecutableExtensionFactory.
Re: Error ruleMemo while creating new Xtext project [message #692615 is a reply to message #689021] Mon, 04 July 2011 16:52 Go to previous message
Sebastian Zarnekow is currently offline Sebastian Zarnekow
Messages: 2809
Registered: July 2009
Senior Member
Hi,

I'm afraid there is a version of the Antlr runtime plugin installed that
is not compatible to the version that is required by Xtext.

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

On 26.06.11 16:50, ElArbi wrote:
> Hi,
>
> I have dowloaded Xtext 1.0.2 from the update site on my Helios 3.6.1
> And when I click on finish in the first page of the new Xtext project
> wizard (with the default settings) I have an error popup window with
> "RuleMemo"
>
> And this is the event details from the Error Log view
> eclipse.buildId=M20100909-0800
> java.version=1.6.0_23
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
> Framework arguments: -product org.eclipse.epp.package.modeling.product
> Command-line arguments: -os win32 -ws win32 -arch x86_64 -product
> org.eclipse.epp.package.modeling.product
>
>
> Error
> Sun Jun 26 16:48:03 CEST 2011
> org.eclipse.xtext.internal.ResourceServiceProviderDescriptor - Plug-in
> org.eclipse.emf.mwe2.language.ui was unable to load class
> org.eclipse.emf.mwe2.language.ui.Mwe2ExecutableExtensionFactory.
>
Previous Topic:Xtext index and referenced JARs
Next Topic:Multiple resources and validation problem
Goto Forum:
  


Current Time: Fri Jul 25 09:58:28 EDT 2014

Powered by FUDForum. Page generated in 0.03841 seconds