Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » How to debug plugins in application server (bea weblogic)
How to debug plugins in application server (bea weblogic) [message #69195] Thu, 29 June 2006 12:51 Go to next message
Eclipse User
Originally posted by: patrick.verboom.juwimm.com

Hi,

I am using equinox's http servlet bridge to run servlets as plugins.
I start my bea weblogic 8 application server with the weblogic plugin in
eclipse.
I used to have the possibility to debug servlets in eclipse by setting
brakepoints in my servlet however this doesn't work with the plugins.
With the plugins the breakpoints are completely ignored.
Does this have something todo with the classloading??
Currently I am using log statements for my debugging but is there a way
to really debug plugins?

Kind Regards,
Patrick Verboom
Re: How to debug plugins in application server (bea weblogic) [message #69337 is a reply to message #69195] Fri, 30 June 2006 10:06 Go to previous message
Eclipse User
Originally posted by: simon.kaegi.cognos.com

Hi Patrick,

You can definitely debug by using regular "Remote Java Application" in the
Eclipse IDE "debug..." section.

I haven't tried the Weblogic plugin but you might try putting break-points
in the "BridgeServlet" and the "FrameworkLauncher" in
"org.eclipse.equinox.servlet.bridge.launcher" and then see if you can't walk
into "EclipseStarter". That's the first Class not on the regular webapp
classloader so perhaps that would help narrow the problem.

-Simon

"patrick" <patrick.verboom@juwimm.com> wrote in message
news:e8109f$gd3$1@utils.eclipse.org...
> Hi,
>
> I am using equinox's http servlet bridge to run servlets as plugins.
> I start my bea weblogic 8 application server with the weblogic plugin in
> eclipse.
> I used to have the possibility to debug servlets in eclipse by setting
> brakepoints in my servlet however this doesn't work with the plugins.
> With the plugins the breakpoints are completely ignored.
> Does this have something todo with the classloading??
> Currently I am using log statements for my debugging but is there a way to
> really debug plugins?
>
> Kind Regards,
> Patrick Verboom
Previous Topic:Servlets with Equinox
Next Topic:configuration to launch the Equinox OSGi framework.
Goto Forum:
  


Current Time: Sat Apr 19 09:08:57 EDT 2014

Powered by FUDForum. Page generated in 0.02559 seconds