Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Problem generating in Xtext 2.0
Problem generating in Xtext 2.0 [message #677183] Tue, 07 June 2011 19:28 Go to next message
Mary Komor is currently offline Mary Komor
Messages: 48
Registered: July 2009
Member
Hi,

I installed Eclipse 3.7 RC3 + Xtext 2.0 and am getting the error below when
I try to generate using my mwe2 file. I am able to generate using the
DomainModel example. I was able to generate using Eclipse 3.6.2 + Xtext
1.0.2 using the same mwe2 file.

Am I missing something?


4 [main] ERROR mf.mwe2.launch.runtime.Mwe2Launcher - Nullparser
java.lang.UnsupportedOperationException: Nullparser
at
org.eclipse.xtext.parser.antlr.IAntlrParser$NullParser.parse(IAntlrParser.java:39)
at org.eclipse.xtext.resource.XtextResource.doLoad(XtextResource.java:146)
at
org.eclipse.xtext.linking.lazy.LazyLinkingResource.doLoad(LazyLinkingResource.java:63)
at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1511)
at
org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1290)
at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:255)
at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:270)
at
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResource(ResourceSetImpl.java:397)
at
org.eclipse.xtext.resource.SynchronizedXtextResourceSet.getResource(SynchronizedXtextResourceSet.java:23)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:47)
at
org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:74)
at
org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:35)
Re: Problem generating in Xtext 2.0 [message #677209 is a reply to message #677183] Tue, 07 June 2011 20:31 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian Dietrich
Messages: 6396
Registered: July 2009
Senior Member
Hi,

it seems you still have some Xtext 1.0.x stuff installed or on classpath. please make sure that your workflows project has deps to the Xtext 2.0.0 plugins. see Migrating from Xtext 1.0.x to 2.0 from the docs

~Christian

[Updated on: Tue, 07 June 2011 20:33]

Report message to a moderator

Re: Problem generating in Xtext 2.0 [message #677241 is a reply to message #677183] Tue, 07 June 2011 22:04 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian Zarnekow
Messages: 2911
Registered: July 2009
Senior Member
Hi Mary,

Xtext 2.0 requires Antlr 3.2. Please make sure that the parser generator
is available in exactly that version. The easiest way would be to
install Xtext from http://download.itemis.com/updates/milestones

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 07.06.11 21:28, schrieb Mary Komor:
> Hi,
>
> I installed Eclipse 3.7 RC3 + Xtext 2.0 and am getting the error below
> when I try to generate using my mwe2 file. I am able to generate using
> the DomainModel example. I was able to generate using Eclipse 3.6.2 +
> Xtext 1.0.2 using the same mwe2 file.
>
> Am I missing something?
>
>
> 4 [main] ERROR mf.mwe2.launch.runtime.Mwe2Launcher - Nullparser
> java.lang.UnsupportedOperationException: Nullparser
> at
> org.eclipse.xtext.parser.antlr.IAntlrParser$NullParser.parse(IAntlrParser.java:39)
>
> at org.eclipse.xtext.resource.XtextResource.doLoad(XtextResource.java:146)
> at
> org.eclipse.xtext.linking.lazy.LazyLinkingResource.doLoad(LazyLinkingResource.java:63)
>
> at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1511)
>
> at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1290)
>
> at
> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:255)
>
> at
> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:270)
>
> at
> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResource(ResourceSetImpl.java:397)
>
> at
> org.eclipse.xtext.resource.SynchronizedXtextResourceSet.getResource(SynchronizedXtextResourceSet.java:23)
>
> at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:47)
> at
> org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:74)
> at
> org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:35)
>
>
Re: Problem generating in Xtext 2.0 [message #677268 is a reply to message #677241] Wed, 08 June 2011 00:04 Go to previous message
Mary Komor is currently offline Mary Komor
Messages: 48
Registered: July 2009
Member
I think this *may* have been due to an incorrect setup in my Target
Platform. It's working now. Thanks for your help!

Mary

"Sebastian Zarnekow" <Sebastian.Zarnekow@itemis.de> wrote in message
news:ism6jh$6cf$1@news.eclipse.org...
> Hi Mary,
>
> Xtext 2.0 requires Antlr 3.2. Please make sure that the parser generator
> is available in exactly that version. The easiest way would be to install
> Xtext from http://download.itemis.com/updates/milestones
>
> Regards,
> Sebastian
> --
> Need professional support for Eclipse Modeling?
> Go visit: http://xtext.itemis.com
>
> Am 07.06.11 21:28, schrieb Mary Komor:
>> Hi,
>>
>> I installed Eclipse 3.7 RC3 + Xtext 2.0 and am getting the error below
>> when I try to generate using my mwe2 file. I am able to generate using
>> the DomainModel example. I was able to generate using Eclipse 3.6.2 +
>> Xtext 1.0.2 using the same mwe2 file.
>>
>> Am I missing something?
>>
>>
>> 4 [main] ERROR mf.mwe2.launch.runtime.Mwe2Launcher - Nullparser
>> java.lang.UnsupportedOperationException: Nullparser
>> at
>> org.eclipse.xtext.parser.antlr.IAntlrParser$NullParser.parse(IAntlrParser.java:39)
>>
>> at
>> org.eclipse.xtext.resource.XtextResource.doLoad(XtextResource.java:146)
>> at
>> org.eclipse.xtext.linking.lazy.LazyLinkingResource.doLoad(LazyLinkingResource.java:63)
>>
>> at
>> org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1511)
>>
>> at
>> org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1290)
>>
>> at
>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:255)
>>
>> at
>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:270)
>>
>> at
>> org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResource(ResourceSetImpl.java:397)
>>
>> at
>> org.eclipse.xtext.resource.SynchronizedXtextResourceSet.getResource(SynchronizedXtextResourceSet.java:23)
>>
>> at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:47)
>> at
>> org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:74)
>> at
>> org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:35)
>>
>>
>
Previous Topic:navigating through an importURI statement
Next Topic:learning xtext
Goto Forum:
  


Current Time: Fri Oct 31 07:48:25 GMT 2014

Powered by FUDForum. Page generated in 0.01644 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software