Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » No application id has been found(Add org.eclipse.equinox.p2.ui.sdk,then: no application id has been found)
icon8.gif  No application id has been found [message #675377] Tue, 31 May 2011 06:34 Go to next message
wmhsss is currently offline wmhsss
Messages: 5
Registered: May 2011
Junior Member
when I add org.eclipse.equinox.p2.ui.sdk to Dependencies, then has a Exception: No application id has been found;

The following steps is my operation:
1, Create a RCP project on the "Eclipse RCP with a view" template
2, Add a product configuration.

now I "launch an eclipse applicatin" in product configration, it's ok,
then i add "org.eclipse.equinox.p2.ui.sdk" to "Dependencipes" in MANIFAST.MF,
"launch an eclipse applicatin" in "MANIFAST.MF" it's ok but "launch an eclipse applicatin" in product configration has a exception: No application id has been found,


when I add org.eclipse.equinox.p2.ui.sdk to Dependencies, then has a Exception: No application id has been found;

The following steps is my operation:
1, Create a RCP project on the "Eclipse RCP with a view" template
2, Add a product configuration.

now I "launch an eclipse applicatin" in product configration, it's ok,
then i add "org.eclipse.equinox.p2.ui.sdk" to "Dependencipes" in MANIFAST.MF,
"launch an eclipse applicatin" in "MANIFAST.MF" it's ok but "launch an eclipse applicatin" in product configration has a exception: No application id has

been found,



!SESSION 2011-05-31 18:23:44.328 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=zh_CN
Framework arguments: -product pro.product
Command-line arguments: -product pro.product -data E:\RCP/../runtime-pro.product -dev

file:E:/RCP/.metadata/.plugins/org.eclipse.pde.core/pro.product/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.equinox.app 0 0 2011-05-31 18:23:45.015
!MESSAGE Product pro.product could not be found.

!ENTRY org.eclipse.osgi 2 0 2011-05-31 18:23:45.031
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-05-31 18:23:45.031
!MESSAGE Bundle initial@reference:file:E:/RCP/pro/ was not resolved.
!SUBENTRY 2 pro 2 0 2011-05-31 18:23:45.031
!MESSAGE Missing required bundle org.eclipse.equinox.p2.ui.sdk_1.0.100.

!ENTRY org.eclipse.osgi 2 0 2011-05-31 18:23:45.031
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-05-31 18:23:45.031
!MESSAGE Bundle pro_1.0.0.qualifier [25] was not resolved.
!SUBENTRY 2 pro 2 0 2011-05-31 18:23:45.031
!MESSAGE Missing required bundle org.eclipse.equinox.p2.ui.sdk_1.0.100.

!ENTRY org.eclipse.osgi 2 0 2011-05-31 18:23:45.031
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-05-31 18:23:45.031
!MESSAGE Bundle initial@reference:file:E:/RCP/pro/ was not resolved.
!SUBENTRY 2 pro 2 0 2011-05-31 18:23:45.031
!MESSAGE Missing required bundle org.eclipse.equinox.p2.ui.sdk_1.0.100.

!ENTRY org.eclipse.osgi 2 0 2011-05-31 18:23:45.031
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2011-05-31 18:23:45.031
!MESSAGE Bundle pro_1.0.0.qualifier [25] was not resolved.
!SUBENTRY 2 pro 2 0 2011-05-31 18:23:45.031
!MESSAGE Missing required bundle org.eclipse.equinox.p2.ui.sdk_1.0.100.

!ENTRY org.eclipse.osgi 4 0 2011-05-31 18:23:45.031
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
at org.eclipse.equinox.launcher.Main.main(Main.java:1384)

Re: No application id has been found [message #728975 is a reply to message #675377] Sat, 24 September 2011 12:09 Go to previous messageGo to next message
Parvez Ahmad Hakim is currently offline Parvez Ahmad Hakim
Messages: 31
Registered: May 2010
Member
I too get the same error. Any help
Parvez Ahmad Hakim
Srinagar http://www.abobjects.com/

!SESSION 2011-09-24 21:33:46.603 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=in
Framework arguments: -product org.cord.client.dms.mainapp.e4.product
Command-line arguments: -product org.cord.client.dms.mainapp.e4.product -data D:\Commit-3.7SR1-RCP\project/../runtime-org.cord.client.dms.mainapp.e4.product -dev file:D:/Commit-3.7SR1-RCP/project/.metadata/.plugins/org.eclipse.pde.core/org.cord.client.dms.mainapp.e4.product/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.equinox.app 0 0 2011-09-24 21:33:49.346
!MESSAGE Product org.cord.client.dms.mainapp.e4.product could not be found.

!ENTRY org.eclipse.osgi 4 0 2011-09-24 21:33:49.389
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
An error has occurred. See the log file
D:\Commit-3.7SR1-RCP\project\.metadata\.plugins\org.eclipse.pde.core\org.cord.client.dms.mainapp.e4.product\1316880226818.log.
Re: No application id has been found [message #728976 is a reply to message #728975] Sat, 24 September 2011 12:10 Go to previous message
Parvez Ahmad Hakim is currently offline Parvez Ahmad Hakim
Messages: 31
Registered: May 2010
Member
!SESSION 2011-09-24 21:33:46.603 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=in
Framework arguments: -product org.cord.client.dms.mainapp.e4.product
Command-line arguments: -product org.cord.client.dms.mainapp.e4.product -data D:\Commit-3.7SR1-RCP\project/../runtime-org.cord.client.dms.mainapp.e4.product -dev file:D:/Commit-3.7SR1-RCP/project/.metadata/.plugins/org.eclipse.pde.core/org.cord.client.dms.mainapp.e4.product/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.equinox.app 0 0 2011-09-24 21:33:49.346
!MESSAGE Product org.cord.client.dms.mainapp.e4.product could not be found.

!ENTRY org.eclipse.osgi 4 0 2011-09-24 21:33:49.389
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
An error has occurred. See the log file
D:\Commit-3.7SR1-RCP\project\.metadata\.plugins\org.eclipse.pde.core\org.cord.client.dms.mainapp.e4.product\1316880226818.log.
Previous Topic:p2 ant mirror task should fails on error
Next Topic:Set Start Level fpr Bundle
Goto Forum:
  


Current Time: Tue Sep 02 00:37:49 EDT 2014

Powered by FUDForum. Page generated in 0.02058 seconds