Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SeMantic Information Logistics Architecture (SMILA) » Another ClassLoader Problem
icon8.gif  Another ClassLoader Problem [message #671854] Thu, 19 May 2011 07:39 Go to next message
No real name is currently offline No real nameFriend
Messages: 3
Registered: May 2011
Junior Member
Hi,

maybe you can help me.
I wanted to make a pipelet to extract text from a html page with XPath.
I´m using the DOMPArser class from Nekohtml, like you guys. But the class isn´t found at runtime.

I added the required line in the MF:

org.cyberneko.html.parsers;version="1.9.9",


In the log i get the following error then:
org.apache.ode.bpel.iapi.BpelEngineException: java.lang.RuntimeException: java.lang.NoClassDefFoundError: org/cyberneko/html/parsers/DOMParser
Caused by: java.lang.NoClassDefFoundError: org/cyberneko/html/parsers/DOMParser


I think thats only a follow up exception, the first exception i get is:

java.lang.NoClassDefFoundError: org/apache/xerces/parsers/DOMParser


I also included that in the "Import-Package" section of the MF:
org.apache.xerces.parsers;version="2.9.0",


I´m stuck, 2 hours i´m trying to figure out what the hell is wrong. I even tried to include the jars directly into my classpath. That didn´t work either.

Greets
Jan

[Updated on: Thu, 19 May 2011 07:45]

Report message to a moderator

Re: Another ClassLoader Problem [message #671903 is a reply to message #671854] Thu, 19 May 2011 10:05 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by:

Hi,

Am 19.05.2011, 09:39 Uhr, schrieb No real name
<forums-noreply@eclipse.org>:

> maybe you can help me.
> I wanted to make a pipelet to extract text from a html page with XPath..
> I´m using the DOMPArser class from Nekohtml, like you guys. But the
> class isn´t found at runtime.

Actually, we do not use *this* parser, so we didn't notice that ...

> I also included that in the "Import-Package" section of the MF:
>
> org.apache.xerces.parsers;version="2.9.0",

.... this needs to be added to the MF of the org.cyberneko.html bundle.
At least, then I can create a dummy instance of DOMParser in the
HtmlToTextPipelet.
I committed the change to our trunk, please try if this is sufficient for
you or
if more imports are needed.

Regards,
Jürgen.
Re: Another ClassLoader Problem [message #671949 is a reply to message #671854] Thu, 19 May 2011 12:30 Go to previous messageGo to next message
thomas menzel is currently offline thomas menzelFriend
Messages: 81
Registered: July 2009
Member
hi,

did u try to import all the stuff that we import in our SMILA Standard
Pipelets Plug-in ?

just looking at it we import

org.apache.xerces.xni;version="2.9.0",
org.apache.xerces.xni.parser;version="2.9.0",

note, the .xni. package part that u are missing below...


On 19.05.2011 09:39, No real name wrote:
> Hi,
>
> maybe you can help me.
> I wanted to make a pipelet to extract text from a html page with XPath.
> I´m using the DOMPArser class from Nekohtml, like you guys. But the
> class isn´t found at runtime.
>
> I added the required line in the MF:
>
>
> org.cyberneko.html.parsers;version="1.9.9",
>
>
> In the log i get the following error then:
>
> org.apache.ode.bpel.iapi.BpelEngineException:
> java.lang.RuntimeException: java.lang.NoClassDefFoundError:
> org/cyberneko/html/parsers/DOMParser
> Caused by: java.lang.NoClassDefFoundError:
> org/cyberneko/html/parsers/DOMParser
>
>
> I think thats only a follow up exception, the first exception i get is:
>
>
> java.lang.NoClassDefFoundError: org/apache/xerces/parsers/DOMParser
>
>
> I also included that in the "Import-Package" section of the MF:
>
> org.apache.xerces.parsers;version="2.9.0",
>
>
> I´m stuck, 2 hours i´m trying to figure out what the hell is wrong. I
> even tried to include the jars directly into my classpath. That didn´t
> work either.
>
>


--
thomas menzel aka tom


thomas menzel aka tom
Re: Another ClassLoader Problem [message #672171 is a reply to message #671949] Fri, 20 May 2011 07:39 Go to previous message
No real name is currently offline No real nameFriend
Messages: 3
Registered: May 2011
Junior Member
Adding "org.apache.xerces.parsers;version="2.9.0"" to the MF of the org.cyberneko.html bundle did the trick. Works like a charm now Smile Thanks.
Previous Topic:HtmlToText Pipelet and encoding
Next Topic:Queue flushing
Goto Forum:
  


Current Time: Mon Nov 24 08:27:14 GMT 2014

Powered by FUDForum. Page generated in 0.02301 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software