Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Problem when deploying RAP Demo on VIRGO
Problem when deploying RAP Demo on VIRGO [message #658075] Sat, 05 March 2011 20:05 Go to next message
Christian Hager is currently offline Christian Hager
Messages: 50
Registered: July 2009
Location: Germany
Member
Hello everyone,

I have encountered a little problem while trying to deploy the rap demo on virgo using a plan as described in http://eclipsesource.com/blogs/2010/10/28/running-rap-on-vir go/. I'm using RAP 1.4.M5 and virgo-web-server-3.0.0.M02 I get the following error:

[2011-03-06 00:53:29.278] startup-tracker              <KE0001I> Kernel starting. 
[2011-03-06 00:53:33.642] startup-tracker              <KE0002I> Kernel started. 
[2011-03-06 00:53:33.922] system-artifacts             <DE0000I> Installing plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'. 
[2011-03-06 00:53:34.464] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-03-06 00:53:34.674] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-03-06 00:53:34.731] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-03-06 00:53:34.767] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:34.789] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:34.978] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. 
[2011-03-06 00:53:35.027] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'. 
[2011-03-06 00:53:35.180] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.osgi.services' version '3.3.0.v20110110'. 
[2011-03-06 00:53:37.613] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-03-06 00:53:37.615] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-03-06 00:53:37.616] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-03-06 00:53:37.618] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:37.619] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:37.622] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. 
[2011-03-06 00:53:37.624] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'. 
[2011-03-06 00:53:37.626] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.osgi.services' version '3.3.0.v20110110'. 
[2011-03-06 00:53:37.627] system-artifacts             <DE0001I> Installed plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'. 
[2011-03-06 00:53:37.706] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'. 
[2011-03-06 00:53:37.720] system-artifacts             <DE0004I> Starting bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-03-06 00:53:37.738] start-signalling-1           <DE0005I> Started bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-03-06 00:53:37.755] system-artifacts             <DE0004I> Starting bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-03-06 00:53:39.269] system-artifacts             <DE0004I> Starting bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-03-06 00:53:39.273] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:39.281] start-signalling-2           <DE0005I> Started bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-03-06 00:53:39.302] start-signalling-1           <DE0005I> Started bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-03-06 00:53:39.311] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:39.311] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:39.398] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. 
[2011-03-06 00:53:39.506] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'. 
[2011-03-06 00:53:39.646] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'. 
[2011-03-06 00:53:40.098] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.osgi.services' version '3.3.0.v20110110'. 
[2011-03-06 00:53:40.103] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. 
[2011-03-06 00:53:40.103] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.osgi.services' version '3.3.0.v20110110'. 
[2011-03-06 00:53:40.126] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:40.128] start-signalling-2           <DE0005I> Started plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'. 
[2011-03-06 00:53:40.250] system-artifacts             <DE0000I> Installing plan 'org.eclipse.virgo.web' version '3.0.0'. 
[2011-03-06 00:53:40.328] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.web.core' version '1.2.0.M03'. 
[2011-03-06 00:53:40.378] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.web.tomcat' version '1.2.0.M03'. 
[2011-03-06 00:53:40.398] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.core' version '3.0.0.M02'. 
[2011-03-06 00:53:40.409] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:40.428] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.tomcat' version '3.0.0.M02'. 
[2011-03-06 00:53:41.322] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.web.core' version '1.2.0.M03'. 
[2011-03-06 00:53:41.325] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.web.tomcat' version '1.2.0.M03'. 
[2011-03-06 00:53:41.328] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.core' version '3.0.0.M02'. 
[2011-03-06 00:53:41.341] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:41.344] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.tomcat' version '3.0.0.M02'. 
[2011-03-06 00:53:41.346] system-artifacts             <DE0001I> Installed plan 'org.eclipse.virgo.web' version '3.0.0'. 
[2011-03-06 00:53:41.402] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.web' version '3.0.0'. 
[2011-03-06 00:53:41.406] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.web.core' version '1.2.0.M03'. 
[2011-03-06 00:53:41.578] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.gemini.web.core' version '1.2.0.M03'. 
[2011-03-06 00:53:41.582] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.web.tomcat' version '1.2.0.M03'. 
[2011-03-06 00:53:42.725] system-artifacts             <TC0000I> Starting Tomcat. 
[2011-03-06 00:53:42.808] system-artifacts             <TC0010I> Creating HTTP/1.1 connector with scheme http on port 8080. 
[2011-03-06 00:53:42.842] system-artifacts             <TC0010I> Creating HTTP/1.1 connector with scheme https on port 8443. 
[2011-03-06 00:53:42.884] system-artifacts             <TC0010I> Creating AJP/1.3 connector with scheme http on port 8009. 
[2011-03-06 00:53:42.964] system-artifacts             <TC0001I> Started Tomcat. 
[2011-03-06 00:53:43.038] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.web.core' version '3.0.0.M02'. 
[2011-03-06 00:53:43.065] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.web.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:43.068] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.virgo.web.dm' version '3.0.0.M02'. 
[2011-03-06 00:53:43.118] system-artifacts             <DE0005I> Started bundle 'org.eclipse.virgo.web.tomcat' version '3.0.0.M02'. 
[2011-03-06 00:53:43.298] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.gemini.web.tomcat' version '1.2.0.M03'. 
[2011-03-06 00:53:43.386] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.virgo.web.core' version '3.0.0.M02'. 
[2011-03-06 00:53:43.389] start-signalling-2           <DE0005I> Started plan 'org.eclipse.virgo.web' version '3.0.0'. 
[2011-03-06 00:53:43.398] sync Event Dispatcher Thread <UR0001I> User region ready. 
[2011-03-06 00:53:43.560] deployer-recovery            <DE0000I> Installing plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-03-06 00:53:43.638] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.M02'. 
[2011-03-06 00:53:44.899] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02'. 
[2011-03-06 00:53:45.815] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.M02'. 
[2011-03-06 00:53:45.817] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02'. 
[2011-03-06 00:53:45.819] deployer-recovery            <DE0001I> Installed plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-03-06 00:53:45.840] deployer-recovery            <DE0004I> Starting plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-03-06 00:53:45.843] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.M02'. 
[2011-03-06 00:53:46.155] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02'. 
[2011-03-06 00:53:46.201] start-signalling-2           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02' with context path '/admin'. 
[2011-03-06 00:53:46.209] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.M02'. 
[2011-03-06 00:53:46.497] deployer-recovery            <DE0000I> Installing par 'org.eclipse.virgo.apps.repository' version '3.0.0.M02'. 
[2011-03-06 00:53:46.499] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.core' version '3.0.0.M02'. 
[2011-03-06 00:53:46.501] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.web' version '3.0.0.M02'. 
[2011-03-06 00:53:46.935] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.core' version '3.0.0.M02'. 
[2011-03-06 00:53:46.941] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.web' version '3.0.0.M02'. 
[2011-03-06 00:53:46.943] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-synthetic.context' version '3.0.0.M02'. 
[2011-03-06 00:53:46.944] deployer-recovery            <DE0001I> Installed par 'org.eclipse.virgo.apps.repository' version '3.0.0.M02'. 
[2011-03-06 00:53:47.038] deployer-recovery            <DE0004I> Starting par 'org.eclipse.virgo.apps.repository' version '3.0.0.M02'. 
[2011-03-06 00:53:47.084] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.core' version '3.0.0.M02'. 
[2011-03-06 00:53:47.131] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.web' version '3.0.0.M02'. 
[2011-03-06 00:53:47.133] start-signalling-3           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.web' version '3.0.0.M02' with context path '/org.eclipse.virgo.apps.repository'. 
[2011-03-06 00:53:47.136] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-synthetic.context' version '3.0.0.M02'. 
[2011-03-06 00:53:47.138] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-synthetic.context' version '3.0.0.M02'. 
[2011-03-06 00:53:47.474] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.M02'. 
[2011-03-06 00:53:47.730] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.core' version '3.0.0.M02'. 
[2011-03-06 00:53:47.830] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.M02'. 
[2011-03-06 00:53:47.880] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.M02'. 
[2011-03-06 00:53:47.896] start-signalling-1           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.M02' with context path '/'. 
[2011-03-06 00:53:48.918] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.admin-3.0.0.M02.plan'. 
[2011-03-06 00:53:48.919] fs-watcher                   <HD0005I> Hot deploy not performed because file 'org.eclipse.virgo.apps.admin-3.0.0.M02.plan' is already deployed. 
[2011-03-06 00:53:48.922] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.repository-3.0.0.M02.par'. 
[2011-03-06 00:53:48.923] fs-watcher                   <HD0005I> Hot deploy not performed because file 'org.eclipse.virgo.apps.repository-3.0.0.M02.par' is already deployed. 
[2011-03-06 00:53:48.924] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.splash-3.0.0.M02.jar'. 
[2011-03-06 00:53:48.926] fs-watcher                   <HD0005I> Hot deploy not performed because file 'org.eclipse.virgo.apps.splash-3.0.0.M02.jar' is already deployed. 
[2011-03-06 00:53:48.927] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'rap-demo.plan'. 
[2011-03-06 00:53:49.115] fs-watcher                   <DE0000I> Installing plan 'rap-demo.plan' version '1.0.0'. 
[2011-03-06 00:53:49.210] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.preferences' version '3.4.0.v20110124-0830'. 
[2011-03-06 00:53:49.312] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.app' version '1.3.100.v20110110'. 
[2011-03-06 00:53:49.525] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.core.commands' version '3.6.0.I20110111-0800'. 
[2011-03-06 00:53:49.693] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.core.jobs' version '3.5.100.v20101008'. 
[2011-03-06 00:53:49.865] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.core.contenttype' version '3.4.100.v20101203-1034'. 
[2011-03-06 00:53:49.954] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.core.runtime' version '3.7.0.v20110110'. 
[2011-03-06 00:53:50.115] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.core.expressions' version '3.4.200.v20100505'. 
[2011-03-06 00:53:50.144] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-com.ibm.icu.base' version '4.2.1.v20100412'. 
[2011-03-06 00:53:50.481] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.help' version '3.5.0.v20100524'. 
[2011-03-06 00:53:50.688] start-signalling-2           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02' with context path '/admin'. 
[2011-03-06 00:53:50.701] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02'. 
[2011-03-06 00:53:50.703] start-signalling-2           <DE0005I> Started plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-03-06 00:53:50.862] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.mortbay.jetty.util' version '6.1.23.v201012071420'. 
[2011-03-06 00:53:51.213] start-signalling-1           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.M02' with context path '/'. 
[2011-03-06 00:53:51.214] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.M02'. 
[2011-03-06 00:53:51.418] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.mortbay.jetty.server' version '6.1.23.v201012071420'. 
[2011-03-06 00:53:51.672] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.registry' version '3.5.100.v20101101'. 
[2011-03-06 00:53:51.735] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.http.registry' version '1.1.100.v20101101'. 
[2011-03-06 00:53:51.866] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.http.servlet' version '1.1.100.v20101204'. 
[2011-03-06 00:53:51.885] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.http.jetty' version '2.0.0.v20100503'. 
[2011-03-06 00:53:52.920] start-signalling-3           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.web' version '3.0.0.M02' with context path '/org.eclipse.virgo.apps.repository'. 
[2011-03-06 00:53:52.926] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.virgo.apps.repository.web' version '3.0.0.M02'. 
[2011-03-06 00:53:52.930] start-signalling-3           <DE0005I> Started par 'org.eclipse.virgo.apps.repository' version '3.0.0.M02'. 
[2011-03-06 00:53:53.567] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.rwt' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:54.449] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.rwt.q07' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:55.342] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.jface' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:58.331] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:58.559] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.ui' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:58.658] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.ui.views' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:59.254] fs-watcher                   <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.demo' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:59.362] fs-watcher                   <DE0002E> Installation of plan 'rap-demo.plan' version '1.0.0' failed. org.eclipse.virgo.kernel.deployer.core.DeploymentException: Error merging expanded imports for [bundle 'rap-demo.plan-1-org.eclipse.rap.ui' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.help' version '3.5.0.v20100524' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.registry' version '3.5.100.v20101101' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.expressions' version '3.4.200.v20100505' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.rwt' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.http.jetty' version '2.0.0.v20100503' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.mortbay.jetty.util' version '6.1.23.v201012071420' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.app' version '1.3.100.v20110110' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-synthetic.context' version '1.0.0' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.http.servlet' version '1.1.100.v20101204' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.contenttype' version '3.4.100.v20101203-1034' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.jface' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.ui.views' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.http.registry' version '1.1.100.v20101101' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.demo' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.rwt.q07' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.preferences' version '3.4.0.v20110124-0830' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.commands' version '3.6.0.I20110111-0800' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.mortbay.jetty.server' version '6.1.23.v201012071420' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.runtime' version '3.7.0.v20110110' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-com.ibm.icu.base' version '4.2.1.v20100412' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.jobs' version '3.5.100.v20101008' in scope 'rap-demo.plan-1']
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer.expandImports(ImportExpandingTransformer.java:112)
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer.expandImportsOfBundlesInScopedPlan(ImportExpandingTransformer.java:89)
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer$ImportExpandingTreeVisitor.visit(ImportExpandingTransformer.java:76)
	at org.eclipse.virgo.util.common.ThreadSafeArrayListTree.visit(ThreadSafeArrayListTree.java:165)
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer.transform(ImportExpandingTransformer.java:58)
	at org.eclipse.virgo.kernel.install.pipeline.stage.transform.internal.TransformationStage.doProcessTree(TransformationStage.java:55)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:72)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:277)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:157)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:129)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:196)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deployIfNotDeployed(HotDeploymentFileSystemListener.java:186)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:87)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:680)
Caused by: org.eclipse.virgo.kernel.osgi.framework.ImportMergeException: cannot merge imports of package 'org.eclipse.ui.internal' from sources 'Import-Bundle 'rap-demo.plan-1-org.eclipse.rap.ui' version '1.4.0.20110201-1534', Import-Bundle 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version '1.4.0.20110201-1534'' because of conflicting values 'rap-demo.plan-1-org.eclipse.rap.ui.workbench', 'rap-demo.plan-1-org.eclipse.rap.ui' of attribute 'bundle-symbolic-name'
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.AbstractTrackedPackageImports.mergeAttributes(AbstractTrackedPackageImports.java:144)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.AbstractTrackedPackageImports.mergePackageImport(AbstractTrackedPackageImports.java:119)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.AbstractTrackedPackageImports.doMerge(AbstractTrackedPackageImports.java:104)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.AbstractTrackedPackageImports.merge(AbstractTrackedPackageImports.java:79)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.ImportExpansionHandler.getAdditionalPackageImports(ImportExpansionHandler.java:235)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.ImportExpansionHandler.expandImports(ImportExpansionHandler.java:206)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.ImportExpansionHandler.expandImportsIfNecessary(ImportExpansionHandler.java:174)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.ImportExpansionHandler.expandImports(ImportExpansionHandler.java:112)
	at sun.reflect.GeneratedMethodAccessor50.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:307)
	at org.springframework.osgi.service.importer.support.internal.aop.ServiceInvoker.doInvoke(ServiceInvoker.java:58)
	at org.springframework.osgi.service.importer.support.internal.aop.ServiceInvoker.invoke(ServiceInvoker.java:62)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:131)
	at org.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:119)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.osgi.service.util.internal.aop.ServiceTCCLInterceptor.invokeUnprivileged(ServiceTCCLInterceptor.java:56)
	at org.springframework.osgi.service.util.internal.aop.ServiceTCCLInterceptor.invoke(ServiceTCCLInterceptor.java:39)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.osgi.service.importer.support.LocalBundleContextAdvice.invoke(LocalBundleContextAdvice.java:59)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:131)
	at org.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:119)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:202)
	at $Proxy68.expandImports(Unknown Source)
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer.expandImports(ImportExpandingTransformer.java:107)
	... 22 common frames omitted

[2011-03-06 00:53:59.371] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.equinox.preferences' version '3.4.0.v20110124-0830'. 
[2011-03-06 00:53:59.373] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.equinox.app' version '1.3.100.v20110110'. 
[2011-03-06 00:53:59.375] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.core.commands' version '3.6.0.I20110111-0800'. 
[2011-03-06 00:53:59.377] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.core.jobs' version '3.5.100.v20101008'. 
[2011-03-06 00:53:59.379] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.core.contenttype' version '3.4.100.v20101203-1034'. 
[2011-03-06 00:53:59.380] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.core.runtime' version '3.7.0.v20110110'. 
[2011-03-06 00:53:59.382] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.core.expressions' version '3.4.200.v20100505'. 
[2011-03-06 00:53:59.384] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-com.ibm.icu.base' version '4.2.1.v20100412'. 
[2011-03-06 00:53:59.385] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.help' version '3.5.0.v20100524'. 
[2011-03-06 00:53:59.387] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.mortbay.jetty.util' version '6.1.23.v201012071420'. 
[2011-03-06 00:53:59.394] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.mortbay.jetty.server' version '6.1.23.v201012071420'. 
[2011-03-06 00:53:59.396] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.equinox.registry' version '3.5.100.v20101101'. 
[2011-03-06 00:53:59.398] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.equinox.http.registry' version '1.1.100.v20101101'. 
[2011-03-06 00:53:59.404] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.equinox.http.servlet' version '1.1.100.v20101204'. 
[2011-03-06 00:53:59.410] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.equinox.http.jetty' version '2.0.0.v20100503'. 
[2011-03-06 00:53:59.414] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.rwt' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:59.416] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.rwt.q07' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:59.419] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.jface' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:59.422] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:59.423] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.ui' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:59.425] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.ui.views' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:59.427] fs-watcher                   <DE0003E> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.demo' version '1.4.0.20110201-1534'. 
[2011-03-06 00:53:59.429] fs-watcher                   <DE0003E> Install failed for plan 'rap-demo.plan' version '1.0.0'. 
[2011-03-06 00:53:59.464] fs-watcher                   <HD0002E> Hot deploy failed for file 'rap-demo.plan'. org.eclipse.virgo.kernel.deployer.core.DeploymentException: Error merging expanded imports for [bundle 'rap-demo.plan-1-org.eclipse.rap.ui' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.help' version '3.5.0.v20100524' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.registry' version '3.5.100.v20101101' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.expressions' version '3.4.200.v20100505' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.rwt' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.http.jetty' version '2.0.0.v20100503' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.mortbay.jetty.util' version '6.1.23.v201012071420' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.app' version '1.3.100.v20110110' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-synthetic.context' version '1.0.0' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.http.servlet' version '1.1.100.v20101204' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.contenttype' version '3.4.100.v20101203-1034' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.jface' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.ui.views' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.http.registry' version '1.1.100.v20101101' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.demo' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.rap.rwt.q07' version '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.equinox.preferences' version '3.4.0.v20110124-0830' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.commands' version '3.6.0.I20110111-0800' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.mortbay.jetty.server' version '6.1.23.v201012071420' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.runtime' version '3.7.0.v20110110' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-com.ibm.icu.base' version '4.2.1.v20100412' in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.core.jobs' version '3.5.100.v20101008' in scope 'rap-demo.plan-1']
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer.expandImports(ImportExpandingTransformer.java:112)
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer.expandImportsOfBundlesInScopedPlan(ImportExpandingTransformer.java:89)
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer$ImportExpandingTreeVisitor.visit(ImportExpandingTransformer.java:76)
	at org.eclipse.virgo.util.common.ThreadSafeArrayListTree.visit(ThreadSafeArrayListTree.java:165)
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer.transform(ImportExpandingTransformer.java:58)
	at org.eclipse.virgo.kernel.install.pipeline.stage.transform.internal.TransformationStage.doProcessTree(TransformationStage.java:55)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:72)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:277)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:157)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:129)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:196)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deployIfNotDeployed(HotDeploymentFileSystemListener.java:186)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:87)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:680)
Caused by: org.eclipse.virgo.kernel.osgi.framework.ImportMergeException: cannot merge imports of package 'org.eclipse.ui.internal' from sources 'Import-Bundle 'rap-demo.plan-1-org.eclipse.rap.ui' version '1.4.0.20110201-1534', Import-Bundle 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version '1.4.0.20110201-1534'' because of conflicting values 'rap-demo.plan-1-org.eclipse.rap.ui.workbench', 'rap-demo.plan-1-org.eclipse.rap.ui' of attribute 'bundle-symbolic-name'
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.AbstractTrackedPackageImports.mergeAttributes(AbstractTrackedPackageImports.java:144)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.AbstractTrackedPackageImports.mergePackageImport(AbstractTrackedPackageImports.java:119)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.AbstractTrackedPackageImports.doMerge(AbstractTrackedPackageImports.java:104)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.AbstractTrackedPackageImports.merge(AbstractTrackedPackageImports.java:79)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.ImportExpansionHandler.getAdditionalPackageImports(ImportExpansionHandler.java:235)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.ImportExpansionHandler.expandImports(ImportExpansionHandler.java:206)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.ImportExpansionHandler.expandImportsIfNecessary(ImportExpansionHandler.java:174)
	at org.eclipse.virgo.kernel.userregion.internal.importexpansion.ImportExpansionHandler.expandImports(ImportExpansionHandler.java:112)
	at sun.reflect.GeneratedMethodAccessor50.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:307)
	at org.springframework.osgi.service.importer.support.internal.aop.ServiceInvoker.doInvoke(ServiceInvoker.java:58)
	at org.springframework.osgi.service.importer.support.internal.aop.ServiceInvoker.invoke(ServiceInvoker.java:62)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:131)
	at org.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:119)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.osgi.service.util.internal.aop.ServiceTCCLInterceptor.invokeUnprivileged(ServiceTCCLInterceptor.java:56)
	at org.springframework.osgi.service.util.internal.aop.ServiceTCCLInterceptor.invoke(ServiceTCCLInterceptor.java:39)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.osgi.service.importer.support.LocalBundleContextAdvice.invoke(LocalBundleContextAdvice.java:59)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.aop.support.DelegatingIntroductionInterceptor.doProceed(DelegatingIntroductionInterceptor.java:131)
	at org.springframework.aop.support.DelegatingIntroductionInterceptor.invoke(DelegatingIntroductionInterceptor.java:119)
	at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:172)
	at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:202)
	at $Proxy68.expandImports(Unknown Source)
	at org.eclipse.virgo.kernel.deployer.core.internal.ImportExpandingTransformer.expandImports(ImportExpandingTransformer.java:107)
	... 22 common frames omitted


Maybe someone could point me to what I'm doing wrong as I don't see it. Or is RAP 1.4.M5 maybe not running on virgo?

Thanks in advance for any help.

Christian
Re: Problem when deploying RAP Demo on VIRGO [message #658152 is a reply to message #658075] Mon, 07 March 2011 02:51 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1782
Registered: July 2009
Senior Member
Hi Christian,
could you try with the stable virgo version virgo-kernel-2.1.0.RELEASE?
Best,
Ivan

On 3/6/2011 3:05 AM, Christian Hager wrote:
> Hello everyone,
>
> I have encountered a little problem while trying to deploy the rap
> demo on virgo using a plan as described in
> http://eclipsesource.com/blogs/2010/10/28/running-rap-on-vir go/ I'm
> using RAP 1.4.M5 and virgo-web-server-3.0.0.M02 I get the following
> error:
>
> [2011-03-06 00:53:29.278] startup-tracker <KE0001I> Kernel starting.
> [2011-03-06 00:53:33.642] startup-tracker <KE0002I> Kernel started.
> [2011-03-06 00:53:33.922] system-artifacts <DE0000I> Installing plan
> 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'.
> [2011-03-06 00:53:34.464] system-artifacts <DE0000I> Installing bundle
> 'org.springframework.osgi.core' version '1.2.1'. [2011-03-06
> 00:53:34.674] system-artifacts <DE0000I> Installing bundle
> 'org.springframework.osgi.extender' version '1.2.1'. [2011-03-06
> 00:53:34.731] system-artifacts <DE0000I> Installing bundle
> 'org.springframework.osgi.io' version '1.2.1'. [2011-03-06
> 00:53:34.767] system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.M02'. [2011-03-06
> 00:53:34.789] system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.M02'.
> [2011-03-06 00:53:34.978] system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. [2011-03-06
> 00:53:35.027] system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.equinox.util' version '1.0.200.v20100503'. [2011-03-06
> 00:53:35.180] system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.osgi.services' version '3.3.0.v20110110'. [2011-03-06
> 00:53:37.613] system-artifacts <DE0001I> Installed bundle
> 'org.springframework.osgi.core' version '1.2.1'. [2011-03-06
> 00:53:37.615] system-artifacts <DE0001I> Installed bundle
> 'org.springframework.osgi.extender' version '1.2.1'. [2011-03-06
> 00:53:37.616] system-artifacts <DE0001I> Installed bundle
> 'org.springframework.osgi.io' version '1.2.1'. [2011-03-06
> 00:53:37.618] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.M02'. [2011-03-06
> 00:53:37.619] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.M02'.
> [2011-03-06 00:53:37.622] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. [2011-03-06
> 00:53:37.624] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.equinox.util' version '1.0.200.v20100503'. [2011-03-06
> 00:53:37.626] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.osgi.services' version '3.3.0.v20110110'. [2011-03-06
> 00:53:37.627] system-artifacts <DE0001I> Installed plan
> 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'.
> [2011-03-06 00:53:37.706] system-artifacts <DE0004I> Starting plan
> 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'.
> [2011-03-06 00:53:37.720] system-artifacts <DE0004I> Starting bundle
> 'org.springframework.osgi.core' version '1.2.1'. [2011-03-06
> 00:53:37.738] start-signalling-1 <DE0005I> Started bundle
> 'org.springframework.osgi.core' version '1.2.1'. [2011-03-06
> 00:53:37.755] system-artifacts <DE0004I> Starting bundle
> 'org.springframework.osgi.extender' version '1.2.1'. [2011-03-06
> 00:53:39.269] system-artifacts <DE0004I> Starting bundle
> 'org.springframework.osgi.io' version '1.2.1'. [2011-03-06
> 00:53:39.273] system-artifacts <DE0004I> Starting bundle
> 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.M02'. [2011-03-06
> 00:53:39.281] start-signalling-2 <DE0005I> Started bundle
> 'org.springframework.osgi.io' version '1.2.1'. [2011-03-06
> 00:53:39.302] start-signalling-1 <DE0005I> Started bundle
> 'org.springframework.osgi.extender' version '1.2.1'. [2011-03-06
> 00:53:39.311] start-signalling-3 <DE0005I> Started bundle
> 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.M02'. [2011-03-06
> 00:53:39.311] system-artifacts <DE0004I> Starting bundle
> 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.M02'.
> [2011-03-06 00:53:39.398] system-artifacts <DE0004I> Starting bundle
> 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. [2011-03-06
> 00:53:39.506] system-artifacts <DE0004I> Starting bundle
> 'org.eclipse.equinox.util' version '1.0.200.v20100503'. [2011-03-06
> 00:53:39.646] start-signalling-3 <DE0005I> Started bundle
> 'org.eclipse.equinox.util' version '1.0.200.v20100503'. [2011-03-06
> 00:53:40.098] system-artifacts <DE0004I> Starting bundle
> 'org.eclipse.osgi.services' version '3.3.0.v20110110'. [2011-03-06
> 00:53:40.103] start-signalling-3 <DE0005I> Started bundle
> 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. [2011-03-06
> 00:53:40.103] start-signalling-2 <DE0005I> Started bundle
> 'org.eclipse.osgi.services' version '3.3.0.v20110110'. [2011-03-06
> 00:53:40.126] start-signalling-2 <DE0005I> Started bundle
> 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.M02'.
> [2011-03-06 00:53:40.128] start-signalling-2 <DE0005I> Started plan
> 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'.
> [2011-03-06 00:53:40.250] system-artifacts <DE0000I> Installing plan
> 'org.eclipse.virgo.web' version '3.0.0'. [2011-03-06 00:53:40.328]
> system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.gemini.web.core' version '1.2.0.M03'. [2011-03-06
> 00:53:40.378] system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.gemini.web.tomcat' version '1.2.0.M03'. [2011-03-06
> 00:53:40.398] system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.virgo.web.core' version '3.0.0.M02'. [2011-03-06
> 00:53:40.409] system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.virgo.web.dm' version '3.0.0.M02'. [2011-03-06
> 00:53:40.428] system-artifacts <DE0000I> Installing bundle
> 'org.eclipse.virgo.web.tomcat' version '3.0.0.M02'. [2011-03-06
> 00:53:41.322] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.gemini.web.core' version '1.2.0.M03'. [2011-03-06
> 00:53:41.325] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.gemini.web.tomcat' version '1.2.0.M03'. [2011-03-06
> 00:53:41.328] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.virgo.web.core' version '3.0.0.M02'. [2011-03-06
> 00:53:41.341] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.virgo.web.dm' version '3.0.0.M02'. [2011-03-06
> 00:53:41.344] system-artifacts <DE0001I> Installed bundle
> 'org.eclipse.virgo.web.tomcat' version '3.0.0.M02'. [2011-03-06
> 00:53:41.346] system-artifacts <DE0001I> Installed plan
> 'org.eclipse.virgo.web' version '3.0.0'. [2011-03-06 00:53:41.402]
> system-artifacts <DE0004I> Starting plan 'org.eclipse.virgo.web'
> version '3.0.0'. [2011-03-06 00:53:41.406] system-artifacts <DE0004I>
> Starting bundle 'org.eclipse.gemini.web.core' version '1.2.0.M03'.
> [2011-03-06 00:53:41.578] start-signalling-2 <DE0005I> Started bundle
> 'org.eclipse.gemini.web.core' version '1.2.0.M03'. [2011-03-06
> 00:53:41.582] system-artifacts <DE0004I> Starting bundle
> 'org.eclipse.gemini.web.tomcat' version '1.2.0.M03'. [2011-03-06
> 00:53:42.725] system-artifacts <TC0000I> Starting Tomcat. [2011-03-06
> 00:53:42.808] system-artifacts <TC0010I> Creating HTTP/1.1 connector
> with scheme http on port 8080. [2011-03-06 00:53:42.842]
> system-artifacts <TC0010I> Creating HTTP/1.1 connector with scheme
> https on port 8443. [2011-03-06 00:53:42.884] system-artifacts
> <TC0010I> Creating AJP/1.3 connector with scheme http on port 8009.
> [2011-03-06 00:53:42.964] system-artifacts <TC0001I> Started Tomcat.
> [2011-03-06 00:53:43.038] system-artifacts <DE0004I> Starting bundle
> 'org.eclipse.virgo.web.core' version '3.0.0.M02'. [2011-03-06
> 00:53:43.065] system-artifacts <DE0004I> Starting bundle
> 'org.eclipse.virgo.web.dm' version '3.0.0.M02'. [2011-03-06
> 00:53:43.068] start-signalling-2 <DE0005I> Started bundle
> 'org.eclipse.virgo.web.dm' version '3.0.0.M02'. [2011-03-06
> 00:53:43.118] system-artifacts <DE0005I> Started bundle
> 'org.eclipse.virgo.web.tomcat' version '3.0.0.M02'. [2011-03-06
> 00:53:43.298] start-signalling-2 <DE0005I> Started bundle
> 'org.eclipse.gemini.web.tomcat' version '1.2.0.M03'. [2011-03-06
> 00:53:43.386] start-signalling-2 <DE0005I> Started bundle
> 'org.eclipse.virgo.web.core' version '3.0.0.M02'. [2011-03-06
> 00:53:43.389] start-signalling-2 <DE0005I> Started plan
> 'org.eclipse.virgo.web' version '3.0.0'. [2011-03-06 00:53:43.398]
> sync Event Dispatcher Thread <UR0001I> User region ready. [2011-03-06
> 00:53:43.560] deployer-recovery <DE0000I> Installing plan
> 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. [2011-03-06
> 00:53:43.638] deployer-recovery <DE0000I> Installing bundle
> 'org.eclipse.virgo.apps.admin.core' version '3.0.0.M02'. [2011-03-06
> 00:53:44.899] deployer-recovery <DE0000I> Installing bundle
> 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02'. [2011-03-06
> 00:53:45.815] deployer-recovery <DE0001I> Installed bundle
> 'org.eclipse.virgo.apps.admin.core' version '3.0.0.M02'. [2011-03-06
> 00:53:45.817] deployer-recovery <DE0001I> Installed bundle
> 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02'. [2011-03-06
> 00:53:45.819] deployer-recovery <DE0001I> Installed plan
> 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. [2011-03-06
> 00:53:45.840] deployer-recovery <DE0004I> Starting plan
> 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. [2011-03-06
> 00:53:45.843] deployer-recovery <DE0004I> Starting bundle
> 'org.eclipse.virgo.apps.admin.core' version '3.0.0.M02'. [2011-03-06
> 00:53:46.155] deployer-recovery <DE0004I> Starting bundle
> 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02'. [2011-03-06
> 00:53:46.201] start-signalling-2 <WE0000I> Starting web bundle
> 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02' with context
> path '/admin'. [2011-03-06 00:53:46.209] start-signalling-3 <DE0005I>
> Started bundle 'org.eclipse.virgo.apps.admin.core' version
> '3.0.0.M02'. [2011-03-06 00:53:46.497] deployer-recovery <DE0000I>
> Installing par 'org.eclipse.virgo.apps.repository' version
> '3.0.0.M02'. [2011-03-06 00:53:46.499] deployer-recovery <DE0000I>
> Installing bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.core'
> version '3.0.0.M02'. [2011-03-06 00:53:46.501] deployer-recovery
> <DE0000I> Installing bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.web'
> version '3.0.0.M02'. [2011-03-06 00:53:46.935] deployer-recovery
> <DE0001I> Installed bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.core'
> version '3.0.0.M02'. [2011-03-06 00:53:46.941] deployer-recovery
> <DE0001I> Installed bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.web'
> version '3.0.0.M02'. [2011-03-06 00:53:46.943] deployer-recovery
> <DE0001I> Installed bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-synthetic.conte xt'
> version '3.0.0.M02'. [2011-03-06 00:53:46.944] deployer-recovery
> <DE0001I> Installed par 'org.eclipse.virgo.apps.repository' version
> '3.0.0.M02'. [2011-03-06 00:53:47.038] deployer-recovery <DE0004I>
> Starting par 'org.eclipse.virgo.apps.repository' version '3.0.0.M02'.
> [2011-03-06 00:53:47.084] deployer-recovery <DE0004I> Starting bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.core'
> version '3.0.0.M02'. [2011-03-06 00:53:47.131] deployer-recovery
> <DE0004I> Starting bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.web'
> version '3.0.0.M02'. [2011-03-06 00:53:47.133] start-signalling-3
> <WE0000I> Starting web bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.web'
> version '3.0.0.M02' with context path
> '/org.eclipse.virgo.apps.repository'. [2011-03-06 00:53:47.136]
> deployer-recovery <DE0004I> Starting bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-synthetic.conte xt'
> version '3.0.0.M02'. [2011-03-06 00:53:47.138] start-signalling-1
> <DE0005I> Started bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-synthetic.conte xt'
> version '3.0.0.M02'. [2011-03-06 00:53:47.474] deployer-recovery
> <DE0000I> Installing bundle 'org.eclipse.virgo.apps.splash' version
> '3.0.0.M02'. [2011-03-06 00:53:47.730] start-signalling-1 <DE0005I>
> Started bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.core'
> version '3.0.0.M02'. [2011-03-06 00:53:47.830] deployer-recovery
> <DE0001I> Installed bundle 'org.eclipse.virgo.apps.splash' version
> '3.0.0.M02'. [2011-03-06 00:53:47.880] deployer-recovery <DE0004I>
> Starting bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.M02'.
> [2011-03-06 00:53:47.896] start-signalling-1 <WE0000I> Starting web
> bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.M02' with
> context path '/'. [2011-03-06 00:53:48.918] fs-watcher <HD0001I> Hot
> deployer processing 'INITIAL' event for file
> 'org.eclipse.virgo.apps.admin-3.0.0.M02.plan'. [2011-03-06
> 00:53:48.919] fs-watcher <HD0005I> Hot deploy not performed because
> file 'org.eclipse.virgo.apps.admin-3.0.0.M02.plan' is already
> deployed. [2011-03-06 00:53:48.922] fs-watcher <HD0001I> Hot deployer
> processing 'INITIAL' event for file
> 'org.eclipse.virgo.apps.repository-3.0.0.M02.par'. [2011-03-06
> 00:53:48.923] fs-watcher <HD0005I> Hot deploy not performed because
> file 'org.eclipse.virgo.apps.repository-3.0.0.M02.par' is already
> deployed. [2011-03-06 00:53:48.924] fs-watcher <HD0001I> Hot deployer
> processing 'INITIAL' event for file
> 'org.eclipse.virgo.apps.splash-3.0.0.M02.jar'. [2011-03-06
> 00:53:48.926] fs-watcher <HD0005I> Hot deploy not performed because
> file 'org.eclipse.virgo.apps.splash-3.0.0.M02.jar' is already
> deployed. [2011-03-06 00:53:48.927] fs-watcher <HD0001I> Hot deployer
> processing 'INITIAL' event for file 'rap-demo.plan'. [2011-03-06
> 00:53:49.115] fs-watcher <DE0000I> Installing plan 'rap-demo.plan'
> version '1.0.0'. [2011-03-06 00:53:49.210] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.preferences'
> version '3.4.0.v20110124-0830'. [2011-03-06 00:53:49.312] fs-watcher
> <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.app'
> version '1.3.100.v20110110'. [2011-03-06 00:53:49.525] fs-watcher
> <DE0000I> Installing bundle
> 'rap-demo.plan-1-org.eclipse.core.commands' version
> '3.6.0.I20110111-0800'. [2011-03-06 00:53:49.693] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-org.eclipse.core.jobs' version
> '3.5.100.v20101008'. [2011-03-06 00:53:49.865] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-org.eclipse.core.contenttype'
> version '3.4.100.v20101203-1034'. [2011-03-06 00:53:49.954] fs-watcher
> <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.core.runtime'
> version '3.7.0.v20110110'. [2011-03-06 00:53:50.115] fs-watcher
> <DE0000I> Installing bundle
> 'rap-demo.plan-1-org.eclipse.core.expressions' version
> '3.4.200.v20100505'. [2011-03-06 00:53:50.144] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-com.ibm.icu.base' version
> '4.2.1.v20100412'. [2011-03-06 00:53:50.481] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-org.eclipse.help' version
> '3.5.0.v20100524'. [2011-03-06 00:53:50.688] start-signalling-2
> <WE0001I> Started web bundle 'org.eclipse.virgo.apps.admin.web'
> version '3.0.0.M02' with context path '/admin'. [2011-03-06
> 00:53:50.701] start-signalling-2 <DE0005I> Started bundle
> 'org.eclipse.virgo.apps.admin.web' version '3.0.0.M02'. [2011-03-06
> 00:53:50.703] start-signalling-2 <DE0005I> Started plan
> 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. [2011-03-06
> 00:53:50.862] fs-watcher <DE0000I> Installing bundle
> 'rap-demo.plan-1-org.mortbay.jetty.util' version
> '6.1.23.v201012071420'. [2011-03-06 00:53:51.213] start-signalling-1
> <WE0001I> Started web bundle 'org.eclipse.virgo.apps.splash' version
> '3.0.0.M02' with context path '/'. [2011-03-06 00:53:51.214]
> start-signalling-1 <DE0005I> Started bundle
> 'org.eclipse.virgo.apps.splash' version '3.0.0.M02'. [2011-03-06
> 00:53:51.418] fs-watcher <DE0000I> Installing bundle
> 'rap-demo.plan-1-org.mortbay.jetty.server' version
> '6.1.23.v201012071420'. [2011-03-06 00:53:51.672] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.registry'
> version '3.5.100.v20101101'. [2011-03-06 00:53:51.735] fs-watcher
> <DE0000I> Installing bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.registry' version
> '1.1.100.v20101101'. [2011-03-06 00:53:51.866] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-org.eclipse.equinox.http.servlet'
> version '1.1.100.v20101204'. [2011-03-06 00:53:51.885] fs-watcher
> <DE0000I> Installing bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.jetty' version
> '2.0.0.v20100503'. [2011-03-06 00:53:52.920] start-signalling-3
> <WE0001I> Started web bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.web'
> version '3.0.0.M02' with context path
> '/org.eclipse.virgo.apps.repository'. [2011-03-06 00:53:52.926]
> start-signalling-3 <DE0005I> Started bundle
> 'org.eclipse.virgo.apps.repository-3.0.0.M02-org.eclipse.vir go.apps.repository.web'
> version '3.0.0.M02'. [2011-03-06 00:53:52.930] start-signalling-3
> <DE0005I> Started par 'org.eclipse.virgo.apps.repository' version
> '3.0.0.M02'. [2011-03-06 00:53:53.567] fs-watcher <DE0000I> Installing
> bundle 'rap-demo.plan-1-org.eclipse.rap.rwt' version
> '1.4.0.20110201-1534'. [2011-03-06 00:53:54.449] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.rwt.q07' version
> '1.4.0.20110201-1534'. [2011-03-06 00:53:55.342] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.jface' version
> '1.4.0.20110201-1534'. [2011-03-06 00:53:58.331] fs-watcher <DE0000I>
> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.ui.workbench'
> version '1.4.0.20110201-1534'. [2011-03-06 00:53:58.559] fs-watcher
> <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.ui'
> version '1.4.0.20110201-1534'. [2011-03-06 00:53:58.658] fs-watcher
> <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.ui.views'
> version '1.4.0.20110201-1534'. [2011-03-06 00:53:59.254] fs-watcher
> <DE0000I> Installing bundle 'rap-demo.plan-1-org.eclipse.rap.demo'
> version '1.4.0.20110201-1534'. [2011-03-06 00:53:59.362] fs-watcher
> <DE0002E> Installation of plan 'rap-demo.plan' version '1.0.0' failed.
> org.eclipse.virgo.kernel.deployer.core.DeploymentException: Error
> merging expanded imports for [bundle
> 'rap-demo.plan-1-org.eclipse.rap.ui' version '1.4.0.20110201-1534' in
> scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.help'
> version '3.5.0.v20100524' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.registry' version
> '3.5.100.v20101101' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.expressions' version
> '3.4.200.v20100505' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.rwt' version '1.4.0.20110201-1534' in
> scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.jetty' version
> '2.0.0.v20100503' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.mortbay.jetty.util' version
> '6.1.23.v201012071420' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version
> '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.app' version '1.3.100.v20110110'
> in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-synthetic.context'
> version '1.0.0' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.servlet' version
> '1.1.100.v20101204' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.contenttype' version
> '3.4.100.v20101203-1034' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.jface' version '1.4.0.20110201-1534'
> in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.ui.views' version
> '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.registry' version
> '1.1.100.v20101101' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.demo' version '1.4.0.20110201-1534'
> in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.rwt.q07' version
> '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.preferences' version
> '3.4.0.v20110124-0830' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.commands' version
> '3.6.0.I20110111-0800' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.mortbay.jetty.server' version
> '6.1.23.v201012071420' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.runtime' version '3.7.0.v20110110'
> in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-com.ibm.icu.base'
> version '4.2.1.v20100412' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.jobs' version '3.5.100.v20101008' in
> scope 'rap-demo.plan-1']
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer.expandImports(ImportExpandingTransformer.java :112)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer.expandImportsOfBundlesInScopedPlan(ImportExpa ndingTransformer.java:89)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer$ImportExpandingTreeVisitor.visit(ImportExpand ingTransformer.java:76)
> at
> org.eclipse.virgo.util.common.ThreadSafeArrayListTree.visit( ThreadSafeArrayListTree.java:165)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer.transform(ImportExpandingTransformer.java:58)
> at
> org.eclipse.virgo.kernel.install.pipeline.stage.transform.in ternal.TransformationStage.doProcessTree(TransformationStage .java:55)
> at
> org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipe lineStage.process(AbstractPipelineStage.java:41)
> at
> org.eclipse.virgo.kernel.install.pipeline.internal.StandardP ipeline.doProcessTree(StandardPipeline.java:62)
> at
> org.eclipse.virgo.kernel.install.pipeline.internal.Compensat ingPipeline.doProcessTree(CompensatingPipeline.java:72)
> at
> org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipe lineStage.process(AbstractPipelineStage.java:41)
> at
> org.eclipse.virgo.kernel.install.pipeline.internal.StandardP ipeline.doProcessTree(StandardPipeline.java:62)
> at
> org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipe lineStage.process(AbstractPipelineStage.java:41)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApp licationDeployer.driveInstallPipeline(PipelinedApplicationDe ployer.java:277)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApp licationDeployer.doInstall(PipelinedApplicationDeployer.java :157)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApp licationDeployer.install(PipelinedApplicationDeployer.java:1 29)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApp licationDeployer.deploy(PipelinedApplicationDeployer.java:19 6)
> at
> org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSyste mListener.deploy(HotDeploymentFileSystemListener.java:174)
> at
> org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSyste mListener.deployIfNotDeployed(HotDeploymentFileSystemListene r.java:186)
> at
> org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSyste mListener.onChange(HotDeploymentFileSystemListener.java:87)
> at
> org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners( FileSystemChecker.java:245)
> at
> org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystem Checker.java:166)
> at
> org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTas k.java:58)
> at java.lang.Thread.run(Thread.java:680)
> Caused by:
> org.eclipse.virgo.kernel.osgi.framework.ImportMergeException : cannot
> merge imports of package 'org.eclipse.ui.internal' from sources
> 'Import-Bundle 'rap-demo.plan-1-org.eclipse.rap.ui' version
> '1.4.0.20110201-1534', Import-Bundle
> 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version
> '1.4.0.20110201-1534'' because of conflicting values
> 'rap-demo.plan-1-org.eclipse.rap.ui.workbench',
> 'rap-demo.plan-1-org.eclipse.rap.ui' of attribute 'bundle-symbolic-name'
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .AbstractTrackedPackageImports.mergeAttributes(AbstractTrack edPackageImports.java:144)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .AbstractTrackedPackageImports.mergePackageImport(AbstractTr ackedPackageImports.java:119)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .AbstractTrackedPackageImports.doMerge(AbstractTrackedPackag eImports.java:104)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .AbstractTrackedPackageImports.merge(AbstractTrackedPackageI mports.java:79)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.getAdditionalPackageImports(ImportEx pansionHandler.java:235)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.expandImports(ImportExpansionHandler .java:206)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.expandImportsIfNecessary(ImportExpan sionHandler.java:174)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.expandImports(ImportExpansionHandler .java:112)
> at sun.reflect.GeneratedMethodAccessor50.invoke(Unknown Source)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at
> org.springframework.aop.support.AopUtils.invokeJoinpointUsin gReflection(AopUtils.java:307)
> at
> org.springframework.osgi.service.importer.support.internal.a op.ServiceInvoker.doInvoke(ServiceInvoker.java:58)
> at
> org.springframework.osgi.service.importer.support.internal.a op.ServiceInvoker.invoke(ServiceInvoker.java:62)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.aop.support.DelegatingIntroductionInterc eptor.doProceed(DelegatingIntroductionInterceptor.java:131)
> at
> org.springframework.aop.support.DelegatingIntroductionInterc eptor.invoke(DelegatingIntroductionInterceptor.java:119)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.osgi.service.util.internal.aop.ServiceTC CLInterceptor.invokeUnprivileged(ServiceTCCLInterceptor.java :56)
> at
> org.springframework.osgi.service.util.internal.aop.ServiceTC CLInterceptor.invoke(ServiceTCCLInterceptor.java:39)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.osgi.service.importer.support.LocalBundl eContextAdvice.invoke(LocalBundleContextAdvice.java:59)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.aop.support.DelegatingIntroductionInterc eptor.doProceed(DelegatingIntroductionInterceptor.java:131)
> at
> org.springframework.aop.support.DelegatingIntroductionInterc eptor.invoke(DelegatingIntroductionInterceptor.java:119)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.aop.framework.JdkDynamicAopProxy.invoke( JdkDynamicAopProxy.java:202)
> at $Proxy68.expandImports(Unknown Source)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer.expandImports(ImportExpandingTransformer.java :107)
> ... 22 common frames omitted
>
> [2011-03-06 00:53:59.371] fs-watcher <DE0003E> Install failed for
> bundle 'rap-demo.plan-1-org.eclipse.equinox.preferences' version
> '3.4.0.v20110124-0830'. [2011-03-06 00:53:59.373] fs-watcher <DE0003E>
> Install failed for bundle 'rap-demo.plan-1-org.eclipse.equinox.app'
> version '1.3.100.v20110110'. [2011-03-06 00:53:59.375] fs-watcher
> <DE0003E> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.core.commands' version
> '3.6.0.I20110111-0800'. [2011-03-06 00:53:59.377] fs-watcher <DE0003E>
> Install failed for bundle 'rap-demo.plan-1-org.eclipse.core.jobs'
> version '3.5.100.v20101008'. [2011-03-06 00:53:59.379] fs-watcher
> <DE0003E> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.core.contenttype' version
> '3.4.100.v20101203-1034'. [2011-03-06 00:53:59.380] fs-watcher
> <DE0003E> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.core.runtime' version '3.7.0.v20110110'.
> [2011-03-06 00:53:59.382] fs-watcher <DE0003E> Install failed for
> bundle 'rap-demo.plan-1-org.eclipse.core.expressions' version
> '3.4.200.v20100505'. [2011-03-06 00:53:59.384] fs-watcher <DE0003E>
> Install failed for bundle 'rap-demo.plan-1-com.ibm.icu.base' version
> '4.2.1.v20100412'. [2011-03-06 00:53:59.385] fs-watcher <DE0003E>
> Install failed for bundle 'rap-demo.plan-1-org.eclipse.help' version
> '3.5.0.v20100524'. [2011-03-06 00:53:59.387] fs-watcher <DE0003E>
> Install failed for bundle 'rap-demo.plan-1-org.mortbay.jetty.util'
> version '6.1.23.v201012071420'. [2011-03-06 00:53:59.394] fs-watcher
> <DE0003E> Install failed for bundle
> 'rap-demo.plan-1-org.mortbay.jetty.server' version
> '6.1.23.v201012071420'. [2011-03-06 00:53:59.396] fs-watcher <DE0003E>
> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.equinox.registry' version
> '3.5.100.v20101101'. [2011-03-06 00:53:59.398] fs-watcher <DE0003E>
> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.registry' version
> '1.1.100.v20101101'. [2011-03-06 00:53:59.404] fs-watcher <DE0003E>
> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.servlet' version
> '1.1.100.v20101204'. [2011-03-06 00:53:59.410] fs-watcher <DE0003E>
> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.jetty' version
> '2.0.0.v20100503'. [2011-03-06 00:53:59.414] fs-watcher <DE0003E>
> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.rwt'
> version '1.4.0.20110201-1534'. [2011-03-06 00:53:59.416] fs-watcher
> <DE0003E> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.rap.rwt.q07' version
> '1.4.0.20110201-1534'. [2011-03-06 00:53:59.419] fs-watcher <DE0003E>
> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.jface'
> version '1.4.0.20110201-1534'. [2011-03-06 00:53:59.422] fs-watcher
> <DE0003E> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version
> '1.4.0.20110201-1534'. [2011-03-06 00:53:59.423] fs-watcher <DE0003E>
> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.ui' version
> '1.4.0.20110201-1534'. [2011-03-06 00:53:59.425] fs-watcher <DE0003E>
> Install failed for bundle 'rap-demo.plan-1-org.eclipse.rap.ui.views'
> version '1.4.0.20110201-1534'. [2011-03-06 00:53:59.427] fs-watcher
> <DE0003E> Install failed for bundle
> 'rap-demo.plan-1-org.eclipse.rap.demo' version '1.4.0.20110201-1534'.
> [2011-03-06 00:53:59.429] fs-watcher <DE0003E> Install failed for plan
> 'rap-demo.plan' version '1.0.0'. [2011-03-06 00:53:59.464] fs-watcher
> <HD0002E> Hot deploy failed for file 'rap-demo.plan'.
> org.eclipse.virgo.kernel.deployer.core.DeploymentException: Error
> merging expanded imports for [bundle
> 'rap-demo.plan-1-org.eclipse.rap.ui' version '1.4.0.20110201-1534' in
> scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-org.eclipse.help'
> version '3.5.0.v20100524' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.registry' version
> '3.5.100.v20101101' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.expressions' version
> '3.4.200.v20100505' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.rwt' version '1.4.0.20110201-1534' in
> scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.jetty' version
> '2.0.0.v20100503' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.mortbay.jetty.util' version
> '6.1.23.v201012071420' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version
> '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.app' version '1.3.100.v20110110'
> in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-synthetic.context'
> version '1.0.0' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.servlet' version
> '1.1.100.v20101204' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.contenttype' version
> '3.4.100.v20101203-1034' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.jface' version '1.4.0.20110201-1534'
> in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.ui.views' version
> '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.http.registry' version
> '1.1.100.v20101101' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.demo' version '1.4.0.20110201-1534'
> in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.rap.rwt.q07' version
> '1.4.0.20110201-1534' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.equinox.preferences' version
> '3.4.0.v20110124-0830' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.commands' version
> '3.6.0.I20110111-0800' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.mortbay.jetty.server' version
> '6.1.23.v201012071420' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.runtime' version '3.7.0.v20110110'
> in scope 'rap-demo.plan-1', bundle 'rap-demo.plan-1-com.ibm.icu.base'
> version '4.2.1.v20100412' in scope 'rap-demo.plan-1', bundle
> 'rap-demo.plan-1-org.eclipse.core.jobs' version '3.5.100.v20101008' in
> scope 'rap-demo.plan-1']
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer.expandImports(ImportExpandingTransformer.java :112)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer.expandImportsOfBundlesInScopedPlan(ImportExpa ndingTransformer.java:89)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer$ImportExpandingTreeVisitor.visit(ImportExpand ingTransformer.java:76)
> at
> org.eclipse.virgo.util.common.ThreadSafeArrayListTree.visit( ThreadSafeArrayListTree.java:165)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer.transform(ImportExpandingTransformer.java:58)
> at
> org.eclipse.virgo.kernel.install.pipeline.stage.transform.in ternal.TransformationStage.doProcessTree(TransformationStage .java:55)
> at
> org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipe lineStage.process(AbstractPipelineStage.java:41)
> at
> org.eclipse.virgo.kernel.install.pipeline.internal.StandardP ipeline.doProcessTree(StandardPipeline.java:62)
> at
> org.eclipse.virgo.kernel.install.pipeline.internal.Compensat ingPipeline.doProcessTree(CompensatingPipeline.java:72)
> at
> org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipe lineStage.process(AbstractPipelineStage.java:41)
> at
> org.eclipse.virgo.kernel.install.pipeline.internal.StandardP ipeline.doProcessTree(StandardPipeline.java:62)
> at
> org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipe lineStage.process(AbstractPipelineStage.java:41)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApp licationDeployer.driveInstallPipeline(PipelinedApplicationDe ployer.java:277)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApp licationDeployer.doInstall(PipelinedApplicationDeployer.java :157)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApp licationDeployer.install(PipelinedApplicationDeployer.java:1 29)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApp licationDeployer.deploy(PipelinedApplicationDeployer.java:19 6)
> at
> org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSyste mListener.deploy(HotDeploymentFileSystemListener.java:174)
> at
> org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSyste mListener.deployIfNotDeployed(HotDeploymentFileSystemListene r.java:186)
> at
> org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSyste mListener.onChange(HotDeploymentFileSystemListener.java:87)
> at
> org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners( FileSystemChecker.java:245)
> at
> org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystem Checker.java:166)
> at
> org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTas k.java:58)
> at java.lang.Thread.run(Thread.java:680)
> Caused by:
> org.eclipse.virgo.kernel.osgi.framework.ImportMergeException : cannot
> merge imports of package 'org.eclipse.ui.internal' from sources
> 'Import-Bundle 'rap-demo.plan-1-org.eclipse.rap.ui' version
> '1.4.0.20110201-1534', Import-Bundle
> 'rap-demo.plan-1-org.eclipse.rap.ui.workbench' version
> '1.4.0.20110201-1534'' because of conflicting values
> 'rap-demo.plan-1-org.eclipse.rap.ui.workbench',
> 'rap-demo.plan-1-org.eclipse.rap.ui' of attribute 'bundle-symbolic-name'
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .AbstractTrackedPackageImports.mergeAttributes(AbstractTrack edPackageImports.java:144)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .AbstractTrackedPackageImports.mergePackageImport(AbstractTr ackedPackageImports.java:119)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .AbstractTrackedPackageImports.doMerge(AbstractTrackedPackag eImports.java:104)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .AbstractTrackedPackageImports.merge(AbstractTrackedPackageI mports.java:79)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.getAdditionalPackageImports(ImportEx pansionHandler.java:235)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.expandImports(ImportExpansionHandler .java:206)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.expandImportsIfNecessary(ImportExpan sionHandler.java:174)
> at
> org.eclipse.virgo.kernel.userregion.internal.importexpansion .ImportExpansionHandler.expandImports(ImportExpansionHandler .java:112)
> at sun.reflect.GeneratedMethodAccessor50.invoke(Unknown Source)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at
> org.springframework.aop.support.AopUtils.invokeJoinpointUsin gReflection(AopUtils.java:307)
> at
> org.springframework.osgi.service.importer.support.internal.a op.ServiceInvoker.doInvoke(ServiceInvoker.java:58)
> at
> org.springframework.osgi.service.importer.support.internal.a op.ServiceInvoker.invoke(ServiceInvoker.java:62)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.aop.support.DelegatingIntroductionInterc eptor.doProceed(DelegatingIntroductionInterceptor.java:131)
> at
> org.springframework.aop.support.DelegatingIntroductionInterc eptor.invoke(DelegatingIntroductionInterceptor.java:119)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.osgi.service.util.internal.aop.ServiceTC CLInterceptor.invokeUnprivileged(ServiceTCCLInterceptor.java :56)
> at
> org.springframework.osgi.service.util.internal.aop.ServiceTC CLInterceptor.invoke(ServiceTCCLInterceptor.java:39)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.osgi.service.importer.support.LocalBundl eContextAdvice.invoke(LocalBundleContextAdvice.java:59)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.aop.support.DelegatingIntroductionInterc eptor.doProceed(DelegatingIntroductionInterceptor.java:131)
> at
> org.springframework.aop.support.DelegatingIntroductionInterc eptor.invoke(DelegatingIntroductionInterceptor.java:119)
> at
> org.springframework.aop.framework.ReflectiveMethodInvocation .proceed(ReflectiveMethodInvocation.java:172)
> at
> org.springframework.aop.framework.JdkDynamicAopProxy.invoke( JdkDynamicAopProxy.java:202)
> at $Proxy68.expandImports(Unknown Source)
> at
> org.eclipse.virgo.kernel.deployer.core.internal.ImportExpand ingTransformer.expandImports(ImportExpandingTransformer.java :107)
> ... 22 common frames omitted
>
> Maybe someone could point me to what I'm doing wrong as I don't see
> it. Or is RAP 1.4.M5 maybe not running on virgo?
>
> Thanks in advance for any help.
>
> Christian
Re: Problem when deploying RAP Demo on VIRGO [message #658192 is a reply to message #658152] Mon, 07 March 2011 06:29 Go to previous messageGo to next message
Christian Hager is currently offline Christian Hager
Messages: 50
Registered: July 2009
Location: Germany
Member
Hi Ivan,

this doesn't seem to work either because of conflicting osgi versions in the RAP-Target and in Virgo. If I try I get the following error:

Cannot resolve: org.eclipse.osgi
    Resolver report:
        The bundle could not be resolved because another singleton bundle was selected. In bundle <org.eclipse.osgi_3.7.0.v20110124-0830>
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.equinox.registry_3.5.100.v20101101>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.equinox.http.registry_1.1.100.v20101101>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="0.0.0">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.jface_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.core.commands; bundle-version="[3.4.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.ui_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.6.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.ui.workbench_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.6.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.demo_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.rap.ui; bundle-version="0.0.0">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.ui.views_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.core.databinding.observable_1.3.0.I20100824-0800>
             constraint: <Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)">
        A Require-Bundle could not be resolved. Caused by missing constraint in bundle <org.eclipse.rap.jface.databinding_1.4.0.20110201-1534>
             constraint: <Require-Bundle: org.eclipse.rap.jface; bundle-version="[1.2.0,2.0.0)">
        The fragment could not be resolved because of a constraint conflict with a host, possibly because the host is already resolved. The affected fragment is org.eclipse.virgo.osgi.extensions.equinox_2.1.0.RELEASE
            Possible hosts:
                org.eclipse.osgi_3.6.1.R36x_v20100806 (resolved)
                org.eclipse.osgi_3.7.0.v20110124-0830 (not resolved)
            Constraint conflict:
                Import-Package: org.eclipse.osgi.baseadaptor; version="0.0.0"
        The fragment could not be resolved because of a constraint conflict with a host, possibly because the host is already resolved. The affected fragment is org.eclipse.virgo.osgi.extensions.equinox_2.1.0.RELEASE


Thats actually the reason why I went with Virgo 3.0.0...

What else could I do? Is it possible to run RAP 1.4 with an older version of osgi like 3.6.1?

Thanks again for any hints.

Christian
Re: Problem when deploying RAP Demo on VIRGO [message #658373 is a reply to message #658192] Tue, 08 March 2011 04:21 Go to previous messageGo to next message
Florian Waibel is currently offline Florian Waibel
Messages: 92
Registered: June 2010
Member
Hi Christian,

I splitted the plan into pieced to find the source of the problem. First I created a plan for installing jetty 6.1.23:

<plan name="jetty-HttpService" version="6.1.23" scoped="false" atomic="false"
        xmlns="http://www.springsource.org/schema/dm-server/plan"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="
            http://www.springsource.org/schema/dm-server/plan 
            http://www.springsource.org/schema/dm-server/plan/springsource-dm-server-plan.xsd">

	<artifact type="bundle" name="org.mortbay.jetty.util" version="[6.1.23, 7.0.0)" />
	<artifact type="bundle" name="org.mortbay.jetty.server" version="[6.1.23, 7.0.0)" />

	<artifact type="bundle" name="org.eclipse.equinox.http.registry" version="[1.1.0, 2.0.0)" />
	<artifact type="bundle" name="org.eclipse.equinox.http.servlet" version="[1.1.0, 2.0.0)" />
	<artifact type="bundle" name="org.eclipse.equinox.http.jetty" version="[2.0.0, 3.0.0)" />

</plan>


Next I tried to install the required eclipse bundles one after the other:

cp repository/usr/org.eclipse.equinox.preferences_3.4.0.v20110124-0830.jar pickup/
cp repository/usr/org.eclipse.equinox.app_1.3.100.v20110110.jar pickup
cp repository/usr/org.eclipse.core.commands_3.6.0.I20110111-0800.jar pickup
cp repository/usr/org.eclipse.core.jobs_3.5.100.v20101008.jar pickup
cp repository/usr/org.eclipse.core.contenttype_3.4.100.v20101203-1034.jar pickup
cp repository/usr/org.eclipse.core.runtime_3.7.0.v20110110.jar pickup


If you start Virgo
bin/startup.sh -Fosgi.console=2401


you can connect to the OSGi console and start the bundles by hand. The bundle org.eclipse.core.runtime does not start properly (in my configuration bundle 71):

osgi> start 71
org.osgi.framework.BundleException: Exception in org.eclipse.core.internal.runtime.PlatformActivator.start() of bundle org.eclipse.core.runtime.
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:299)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:291)
	at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:253)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:155)
	at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:155)
	at org.eclipse.osgi.framework.internal.core.FrameworkConsole.runConsole(FrameworkConsole.java:140)
	at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:104)
	at java.lang.Thread.run(Thread.java:680)
Caused by: java.lang.NullPointerException
	at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:791)
	at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:30)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	... 14 more
Nested Exception:
java.lang.NullPointerException
	at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:791)
	at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:30)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:299)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:291)
	at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:253)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:155)
	at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:155)
	at org.eclipse.osgi.framework.internal.core.FrameworkConsole.runConsole(FrameworkConsole.java:140)
	at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:104)
	at java.lang.Thread.run(Thread.java:680)
Nested Exception:
java.lang.NullPointerException
	at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:791)
	at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:30)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:299)
	at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:291)
	at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:253)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:155)
	at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:155)
	at org.eclipse.osgi.framework.internal.core.FrameworkConsole.runConsole(FrameworkConsole.java:140)
	at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:104)
	at java.lang.Thread.run(Thread.java:680)


But I need some more time to investigate this error.

Hope this helps,
florian

Looking through your post it seems you are using Virgo Web Server. Running RAP only requires an OSGi HttpService. (Virgo Kernel + Jetty HttpService)
Re: Problem when deploying RAP Demo on VIRGO [message #714548 is a reply to message #658373] Wed, 10 August 2011 15:48 Go to previous message
Florian Waibel is currently offline Florian Waibel
Messages: 92
Registered: June 2010
Member
For further details to this issue please see the discussion on this bug 324445 [1]
Please see this blog post [2] for how to run RAP 1.4 / 1.5 on Virgo 3.x Jetty Server.

[1] bugs.eclipse.org/bugs/show_bug.cgi?id=324445
[2] eclipsesource.com/blogs/2011/08/10/how-to-extend-the-virgo-jetty-server-to-support-the-rap-widget-toolkit/

Previous Topic:Printing in RWT
Next Topic:web based form and letter generator?
Goto Forum:
  


Current Time: Wed Jul 30 19:25:11 EDT 2014

Powered by FUDForum. Page generated in 0.01794 seconds