Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux
Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux [message #657739] Thu, 03 March 2011 19:02 Go to next message
Andrew Keen is currently offline Andrew Keen
Messages: 5
Registered: July 2010
Junior Member
I have a need to run 32-bit Eclipse in a 64-bit Linux. I've downloaded Eclipse Classic 3.6.2 and Java SE JDK 1.6 and 1.5. I've tried a variety of combinations using these two JDKs with the -vm argument but Eclipse always seems to fail to start with exit code 13 and no console output no matter what I try. Does anyone have any pointers for me or good online resources that could help with this? Google searches have been thoroughly unsuccessful. The only help I've been able to find is "download a 32-bit JDK and use the -vm argument," which isn't working for me.

Thanks.
Re: Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux [message #698211 is a reply to message #657739] Tue, 19 July 2011 02:37 Go to previous messageGo to next message
Peter Shannon is currently offline Peter Shannon
Messages: 3
Registered: July 2011
Junior Member
I'm having exactly the same problem. I've tried two differetn versions of eclipse 32 bit and two different versions of java 32 bit and no dice.

I'm trying helios now to see if it behaves differently.

Seems strange to need this but android sdk is only 32 bit so there you go, time to jump through some hoops.
Re: Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux [message #698212 is a reply to message #698211] Tue, 19 July 2011 02:42 Go to previous messageGo to next message
Peter Shannon is currently offline Peter Shannon
Messages: 3
Registered: July 2011
Junior Member
No good either. Helios 32 bit & java 32 bit, result: same error.

/home/shannon/lib/helios> eclipse -vm /home/shannon/lib/jdk1.6.0_26/bin/java

JVM terminated. Exit code=13
/home/shannon/lib/jdk1.6.0_26/bin/java
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata d8004
-vm /home/shannon/lib/jdk1.6.0_26/bin/java
-vmargs
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
Re: Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux [message #698213 is a reply to message #698212] Tue, 19 July 2011 02:45 Go to previous messageGo to next message
Peter Shannon is currently offline Peter Shannon
Messages: 3
Registered: July 2011
Junior Member
Damn! look at that:

-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata d8004
-vm /home/shannon/lib/jdk1.6.0_26/bin/java

Ok, I should have spotted its using the installed version of eclipse too but that is surely a bug. It shouldn't pick up another system wide install if I'm running another copy.
Re: Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux [message #698586 is a reply to message #698213] Tue, 19 July 2011 18:50 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1341
Registered: July 2009
Senior Member
What is in your PATH environment variable. If the directory where you have 32 bit Eclipse installed isn't in your PATH, then you won't run 32 bit Eclipse. If you are trying to run from the 32 bit install directory, you would have to have . included in the PATH.
Re: Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux [message #703370 is a reply to message #657739] Wed, 27 July 2011 13:55 Go to previous messageGo to next message
David I is currently offline David I
Messages: 6
Registered: July 2009
Junior Member
For reference, I'm seeing the same problem:


JVM terminated. Exit code=13
/usr/java/latest/bin/java
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-os linux
-ws gtk
-arch x86
-showsplash
-launcher /home/isheedm/bin/eclipse/eclipse
-name Eclipse
--launcher.library /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505/eclipse_1407.so
-startup /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.overrideVmargs
-exitdata 1180010
-product org.eclipse.epp.package.jee.product
-vm /usr/java/latest/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

>/usr/java/latest/bin/java -version
java version "1.6.0_25"
Java(TM) SE Runtime Environment (build 1.6.0_25-b06)
Java HotSpot(TM) 64-Bit Server VM (build 20.0-b11, mixed mode)

Is there a problem running 32 bit Eclipse with a 64 bit Java?

David
Re: Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux [message #703536 is a reply to message #703370] Wed, 27 July 2011 17:11 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1341
Registered: July 2009
Senior Member
David I wrote on Wed, 27 July 2011 08:55
For reference, I'm seeing the same problem:


JVM terminated. Exit code=13
/usr/java/latest/bin/java
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-os linux
-ws gtk
-arch x86
-showsplash
-launcher /home/isheedm/bin/eclipse/eclipse
-name Eclipse
--launcher.library /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505/eclipse_1407.so
-startup /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.overrideVmargs
-exitdata 1180010
-product org.eclipse.epp.package.jee.product
-vm /usr/java/latest/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

>/usr/java/latest/bin/java -version
java version "1.6.0_25"
Java(TM) SE Runtime Environment (build 1.6.0_25-b06)
Java HotSpot(TM) 64-Bit Server VM (build 20.0-b11, mixed mode)

Is there a problem running 32 bit Eclipse with a 64 bit Java?

David


Yes. You can't run a 32 bit Eclipse on a 64 bit VM and you can't run a 64 bit Eclipse on a 32 bit VM. They have to match.
Re: Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux [message #703551 is a reply to message #703370] Wed, 27 July 2011 16:47 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3190
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 27-Jul-11 07:55, David I wrote:
> For reference, I'm seeing the same problem:
>
>
> JVM terminated. Exit code=13
> /usr/java/latest/bin/java
> -Dosgi.requiredJavaVersion=1.5
> -XX:MaxPermSize=256m
> -Xms40m
> -Xmx512m
> -jar
> /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>
> -os linux
> -ws gtk
> -arch x86
> -showsplash
> -launcher /home/isheedm/bin/eclipse/eclipse
> -name Eclipse
> --launcher.library
> /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505/eclipse_1407.so
>
> -startup
> /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>
> --launcher.overrideVmargs
> -exitdata 1180010
> -product org.eclipse.epp.package.jee.product
> -vm /usr/java/latest/bin/java
> -vmargs
> -Dosgi.requiredJavaVersion=1.5
> -XX:MaxPermSize=256m
> -Xms40m
> -Xmx512m
> -jar
> /home/isheedm/bin/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>
>> /usr/java/latest/bin/java -version
> java version "1.6.0_25"
> Java(TM) SE Runtime Environment (build 1.6.0_25-b06)
> Java HotSpot(TM) 64-Bit Server VM (build 20.0-b11, mixed mode)
>
> Is there a problem running 32 bit Eclipse with a 64 bit Java?
>
> David

Yup.
Re: Trouble starting 32-bit Eclipse Classic 3.6.2 on 64-bit Linux [message #704589 is a reply to message #657739] Thu, 28 July 2011 20:29 Go to previous message
Andrew Keen is currently offline Andrew Keen
Messages: 5
Registered: July 2010
Junior Member
Hey guys,

I eventually figured this one out, sorry I didn't get back sooner. I used the self extracting 32-bit Java SE 6u24 from Oracle's website. The trick is that (at least with Helios), Eclipse treats each line in the eclipse.ini file as one argument.

To make it work, I extracted the 32-bit JVM inside of my Eclipse directory and added these two lines as the very first lines in my eclipse.ini file:
-vm
jdk1.6.0_24/bin

My problem was that I was putting them both on the same line like this:
-vm jdk1.6.0_24/bin

Hope this helps.
Previous Topic:Veto Perspective close and View Close.
Next Topic:JVM terminated. Exit code=1
Goto Forum:
  


Current Time: Thu Sep 18 17:53:02 GMT 2014

Powered by FUDForum. Page generated in 0.28765 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software