Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » [Table] Scrolling issue
[Table] Scrolling issue [message #657278] Wed, 02 March 2011 10:25 Go to next message
Oliver B. is currently offline Oliver B.
Messages: 38
Registered: November 2010
Member
Hi,

while debugging my RAP application with firebug, I encountered a strange behaviour while scrolling in a Table (Viewer) control,

I scrolled up/down several times in the table. I was looking into the firebug network monitor. I saw that while scrolling the mouse cursor position is send to the server. This seems normal for me. But in some cases these requests are send in an infinite loop even when I am not scrolling anymore.

After 5 minutes I have already >500 requests. They all have the same POST information:

w1.cursorLocation.x=-324&w1.cursorLocation.y=369&uiR oot=w1&requestCounter=825

The x-location seems to be negative.

I can reproduce tihs in my application. But I cannot reprodruce it in the control demo.

Is this bug?

Regards,
Oliver
Re: [Table] Scrolling issue [message #657282 is a reply to message #657278] Wed, 02 March 2011 10:30 Go to previous messageGo to next message
Oliver B. is currently offline Oliver B.
Messages: 38
Registered: November 2010
Member
Another observation:

In the control demo:
I scrolled with the mouse wheel in the table. The scrolling was done correctly. But when I hover over the table with mouse, the table seems to scroll by itself (up and down with each hover).

I could not reproduce this a second time.

Forget to meantion. We are using RAP1.4M5

Regards,
Oliver
Re: [Table] Scrolling issue [message #657298 is a reply to message #657278] Wed, 02 March 2011 11:07 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1817
Registered: July 2009
Senior Member
Hi Oliver,
looks like an issue with the new scrollbar implementation. Is it
reproducible in other browsers or it is a FF issue only? Could you
provide a snippet to reproduce it? If yes - please file a bugzilla.
Thanks,
Ivan

On 3/2/2011 12:25 PM, Oliver wrote:
> Hi,
>
> while debugging my RAP application with firebug, I encountered a
> strange behaviour while scrolling in a Table (Viewer) control,
>
> I scrolled up/down several times in the table. I was looking into the
> firebug network monitor. I saw that while scrolling the mouse cursor
> position is send to the server. This seems normal for me. But in some
> cases these requests are send in an infinite loop even when I am not
> scrolling anymore.
>
> After 5 minutes I have already >500 requests. They all have the same
> POST information:
>
> w1.cursorLocation.x=-324&w1.cursorLocation.y=369&uiR
> oot=w1&requestCounter=825
>
> The x-location seems to be negative.
>
> I can reproduce tihs in my application. But I cannot reprodruce it in
> the control demo.
>
> Is this bug?
>
> Regards,
> Oliver
>
Re: [Table] Scrolling issue [message #657303 is a reply to message #657278] Wed, 02 March 2011 11:29 Go to previous messageGo to next message
Oliver B. is currently offline Oliver B.
Messages: 38
Registered: November 2010
Member
Hi Ivan,

I could reproduce it with Google Chrome.
I don't know how to check it with IE8, Opera or Safari because there are no addons to trace the network traffic.

I will try to create a snippet.

Regards,
Oliver
Re: [Table] Scrolling issue [message #657351 is a reply to message #657278] Wed, 02 March 2011 14:23 Go to previous messageGo to next message
Oliver B. is currently offline Oliver B.
Messages: 38
Registered: November 2010
Member
Hi Ivan,

I found out that it is possible to reproduce this behaviour with the control demo. Therefore I think no particularly snippet is needed.

I think it is a timing issue. It only occurs while scrolling fastly (either vertically or horizontally)

Is this information enough to file a bug?

Regards,
Oliver
Re: [Table] Scrolling issue [message #657362 is a reply to message #657351] Wed, 02 March 2011 14:52 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1817
Registered: July 2009
Senior Member
Hi Oliver,
sure... if it's reproducible with Controls Damo -> Table Tab this is
great. Just specify the steps needed to reproduce it.
Best,
Ivan

On 3/2/2011 4:23 PM, Oliver wrote:
> Hi Ivan,
>
> I found out that it is possible to reproduce this behaviour with the
> control demo. Therefore I think no particularly snippet is needed.
>
> I think it is a timing issue. It only occurs while scrolling fastly
> (either vertically or horizontally)
>
> Is this information enough to file a bug?
>
> Regards,
> Oliver
Re: [Table] Scrolling issue [message #657374 is a reply to message #657278] Wed, 02 March 2011 15:34 Go to previous message
Oliver B. is currently offline Oliver B.
Messages: 38
Registered: November 2010
Member
Hi Ivan,

I filed the bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=338686

Greets,
Oliver
Previous Topic:Data from my widget don't appear in other widget
Next Topic:Problem with RAP+BIRT target platform
Goto Forum:
  


Current Time: Tue Sep 23 00:20:54 GMT 2014

Powered by FUDForum. Page generated in 0.02190 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software