Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Java EE wizards not working. Only EAR Wizard works
Java EE wizards not working. Only EAR Wizard works [message #655464] Mon, 21 February 2011 04:54 Go to next message
vlad.balan Missing name is currently offline vlad.balan Missing name
Messages: 45
Registered: June 2010
Member
Hello,

i'm getting

The selected wizard could not be started.
Plug-in "org.eclipse.jst.ejb.ui" was unable to instantiate class "org.eclipse.jst.ejb.ui.project.facet.EjbProjectWizard".
java.lang.NullPointerException


I have Eclipse 3.5 Galileo for Java EE.


Similer error also happens for Dynamic Web project, or Application Client project.

Pls tell me if you need other info.

I also have Aptana plugin and Google GWT SDK, AppEngine SDK plugins and Google Plugin for Eclipse installed. Maybe they interfere....

[Updated on: Mon, 21 February 2011 04:57]

Report message to a moderator

Re: Java EE wizards not working. Only EAR Wizard works [message #661772 is a reply to message #655464] Sun, 27 March 2011 14:05 Go to previous messageGo to next message
Aditya Adepu is currently offline Aditya Adepu
Messages: 2
Registered: March 2011
Junior Member
getting a similar error.
Re: Java EE wizards not working. Only EAR Wizard works [message #662009 is a reply to message #661772] Mon, 28 March 2011 17:01 Go to previous messageGo to next message
Aditya Adepu is currently offline Aditya Adepu
Messages: 2
Registered: March 2011
Junior Member
After some googling, it seems i might have mixed the updated from helios and galileo. One possibility of this happening is clicking on check updates and installing them with out looking. My update site list has both the links for galileo and helios.
I was thinking how to get back. Eclipse has this wonderful feature of reverting back to a previous configuration. so just reverted back to a day before the error happened. Now the problem is solved.

Re: Java EE wizards not working. Only EAR Wizard works [message #662078 is a reply to message #662009] Tue, 29 March 2011 04:10 Go to previous message
vlad.balan Missing name is currently offline vlad.balan Missing name
Messages: 45
Registered: June 2010
Member
Hi,

thanks for the update. I'll try reversing to a previous version - don't know in which version that mix must have happened (and anyway then reinstall the plugins i installed after.)
Previous Topic:Failed to create Java virtual machine-Eclipse Halios EE
Next Topic:Eclipse fails to monitor embedded tomcat
Goto Forum:
  


Current Time: Fri Aug 22 06:09:13 EDT 2014

Powered by FUDForum. Page generated in 0.06146 seconds