Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Getting GDB running under Helios(GDB doesn't work in combination with Helios, Galileo works)
icon5.gif  Getting GDB running under Helios [message #654832] Thu, 17 February 2011 05:55 Go to next message
Toetsje  is currently offline Toetsje
Messages: 3
Registered: February 2011
Junior Member
Hi all,

I'm a happy user of Eclipse and I use this IDE to develop some C/C++ programs. These programs are written within Eclipse (Galileo), compiled by MinGW (5.4.1) and debugged by GDB (7.2).

However, since I've switched from Galileo to Helios this combination doesn't fully work anymore. I think it has to do with the Debugger setting (Run -> Debug Configurations -> Debugger) because I only see 3 debuggers in this list while Galileo listed 5 items.

In Galileo the following items are available:
- Cygwin gdb Debugger
- gdb Debugger
- gdb/mi
- gdbserver Debugger
- MinGw gdb Debugger

In Helios I can only make a choice between:
- gdb/mi
- gdbserver Debugger
- MinGw gdb Debugger

The debug session only works correctly when "Cygwin gdb Debugger" or "gdb Debugger" is selected, however these items seems to be removed from Helios.

When "gdb/mi" or "MinGW gdb Debugger" is selected the program stops at Main() and it's possible to step in the code. However, when the debugger stops at a breakpoint only the trace is shown (i.e. "DATA*stopped,reason="breakpoint-hit",disp="keep",bkptno= "2",frame={addr="0x00409b85",func="TestApp,,,,,,,,,,,") and the process keeps running on the background. The "Resume" button stays grey and it's impossible to step.

On the internet I already found a post that says that "Cygwin gdb Debugger" and "gdb Debugger" are removed from Helios because it's outdated. However, I have the latest GDB release and this is incompatible with the rest of the list.

Could somebody help me out?

[Updated on: Thu, 17 February 2011 07:14]

Report message to a moderator

Re: Getting GDB running under Helios [message #654885 is a reply to message #654832] Thu, 17 February 2011 09:12 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3157
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

As the sticky post at the top of this forum indicates, you'll get more
and better help from the Eclipse CDT forum for questions such as these.

On 2011.02.17 3:55, Toetsje wrote:
> Hi all,
>
> I'm a happy user of Eclipse and I use this IDE to develop some C/C++
> programs. These programs are written within Eclipse (Galileo), compiled
> by MinGW (5.4.1) and debugged by GDB (7.2).
> However, since I've switched from Galileo to Helios this combination
> doesn't fully work anymore. I think it has to do with the Debugger
> setting (Run -> Debug Configurations -> Debugger) because I only see 3
> debuggers in this list while Galileo listed 5 items.
>
> In Galileo the following items are available:
> - Cygwin gdb Debugger
> - gdb Debugger
> - gdb/mi
> - gdbserver Debugger
> - MinGw gdb Debugger
>
> In Helios I can only make a choice between:
> - gdb/mi
> - gdbserver Debugger
> - MinGw gdb Debugger
>
> The debug session only works correctly when "Cygwin gdb Debugger" or
> "gdb Debugger" is selected, however these items seems to be removed from
> Helios.
>
> When "gdb/mi" or "MinGW gdb Debugger" is selected the program stops at
> Main() and it's possible to step in the code. However, when the debugger
> stops at a breakpoint only the trace is shown (i.e.
> "DATA*stopped,reason="breakpoint-hit",disp="keep",bkptno=
> "2",frame={addr="0x00409b85",func="TestApp,,,,,,,,,,,") and the process
> keeps running on the background. The "Resume" button stays grey and it's
> impossible to step.
>
> On the internet I already found a post that says that "Cygwin gdb
> Debugger" and "gdb Debugger" are removed from Helios because it's
> outdated. However, I have the latest GDB release and this is
> incompatible with the rest of the list.
>
> Could somebody help me out?
Re: Getting GDB running under Helios [message #654895 is a reply to message #654885] Thu, 17 February 2011 09:40 Go to previous message
Toetsje  is currently offline Toetsje
Messages: 3
Registered: February 2011
Junior Member
Thanks for your remark
Previous Topic:Unable to read workbench state
Next Topic:Execute an applet in a jar from within eclipse
Goto Forum:
  


Current Time: Fri Aug 29 22:23:14 EDT 2014

Powered by FUDForum. Page generated in 0.10626 seconds