Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » [Solved] Validate for Non Ascii characters(Validate for Non Ascii characters while providing values in Properties View)
[Solved] Validate for Non Ascii characters [message #649192] Tue, 18 January 2011 06:06 Go to next message
Jeno Jeyakumar Nathaniel is currently offline Jeno Jeyakumar Nathaniel
Messages: 18
Registered: April 2010
Junior Member
Hi All,

I have to validate the model xml for Non Ascii characters(except few like £).So i need to trigger a event to validate while providing values for the attributes of node(same as a exception being triggered when we provide date in wrong format).

Thanks,
Jeno.

[Updated on: Thu, 03 February 2011 10:33]

Report message to a moderator

Re: Validate for Non Ascii characters [message #649332 is a reply to message #649192] Tue, 18 January 2011 18:12 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26138
Registered: July 2009
Senior Member
Jeno,

You could define your own EDataType for java.lang.String and specialize
the createAbcFromString method to reject characters you don't want. Or,
with extended metadata annotations, you can define a pattern constraint
on your own EDataType that would only allow whatever characters you want
to allow


Jeno Jeyakumar Nathaniel wrote:
> Hi All,
>
> I have to validate the model xml for Non Ascii characters(except few
> like £).So i need to trigger a event to validate while providing
> values for the attributes of node(same as a exception being triggered
> when we provide date in wrong format).
>
> Thanks,
> Jeno.
>
Re: Validate for Non Ascii characters [message #649932 is a reply to message #649332] Fri, 21 January 2011 04:19 Go to previous message
Jeno Jeyakumar Nathaniel is currently offline Jeno Jeyakumar Nathaniel
Messages: 18
Registered: April 2010
Junior Member
Thanks Ed. I tried creating my own Data Type and its working fine.

Regards,
Jeno
Previous Topic:Editing of invisible labels when edit part is added bug or expected behaviour?
Next Topic:Removing editMenu from popup contributions throws an error in error log
Goto Forum:
  


Current Time: Fri Oct 24 07:05:06 GMT 2014

Powered by FUDForum. Page generated in 0.01753 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software