Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Linked xsd not found during validation?("No grammer constraints" when validating with a linked xsd)
Linked xsd not found during validation? [message #643438] Mon, 06 December 2010 20:53
John Palof is currently offline John Palof
Messages: 15
Registered: July 2009
Junior Member
I have an xsd and a conforming xml file sitting in a directory of a project. If I right click on the xml and choose validate, the validation is successfull.

However, if I change the xsd to be a linked file from another project, the xsd is not resolved and I receive the following marker when validating:
"No grammer constraints (DTD or XML schema) detected for the document."

Note: I am able to double click and open the contents of the linked xsd so I am fairly confident that I and creating the link correctly.

I have searched the Eclipse bugs to see if this has been reported but the closest I came was 294885. This occurs on:

Eclipse Web Developer Tools
Version: 3.2.0.v201005241510-7O7CFb3EMf84nOyJKuT05LU72RId
Build id: 20100529234347

Eclipse Web Developer Tools
Version: 3.2.2.v201008100100-7O7CFbKEMf84nUlEJyX7-SPQjhYZ
Build id: 20100529234347

Is this a known bug or should I be utilizing the XML catalog rather than using a linked file?


Thank you
Previous Topic:Is there a standard solution for equinox + struts2?
Next Topic:WTP plugins broken
Goto Forum:
  


Current Time: Thu Oct 30 19:00:06 GMT 2014

Powered by FUDForum. Page generated in 0.67497 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software