Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Source file not being included in a build
Source file not being included in a build [message #643202] Sun, 05 December 2010 20:25 Go to next message
Andrew Ellis is currently offline Andrew Ellis
Messages: 7
Registered: December 2010
Junior Member
Hi,

I am using Eclipse with C/C++ compiler for Jennic microcontroller.

I have added a source file to my project tree, but when I build the project the source file is not be built. I have spent a lot of time searching for inspiration to solving this problem but I have been unsuccessful. The file in question is shown in the project tree. What do I need to do to ensure the source file is included in the build?

Thanks in advance

Andrew
Re: Source file not being included in a build [message #643218 is a reply to message #643202] Sun, 05 December 2010 23:40 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3121
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

Sticky post at the top of this forum:

http://www.eclipse.org/forums/index.php?t=msg&th=161206& amp;start=0&S=c89e3369de31210df06da94abcf6411d
On 2010.12.05 18:26, Andrew Ellis wrote:
> Hi,
>
> I am using Eclipse with C/C++ compiler for Jennic microcontroller.
>
> I have added a source file to my project tree, but when I build the
> project the source file is not be built. I have spent a lot of time
> searching for inspiration to solving this problem but I have been
> unsuccessful. The file in question is shown in the project tree. What do
> I need to do to ensure the source file is included in the build?
>
> Thanks in advance
>
> Andrew
Re: Source file not being included in a build [message #643325 is a reply to message #643218] Mon, 06 December 2010 09:08 Go to previous messageGo to next message
Andrew Ellis is currently offline Andrew Ellis
Messages: 7
Registered: December 2010
Junior Member
Hi Russell,

Thank you for your reply.

Unfortunately it does not help me. As I stated in my original message I have spent a lot of time searching for the answer. To be more specific, I have searched this site, used Google and the help facility within Eclipse. However all that has happened is that I have been going round in circles. I have used search terms such as "adding files to an eclipse project" and "adding files to a make file in eclipse", unfortunately these have not yielded the answer.

I'm sorry if this seems a repetitive question, but I really cannot find the answer anywhere else, despite my best efforts. Could some one please direct me to a link that may answer my question, or explain what I am doing wrong.

Thanks in advance

Andrew

[Updated on: Mon, 06 December 2010 09:08]

Report message to a moderator

Re: Source file not being included in a build [message #643387 is a reply to message #643325] Mon, 06 December 2010 11:52 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric Rizzo
Messages: 2202
Registered: July 2009
Senior Member
On 12/6/10 9:08 AM, Andrew Ellis wrote:
> Hi Russell,
>
> Thank you for your reply.
>
> Unfortunately it does not help. Me. As I stated in my original message I
> have spent a lot of time searching for the answer. To be more specific,
> I have searched this site, used Google and the help facility within
> Eclipse. However all that has happen is that I have been going round in
> circles. I have used search terms such as "adding files to an eclipse
> project" and "adding files to a make file in eclipse", unfortunately
> these have not yielded the answer.
>
> I'm sorry if this seems a repetitive question, but I really cannot find
> the answer anywhere else, despite my best efforts. Could some one please
> direct me to a link that may answer my question, or explain what I am
> doing wrong.

What Russ was trying to tell you by pointing to the sticky post was that
you should ask on the CDT forum group; most of the C/C++ gurus hang out
there instead of in this "newcomers" group.

Eric
Re: Source file not being included in a build [message #643389 is a reply to message #643387] Mon, 06 December 2010 12:19 Go to previous message
Andrew Ellis is currently offline Andrew Ellis
Messages: 7
Registered: December 2010
Junior Member
Ok.

I think I am being a bit dumb, Sorry to be a nuisance.

Andrew
Previous Topic:How extended html Tags
Next Topic:Compare CSV Files as ASCII
Goto Forum:
  


Current Time: Wed Jul 23 10:08:42 EDT 2014

Powered by FUDForum. Page generated in 0.02347 seconds