Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » acceleo run configuration with model outside of workspace
acceleo run configuration with model outside of workspace [message #64370] Mon, 13 July 2009 17:10 Go to next message
Mats Svefors is currently offline Mats Svefors
Messages: 2
Registered: July 2009
Junior Member
I'm trying to setup my run configuration for the acceleo generation. If I
try to use a model that is in a project that is located outside of the
workspace if won't generate any files.

works fine:
<workspace>/foo/bar.uml

but if I wish to have my project in a different location, say perhaps I
want to check it out of version control, it doesn't work fine:
/svn/trunk/foo/bar.uml

Am I doing something wrong or Is this a bug, and is there a workaround?

/Mats Svefors
Re: acceleo run configuration with model outside of workspace [message #64693 is a reply to message #64370] Mon, 20 July 2009 05:13 Go to previous message
Laurent Goubet is currently offline Laurent Goubet
Messages: 1621
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------000301030902000800040102
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8bit

Hi Mats,

Sorry, I overlooked this post :(.

We haven't tried anything to enable the use of models located outside of
the workspace from these launch configurations. I believe we could make
it for models located on disk. Can you raise an enhancement request for
this? The use of repository models (svn, models, http, ...) will most
likely not be supported though.

Laurent Goubet
Obeo

Mats Svefors a
Previous Topic:[Announce] M2T XPAND 0.7.1 is available
Next Topic:Re: OAW to TMF migration: ext allElements migration
Goto Forum:
  


Current Time: Tue Jul 29 19:06:35 EDT 2014

Powered by FUDForum. Page generated in 0.02253 seconds