Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » How to import/install a feature or plugin(Manual install of features and/or plugins)
How to import/install a feature or plugin [message #636009] Thu, 28 October 2010 22:38 Go to next message
Thomas Jung is currently offline Thomas JungFriend
Messages: 5
Registered: October 2010
Junior Member
Hello,

how can I manual install a feature or plugin?

E.g.:

I would like to install the feature:
SmartQVT which should be available here:
http://smartqvt.elibel.tm.fr/
(See: http://en.wikipedia.org/wiki/SmartQVT)
but the site is down.

I have downloaded the jar file available at:

http://topcased-mm.gforge.enseeiht.fr/dependencies/smartqvt- 0.2.1/

Just adding that site to the update-manager doesn't
work. think because there are no site.xml, etc. files

How can I add such a feature to eclipse
which respects dependencies, etc.

Thomas

[Updated on: Thu, 28 October 2010 22:38]

Report message to a moderator

Re: How to import/install a feature or plugin [message #636231 is a reply to message #636009] Fri, 29 October 2010 18:50 Go to previous messageGo to next message
saurav sarkar is currently offline saurav sarkarFriend
Messages: 424
Registered: July 2009
Senior Member
Thomas,

I did not check your link.

But if you get the update site jar which typically has a site.xml, you can add as an local update site archive into the eclipse installation.

Otherwise you can copy the plug-ins into the plug-in folder of the eclipse installation.

cheers,
Saurav


Re: How to import/install a feature or plugin [message #636552 is a reply to message #636009] Mon, 01 November 2010 20:20 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2371
Registered: July 2009
Senior Member
On 10/28/10 6:38 PM, Thomas Jung wrote:
> Hello,
>
> how can I manual install a feature or plugin?
>
> E.g.:
>
> I would like to install the feature:
> SmartQVT which should be available here:
> http://smartqvt.elibel.tm.fr/
> (See: http://en.wikipedia.org/wiki/SmartQVT)
> but the site is down.
>
> I have downloaded the jar file available at:
>
> http://topcased-mm.gforge.enseeiht.fr/dependencies/smartqvt- 0.2.1/
>
> Just adding that site to the update-manager doesn't
> work. think because there are no site.xml, etc. files
>
> How can I add such a feature to eclipse
> which respects dependencies, etc.

You can try placing the plugin JAR(s) into the dropins/ folder in your
Eclipse installation, but seeing how old that plugin appears to be, I'd
guess you'll be luck if it just works. The plugin may specify
dependencies that are no longer compatible with the latest Eclipse versions.

Eric
Previous Topic:enabling mouse wheel scroll in .Xdefaults
Next Topic:No grammar constraints (DTD or XML schema) detected for the document.
Goto Forum:
  


Current Time: Fri Nov 28 06:13:57 GMT 2014

Powered by FUDForum. Page generated in 0.01776 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software