Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Tycho » Building plugins with non-default bundle root location
Building plugins with non-default bundle root location [message #629546] Tue, 28 September 2010 16:14 Go to next message
Kaloyan Raev is currently offline Kaloyan Raev
Messages: 188
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
PDE comes with a new feature in Eclipse 3.6 Helios - the bundle root (the folder that contains the META-INF/MANIFEST.MF file) of a plug-in project can be specified to be any location under the project's root folder. Until then the bundle root location was always equal to the project's root folder.

This setting is persisted in the <project-root>/.settings/org.eclipse.pde.core.prefs file. The preference key is BUNDLE_ROOT_PATH. Here is an example of its content:

#Tue Sep 28 18:27:21 EEST 2010
BUNDLE_ROOT_PATH=WebContent
eclipse.preferences.version=1
manifest.launchShortcuts=org.eclipse.pde.ui.EquinoxLaunchShortcut,org.eclipse.wst.server.launchShortcut
pluginProject.extensions=false
resolve.requirebundle=false

But, if I create such plugin (with bundle root different than the project's root), I can no longer build it with Maven/Tycho. My pom.xml is still in the project's root. I get the following message:

[WARNING] Exception reading bundle manifest: Could not find a META-INF/MANIFEST.MF, plugin.xml or a fragment.xml in ... [cut off]
[ERROR] Internal error: java.lang.NullPointerException -> [Help 1]

This is because META-INF/MANIFEST.MF is no longer under the project's root, but under <project-root>/<bundle-root>/META-INF/MANIFEST.MF.

Is there any configuration for the tycho plugin that I can use for specifying the bundle root of a plugin project?
Re: Building plugins with non-default bundle root location [message #629683 is a reply to message #629546] Wed, 29 September 2010 08:32 Go to previous messageGo to next message
Jan Sievers is currently offline Jan Sievers
Messages: 23
Registered: July 2009
Junior Member
Hi Kaloyan,

this is not supported as of now with tycho.

Does PDE headless build support non-root MANIFEST files also?
If so, I guess you should open a a bug with some details (documentation of
this new feature) and maybe explain the background of your (web bundle?) use
case.

https://issues.sonatype.org/browse/TYCHO

Best Regards
Jan

"Kaloyan Raev" <kaloyan.raev@sap.com> wrote in message
news:i7t448$qpg$1@news.eclipse.org...
> PDE comes with a new feature in Eclipse 3.6 Helios - the bundle root (the
> folder that contains the META-INF/MANIFEST.MF file) of a plug-in project
> can be specified to be any location under the project's root folder. Until
> then the bundle root location was always equal to the project's root
> folder.
> This setting is persisted in the
> <project-root>/.settings/org.eclipse.pde.core.prefs file. The preference
> key is BUNDLE_ROOT_PATH. Here is an example of its content:
>
> #Tue Sep 28 18:27:21 EEST 2010
> BUNDLE_ROOT_PATH=WebContent
> eclipse.preferences.version=1
> manifest.launchShortcuts=org.eclipse.pde.ui.EquinoxLaunchSho rtcut,org.eclipse.wst.server.launchShortcut
> pluginProject.extensions=false
> resolve.requirebundle=false
> But, if I create such plugin (with bundle root different than the
> project's root), I can no longer build it with Maven/Tycho. My pom.xml is
> still in the project's root. I get the following message:
>
> [WARNING] Exception reading bundle manifest: Could not find a
> META-INF/MANIFEST.MF, plugin.xml or a fragment.xml in ... [cut off]
> [ERROR] Internal error: java.lang.NullPointerException -> [Help 1]
> This is because META-INF/MANIFEST.MF is no longer under the project's
> root, but under <project-root>/<bundle-root>/META-INF/MANIFEST.MF.
> Is there any configuration for the tycho plugin that I can use for
> specifying the bundle root of a plugin project?
Re: Building plugins with non-default bundle root location [message #630669 is a reply to message #629546] Mon, 04 October 2010 14:12 Go to previous message
Kaloyan Raev is currently offline Kaloyan Raev
Messages: 188
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Jan, thanks for the reply.

I have submitted the following bug to the Tycho project:
https://issues.sonatype.org/browse/TYCHO-500
Previous Topic:Missing Tycho project page ?!
Next Topic:Compiler Integration
Goto Forum:
  


Current Time: Sat Oct 25 07:16:17 GMT 2014

Powered by FUDForum. Page generated in 0.01631 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software